Menu

Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Show posts Menu

Messages - slarti76

#346
Quote from: menion on January 17, 2018, 10:59:01
@slarti76
uff, quite a serious problem in editor of track, thanks! Problem happen because of editing first trackpoint, hopefully solved.
Great, thx! It just happened to me again and I wanted to add that step 1 (deleting a part at the start) obviously wasn't important - but looks like you found that out yourself :)
I sometimes have the feeling that I'm the most extensive user of the track editor here ;)
#347
Quote from: slarti76 on January 15, 2018, 14:10:22
Sorry, I still don't get it. So 1) the "World Map" has to be vector map, right? Then 2) Where do I get such a map? As you write, the Store World Map does not work - but can't find a hint as to where to find a fitting map.
Ok, forget my question, the map I tried was missing Level 1 - now it works.

However, there's one strange thing: Zooming in/out with two fingers doesn't zoom the map smoothly. If I choose the same map (it's a pixel map) as main map, it zooms smoothly in the same levels. Interestingly, when there are points displayed on the screen, their positions are zoomed smoothly, while the map is only refreshed once I lift my fingers. Looks weird...
#348
Quote from: menion on January 14, 2018, 16:27:29
As I wrote in help desk, currently as a "world map" is considered map, with zoom levels usable for a world map. To simplify it, I've set condition to map with zoom level 1.

@john_percy
world map from Locus Store is old and little bit different system which is completely automatically used for V3 vector maps. It should be anyway in future replaced by this system.
Sorry, I still don't get it. So 1) the "World Map" has to be vector map, right? Then 2) Where do I get such a map? As you write, the Store World Map does not work - but can't find a hint as to where to find a fitting map.
#349
First of all: Happy New Year, everyone, especially Menion! :)
Now yesterday I stumbled over a rather serious bug with the track editor. Import the attached track. The start looks like in Before.png.
Now do this:

  • Modify track
  • Mark point 4 and "Delete all before"
  • "Insert/edit track points" and move the first two or three points a little (see Step3.png)
  • Now select a point further on, e.g. 7, do Insert/edit again and move it just a little.
Now the whole section is jumbled up - After.png.
In step 3 it's important to move at least two points, and beginning with the first point of the track. Otherwise everything is fine.
Granted, very special situation - but with a very bad outcome...
#350
Thx for 1,2 & 4!

Quote from: menion on December 21, 2017, 11:48:34
@slarti76
3. Walking profile was updated with new @poutnik profiles. Are you using Locus internal profiles for routing or some your own or BRouter original profiles? With latest version I see no obvious problem, so please 1. use latest Locus Map, 2. update routing data in BRouter, 3. use internal routing profiles, 4. if problem appear, write here exact start > stop coordinates, thanks.
I re-downloaded newest segment with BRouter and tried again. I'm using the Locus profiles, and I found out that it does depend on the destination: Sometimes the mentioned message is shown, sometimes it takes very long and I stop it with the X.
Here are the coordinates:
Start: N46°46.499' E008°43.293' (Switzerland, near Bristen, Cable car Terminal "Golzeren")
End: N46°47.414' E008°45.346' (Mountain hut "Windgällenhütte")
When using another end point which would be on the way (Bernetsmatt, N46°47.113' E008°44.731'), an orange error message is shown.
Again, when choosing profile Hike, Climb, Cycle, a track is calculated, when using anything with car, the error message is always shown.
Could it be a bug in BRouter (some infinite loop)?

And just a question: Could you change the icons for Walk and Climb? Right now, they are the same as "Hike", although Locus has perfectly fitting icons for all three (as used in the activities) - I think it would make sense to use these.
#351
Quote from: slarti76 on December 21, 2017, 09:27:07
3.Something wrong with BRouter integration: When I try to force him to a track that BRouter doesn't recognize, Locus doesn't display an error message, but the "Wait circle" turns forever. I can't compare this exact location with old version anymore (why do I always have to update all devices at once?), so it might not be new in this version... Is this related to the Release Notes entry "Problem with Locus-based Walk routing in BRouter"?
Just for confirmation: Only happens in the Walk profile (I didn't realize at first, because the icons for Walk, Hike and Climb are the same). I tried a car profile (in the mountains), there I immediately get an error message. The message is a little technical "target island detected for section 0", but I assume it's coming directly from BRouter. Anyway, seems to be something wrong with Walk profile, still.
#352
1.This thread's title is wrong (should be 3.28.+ (20.12.2017))
2.The new popup "Session restored - cancel" after opening the Route planner with an unfinished old session appears for like 2s - hardly enough to hit Cancel if wanted.
3.Something wrong with BRouter integration: When I try to force him to a track that BRouter doesn't recognize, Locus doesn't display an error message, but the "Wait circle" turns forever. I can't compare this exact location with old version anymore (why do I always have to update all devices at once?), so it might not be new in this version... Is this related to the Release Notes entry "Problem with Locus-based Walk routing in BRouter"?
4.I can also confirm that a planned route stays on the map for some seconds after exiting Route Planner.
#353
3.27.1.7: "About App" confirmed working again, thx.
Still problems with waypoints in tracks, posted exact replication here: http://help.locusmap.eu/topic/editing-waypoint-messes-up-chart
#354
Quote from: menion on November 29, 2017, 15:07:41
And still no idea what happen :)
Any way to help with a log, perhaps?
#355
Newest Beta: "About app/Support" still not working...
#356
Quote from: balloni55 on November 26, 2017, 18:43:55
Quote from: menion
@balloni55:
this is interesting. Other options in main menu works? Mainly add-ons and co-apps, that are made with exactly same system.
exactly, behavior is identical on both of my devices
Can confirm that (Galaxy Tab Pro, Android 5.1.1) - "About app/Support" does nothing, all other main menu points seem to be working fine.
#357
Android versions / Re: Test version from GooglePlay
November 22, 2017, 11:38:56
Thanx for that info and the link. Looks like I didn't search the Knowledge Base thoroughly enough... Anyway, I think that answers my questions. Now to some testing :)
#358
Android versions / Re: Test version from GooglePlay
November 22, 2017, 09:25:48
Hi there
I'm new to beta testing. I have Pro and now installed 3.27.1.2 Free. Now I'm confused, because the Beta Version finds some data from the Pro Version, like my database, icons, etc. - but not my settings. They were obviously all the defaults.
Are they stored somewhere else? I'm sure that would make sense, as a new version might have settings that could confuse an old version. Is there anything else I should avoid in order not to destroy my Pro installation?
Sorry if that has been asked before, but didn't find anything with the search and also on knowledge base.
#359
Quote from: tapio on November 13, 2017, 10:57:28
New Version as of today: rename exising track still impossible.
Weird, for me it's ok now...
#360
Serious bug in 3.27: Cannot save track descriptions
http://help.locusmap.eu/topic/cannot-save-track-description