[APP] - version 4.0.+ ( 30. 3. 2021 )

Started by Menion, March 30, 2021, 07:22:08

0 Members and 1 Guest are viewing this topic.


I have a strange issue with the Gold app.

2 days ago I created a track using the web planner. Yesterday I was out for cycling and tried to sync my mobile phone and get that track. It didn't work. It took ages for the sync process even though I had excellent connection and besides that one track everything was up to date. After a while the sync function always said "congratulations" but that track never appeared in the app.

So I opened the browser on my phone and checked the web planner. The track was there. I downloaded the gpx file (export.gpx was the name) and tried to import it manually into locus. It was impossible. The app was frozen and crashed after a few seconds. I tried it several times. Always the same problem.
Then I opened komoot and imported the export.gpx and exported from komoot to my phone in order to manually import another file into locus. It didn't work. The app crashed as described before.
Furthermore all my tracks were gone. There was no nothing left.
I ignored locus for a while. After that my "old" tracks were there again. The sync still didn't work. I didn't get the latest track from the web planner.

Today I read that there is version 4.02.
I installed it and tried to sync again. It says congratulations but the track does not appear on my phone.

What is the problem and what to do?


So the core sync problem fixed, perfect, thanks guys!

Beta version
damn, this is really complicated task now  :). Andrew, I probably see your crash in auto reporting system. Seems two users already have this problem. Reason? You probably set the bottom panel to full auto-hide and 4.0.2 does not know this option = crash  :-\.

Solution? New Beta!!  ;D

Link in the first post or here: http://bit.ly/lmVersionsTest

ah vacation. I've almost forget.
Is there anywhere existing topic on the help desk? Can find any. I would like to add it to my to-do list.

interesting problem. May you please do just a tiny modification on the web, like change any letter in the track name? Because it is possible that because of the bug in 4.0.1, the track is marked as correctly synced, but it isn't. Sorry for this.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download



I changed the track name (a bit), synced again and it worked. The track now is also on my phone.
Thanks for the help


Point screen does not close anymore by wiping down.
This feature was still present in the beta (before 4.0.0) and in the RC2.
The new track screen will work.
In official version 4.0.2 it is not synonymous.
Xiaomi Redmi Note 10 Pro, Android 13
Locus Map 4 Gold (always latest version)
LM4 User-ID: 64fc904a8  (Devices-ID)
    The following users thanked this post: balloni55


Thanks, I now created a helpdesk entry. https://help.locusmap.eu/topic/24119-distance-from-current-position-to-selected-point-on-track

Quote from: Menion on April 10, 2021, 11:58:23Is there anywhere existing topic on the help desk? Can find any. I would like to add it to my to-do list.

BTW the beta says "Test version expired" at start. But it seems to be the full subscription related version.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download


The waypoints listing looks rather useless 😁
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download


New beta:

@Track details:
Great, loving it! Finally one-click track profile!

Minor observation: I had automatic sync turned off for a while (during beta phase and in my holidays, I didn't trust it enough). Now I turned it on on two devices. By chance, one of them had two new tracks. But they weren't synced after turning auto on on both. A later change however got synced immediately.
I think, turning on Auto-sync should trigger one background sync immediately.

Look at the screenshots: The map shading in level 12 is visibly more detailed than in level 13.
I think we talked about this a while ago, Menion, I remember it was intentional for performance reasons, but I thought I convinced you to change it, or didn't I? ;) For one thing, even with my slower outdoor phone (XCover Pro), it doesn't seem to slow down map painting much. And for another, it may be more detail, but the map area for which it is shown is also 1/4, so that balances itself out.
It's not only aestethic, you also lose valuable information, e.g. for slopes > 30° in winter. If you don't want to change the default, perhaps an Expert Setting? At least the user should be able to override performance-based defaults...


    Few more things about the new track details:

    • Thx for making the description selectable & copyable, as I asked for! :) While you're at it, why not make the title selectable, too?
    • As has been noted above, simply having the waypoint icons there is, well, not so helpful. Tapping them should at least show their name, or even center them on screen.
    • Also as noted above, wouldn't mind the description below the title. To save space without the header "Description", and perhaps only max. 2 lines, with a clickable "<more>" to expand if longer
    • Some customization would be nice - I for example would like to slim it down by removing "Best interval"
    • The crossing lines for the "current point" are nice to better gues the values - but why not display the actual values directly, too: "432m / 6.1km".
    • I know, the left-most button takes you directly to the current trackpoint - but there should be the opposite, taking you back to the track.
    Just my 2 cents - probably you already have some of those things in mind...


Major sync error!

I'm afraid syncing is still not to be trusted. :( But I can tell you exactly what happened:
As mentioned above, I turned on auto-sync for my phone and tab, let's say device A and B. At the start, both were in sync. Now I edited two tracks on A. I waited a minute or so to let auto-sync do its magic. When I checked again, both tracks were deleted on B! The "Last Update" dialog showed "pullDelete: 2".
And now the kicker: On A, both tracks were still there, but the "Last Update" dialog showed "pushDelete: 2"!!!
Turned off auto-sync on A and B as quickly as possible and restarted Locus on A, just to be sure. And yeah, both tracks were still there.
A "Compute Plan" on A now showed "pullDelete: 2" and "pushDelete: 2". No idea what deletions it wants to push again, but I certainly don't want to pull those wrong deletions.
Anyway, I exported both tracks as GPX and did a manual sync. That worked, but coming back from sync dialog, Locus crashed. After restart, tracks were still there, "Last Update" showed "pullDelete: 2" (but "pushDelete: 0"). Well, tracks were displayed, but clicking them crashes Locus.

Now the next (seemingly better) surprise: Manual sync on B suddenly downloaded the tracks again! Another sync again downloaded both tracks, now finally "Compute plan" showed zeroes everywhere.
Back on A, the next sync also showed "pull: 2" and seemed to download two tracks.

But on both devices, tapping the tracks still crashed Locus reproducibly. So I had no choice but to finally delete the tracks and import the GPX (on A). That worked, tracks could be tapped again. Next sync to B, and finally everything is coming up roses: both tracks are there and clickable, on both devices.

Certainly I'm leaving off auto-sync for now and checking with "Compute Plan" before every sync. But you'll probably admit that that can't be the solution.
The main question obviously is: Why did an edit lead to "pushDelete"?


Concerning new track screen:

Would it be possible to lock the up/down movement of the track screen as soon as someone starts swiping the elevation diagram left/right?

Because when you start swiping and then accidentally move just a little too much up or down, the wiping functionality stops immediately and instead the track screen moves up or down.

Andrew Heard

Quote from: Menion on April 10, 2021, 11:58:23
Beta version
damn, this is really complicated task now  :). Andrew, I probably see your crash in auto reporting system. Seems two users already have this problem. Reason? You probably set the bottom panel to full auto-hide and 4.0.2 does not know this option = crash  :-\.
@Menion - damn me too - didn't see your suggestion in time - I uninstalled 4.0.2 & reinstalled Oh well. - fixed - thanks.

new suggestion in settings > Search: color scheme for search textbox is hard to see - black text on grey background - see attached

and when displayed is turned off > on, refresh returns to previous settings screen, so search is lost.
LM4.20.0.0 GOLD user ID:c7d47597a


The vertical allignment of text (waypoints) in the multiple items menu has always been funny, see screenshot. Because of the symbol I guess.
If wanted I can created a helpdesk entry later.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download


As for the track screen AND if I am navigating the track... I wish for more nav related information, like

distance from current position until selection
distance to end/from start (cur. selection)
pos elev todo... to end/from start (cur. selection)
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download


The right arrows are a bit confusing, feel like "next track" etc... has always been confusing IMO, aren't there better symbols?
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download


When I switch to the trackpoint view via the bottom left icon, there should, at the same place, be a possibility to return back to track view. Currently, there is no way back.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download