Locus Store

Started by jusc, March 06, 2015, 16:43:34

0 Members and 1 Guest are viewing this topic.

syni

Every time I try to go to Locus Store, I get an error message:

Unknown Problem

AuthenticatorException,
android.accounts.AuthenticatorException:
NetworkError
Error code:11304

I am using 3.18.2 on Android 5.02

Hope somebody can help?!

Best Regards


  •  

sbouju

#106
After the purchase of France South LoMaps, the cartography was not available via the LocusMap normal menu.
Then,I founded the two files (*), and they were stored not in the "france" folder, but just above, in the "europe" folder...
Finally, all became OK after a cut and paste of the two files to the france folder...

(*) _france_south.osm.db (305 Mo)   and   _france_south.osm.map (1,14 Go)
  •  

Menion

#107
Quote from: syni on July 01, 2016, 14:33:13
Every time I try to go to Locus Store, I get an error message:
Unknown Problem
AuthenticatorException,
android.accounts.AuthenticatorException:
NetworkError
Error code:11304

Hello syni,

I'm checking Locus source code and this error may happen in case, Locus has a problem with validation of your credentials. I remember that this issue rarely happen and usually helped restart device or remove/add account in Android "Accounts" settings directly in your device. Of course I expect that you have a perfectly working internet connection, which may otherwise cause also this problem. May you please try mentioned options? And sorry for a complications.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

john_percy

Is that not the same error I got with no internet connection?
  •  

Menion

Yep same error code if I remember correctly, but it does not means it's same problem.

Problem here is that Locus use method included in Android device and if this method fail, it just return some undefined error > and Locus display this message. So there may be more reasons, not just problematic internet connection.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Sersus2

Yes, Locus Store doesnt work when I try to purchase the coins. It returns "Error, try again" every time after entering (correct) password of my Google account.
Sometimes Locus crashes with error during this operation.
  •  

Menion

Good day Sersus2,

I'm sorry to say this, but it will be little bit complicated here. Mainly because it looks for me as it is not a problem with Locus itself, but with a In-app billing system in Google Play application.

Firstly, are you able to create a screenshot with mentioned error message, so I may exactly see how it looks and where it appear?

And also, are you able to create a log right after Locus Map crash, with this method http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log ? It should help find out reason why Locus crash, thank you and sorry for a complications!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Sersus2

I've just created a bug report and sent it to your "locus.map@" email from my google account "mrbaxmypka".
Temporary I can't attach the screenshot but I can do it some later if you need it.
  •  

balloni55

Hello Petr,
since now theme HiLo is available on locus store :)
- inside store  is no version info
- also on device file manager
please make version visible
https://postimg.org/image/7vsery2kn/
on theme tab it´s named "HiLO V6" :D

Question:
is it possible to open a request window "delete old version" while user update to a  new theme version?

Wolfgang
Locus Map Classic 3.63.0 AFA
Locus Map 4.12.0 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

voldapet

Hi,
- you should be able to see version of theme in Locus store ( under images is row "version").

You're right, every version is downloaded to the same location: locus/_themes/hilo. I can not see any reason why should the location of theme respect the version of theme. It's the same as updates of map files.
The request "delete old version" does not make sense from my point of view. For example old version of any application is deleted when you update to the newest one, old map file is also deleted. Why should theme have different behaviour?

Petr
  •  

balloni55

Hi Petr
ok,  version of theme is there visible, thanks

QuoteWhy should theme have different behaviour?

thats ok ;) and this is what i´ve expected
and now it´s clear for me V4 and V5 where installed/copied manually to  e.g.   _themes/HiLo_V4
so they arn´t recognized and automatically overwritten.
Thanks for clarification
Locus Map Classic 3.63.0 AFA
Locus Map 4.12.0 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

voldapet

I can understand that for testing or some playing with themes isn't mentioned "store solution" useful. But I hope that it's the best behaviour for almost all users that only want to download/update theme
Thanks for understanding
  •  

zuku

Hi,
I use locus version 3.14.2 (and don't want upgrade because this is the last version which allow to use online maps)
and I would to purchase shocart cycling map, but during map download I get error code 83, is any way to fix this?
  •  

gynta

#118
http://help.locusmap.eu/topic/st%C3%A1hnuti-online-mapy

helpful?
...unfortunately i can't read this funny language  ;D

poutnikl

Quote from: gynta on September 05, 2016, 12:55:52
http://help.locusmap.eu/topic/st%C3%A1hnuti-online-mapy

helpful?
...unfortunately i can't read this funny language  ;D

It is the native language of Menion and the Assam company, so be careful.. ;D