Locus Map 4, discussion (alpha)

Started by Menion, December 06, 2019, 14:57:45

0 Members and 28 Guests are viewing this topic.

Menion

The same happens to one of my colleagues. It was most probably caused by an accidental tap on this feature in the menu > more. I'll improve this by preventing using zoom lock & magnifier directly from the menu > more. Next version, you will see. Thanks.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Andrew Heard

#736
Quote from: Menion on November 19, 2020, 09:08:28
thanks for the backup, problem found and solved.
@Menion - do you mean my reported problem with duplicated points/ tracks/ folders/ groups was fixed? Great if so.

Today I did a new manual Sync. The process was fast, maybe 30s, and I see no duplication. Phew.

So I installed LM4 on a tablet. This device did not have LM3 installed. I copied an OSM map into mapsVector folder. I assumed I would then be able to restore settings via a settings ZIP from my phone and Sync the points/ tracks/ folders/ groups. Instead I am locked out of LM4 with the attached screen cap "tablet.jpeg".

Separately out  of curiosity on the working phone LM4 I tapped BRouter Updater but also got an error msg in screen cap "brouter.jpeg".
LM4.23.1 GOLD user ID:c7d47597a
  •  

Menion

@Andrew Heard
ah no, solved is a problem with the "one-click to toggle panels", where you backup helped. The problem with duplicates in sync unfortunately remains a big unsolved mystery for us  ???

Tablet problem: and this happens during/after restore of data after sync?

BRouter updater: sorry, there were still some weird issues. I've already solved this but not yet published an update. Hopefully today!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Andrew Heard

#738
Quote from: Menion on November 26, 2020, 08:34:41
Tablet problem: and this happens during/after restore of data after sync?
@Menion - my sequence:

  • fresh install of LM4 on tablet (no other Locus installed)
  • run LM4
  • map with loading tiles is displayed then quickly...
  • full screen with code 11556 is displayed but in less than 1s...
  • next full screen with 3 options: 1) close/restart 2) restore 3) info, is displayed
  • if I tap close then the previous screen with code 11556 is briefly displayed then LM4 closes
  • if I tap restore then the screen with code 11556 is displayed, I tap close twice to exit (no other option)
LM3 free & pro have both previously worked on this tablet but are not currently installed. My only thought is that a while back I inserted a 16GB SD card, and Android 7.1.1 offered to move all apps & data from the internal flash onto this new card. For one other app I had to reinstall because it would not save settings. LM4 was installed after the new SD card was inserted, so maybe unrelated.

So, no opportunity to sync (restore) or do anything because I'm locked out of LM4. Shall I send a log directly after the close?

LM4.23.1 GOLD user ID:c7d47597a
  •  

Menion

This most probably won't be related to LM4. When you install LM Free/Pro, the result will be most probably the same.

Is the Locus Map directory in the internal memory? If so, all should work correctly so this may only mean really some problem with DB.
The best should be to rename Locus/data/database to something like Locus/data/database-backup. Start the app and try sync, it should work. If all went well, you may send me your backup database directory, maybe there is any issue with it I may fix in the app. Thanks
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download

Andrew Heard

Quote from: Menion on November 27, 2020, 06:57:46
Is the Locus Map directory in the internal memory?
@Menion - yes

Quote from: Menion on November 27, 2020, 06:57:46
The best should be to rename Locus/data/database to something like Locus/data/database-backup.
thanks, that worked; I assume LM4 was confused because there was an old LM3 /data/* still there, even though LM3 was uninstalled?

Quote from: Menion on November 27, 2020, 06:57:46
Start the app and try sync, it should work.
It worked a treat. Sync took ~15 minutes. All good now, thanks.
LM4.23.1 GOLD user ID:c7d47597a
  •  

Menion

Problem is that it should not be confused. The app should be able to re-use the old database without any problem ... this makes me worry a little bit. If you have no serious problem to share your not-working "database" folder with me, it will be more than welcome. There has to be any problem in the structure of DB most probably caused by Locus Map itself. Thanks
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Menion

New version 3.49.1.4 just uploaded to Google Drive.

News after app start, as usual.

Have a nice weekend!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  
    The following users thanked this post: Tapio

Tapio

Thx, testing brouter segment download. Very tiring. I need 4 segments. e5_n50 is missing btw. It exists on http://brouter.de/brouter/segments4/

It tends to select all, e. g. when going to another app and return to Locus. Have to deselect 1 by 1.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •  

balloni55

Hello menion
thanks for new version :)

# 964 solved :)

enter coords to a waypoint with 0.00 coords isn´t possible > screencast
https://www.dropbox.com/s/nv8ew79eib6szgx/can%C2%B4t%20add%20koords.mp4?dl=0

after update of a cache which was "temporary disabeled" and is now enabeled, icon is displayed well but text is furthermore crossed out till i reopen it
Locus Map 4.23.1.1 Gold AFA

LM4 User ID e06d572d4
  •  

balloni55

#745
after todays update of LM4 there is a problem inside LMP displaying POI´s/Geocaches on map althought they are marked as visible in the POI tab :-[
https://www.dropbox.com/s/euq6soswhb7cz61/POI%20problem.mp4?dl=0

Restart of device and LMP didn´t help

EDIT:
if i try to open one of these marked caches >  locus FC
Log just send ;)
Locus Map 4.23.1.1 Gold AFA

LM4 User ID e06d572d4
  •  

Andrew Heard

#746
Quote from: Menion on November 27, 2020, 12:01:35
If you have no serious problem to share your not-working "database" folder with me, it will be more than welcome.
@menion - /data/database/track.db is 164MB. Do you want it or could I ideally just ZIP the remainder of /data/database/* to save upload time?

3.49.1.4 - menu > More - nice. But why is "Quick action menu" listed with "Beta - testing"? It's been around for years.

3.49.1.4 - BRouter Updater download now working. Do you plan to have Minimize button similar to Sync so that operation can continue in background, then view progress via notifications?

This comment is not directly related to LM4, but when you select Backup manager > Restore, the initial File browser directory is the root of the internal file system, which seems an odd place to be placed. I then select the "Internal storage" directory. Would this be a better default?

Regards manual Cloud Sync: would it be possible to display summary of sync operations that will be performed for confirmation before proceeding further? When I see a brief message "deleting points" or "deleting tracks" with no mention of what, I get concerned. Maybe the summary could list the points & tracks which will be sync'd & whether the action is new, update or delete. I just did a manual Sync of (slave) tablet data; it appears to have performed fast & correctly. AFAIK anyway ;-)

PS. Quick settings don't appear to be backed up or restored. I did a settings backup from (master) phone which has a Quick settings panel. I did a settings restore to (slave) tablet & Quick settings appear to be the defaults. Could Quick settings > Change have the same nice new structure that Menu > More has? Or even a search field.
LM4.23.1 GOLD user ID:c7d47597a
  •  

john_percy

@Menion What means "Duplicate folder" in red in the About screen in Locus 4?
Red means something wrong?
Folder is Android system one, isn't it?


Sent from my moto g(6) plus using Tapatalk

Voluntary and Velocity themes - https://voluntary.nichesite.org
  •  

Tapio

I cannot configure which geotagged photos are to be shown currently. I use them a lot.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •  

Tapio

#749
Serious issue, I reported before, still present.
AFTER MOVING AN EMBEDDED WAYPOINT IT IS DELETED FROM THE TRACK. Hide/show track and wp is gone.  :(

I do it post-hiking, manual correction of some automatically added poi.

EDIT: I think I am wrong here. WP was not deleted. But the new position is only shown after hide/show of track.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •