[APP] - version 1.8.x

Started by Menion, May 19, 2011, 15:17:56

0 Members and 1 Guest are viewing this topic.


I've cleard my error logs yesterday and today I have a about 10 new .err files in the folder. All filled with the same error message.

----------  1 jul. 2011 07:57:12  ----------
MSG:run() - while (!requests.isEmpty())
   at org.mapsforge.android.maps.az.i(L:1799)
   at menion.android.maps.n.a(L:78)
   at menion.android.maps.d.d.run(L:282)
   at java.lang.Thread.run(Thread.java:1102)

This about 25 times with the same timestamp (1 second). My whole log folder is floooded with files  ;)

Using vector maps of Netherlands and Czech Republic from this thread (message with both maps) in latest Locus Pro market version as well as todays Locus


I know about this, have to disable error logging for this :)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download


Quote from: "menion"thanks guys (berkley also for email) ... should be fixed in last testing version

No FC's so far, well done ;)
Search before posting!!!
XDA Orbit, HTC Touch HD, SGS1, SGS2, Nexus S, S4 Active, OnePlus One, Innos D6000
OnePlus X


The intermittent FCs have gone for me too, but I have found another problem. I tried a recording. Starting the recording from the widget worked fine. When I stopped it I got the expected "save" screen, changed the name, and selected OK. But now if I try to start Locus Free it shows the same save screen again (with the exact same default name with the same time in it, so it's not a new track). So I saved the track a second time. When I did that I briefly got a recording notification, and then Locus Free exited (no error messages, just an exit). If I look in Locus Pro, the first track is correct, but the second one has a time of 0h:0m:0s and a distance of 0m. I then tried going into Locus Free again, but I got the same save screen again! So I saved the track a third time, got the same brief recording notification, Locus Free exited, but this time no track was saved at all. After that, every time I started Locus Free I got the same thing. If I select "Cancel" instead of "OK". Locus Free also exits.

Next I started a new recording from the widget. It started recording fine (which surprised me a bit - I was expecting it to do something bad at this point!). When I stopped the recording it saved fine, as before (with a new default name, so it's now a new track). Then I could exactly repeat the sequence above, except that I managed to get it to save two additional 0h:0m:0s tracks rather than only one.


I had the crash too, in the previous version, but I don't see the problem rijackson741 describes. Just came back from a small drive, used the widget to record, pause and stop. Afterwards Locus Free opens normally, without problems.

One thing I noticed, it seemed to switch off the GPS when pressing pause on the widget - but I have the "Keep GPS on when paused" switched on.

Another difference is that you see the track on the map after (auto-)saving when recording in Locus. After pressing stop in the widget the track is not displayed. Not a problem, just a small difference in behaviour :-)



I just rebooted the phone and tried again. Same thing, except that this time I manged to save many 0h:0m:0s tracks.

Also, if I turn off the GPS in system settings and then try to record using the widget I get a FC. After that the widget is dead.


I have figured out what is going on. I do not have Locus Free on my home screen, only Locus Pro. But since I knew I had run Locus Free earlier, after recording I selected it from the recent apps list (an act of laziness!). If I do that I always get the track save screen again. If I go to the actual Locus Free app and select that, Locus Free opens fine. After I have done that the icon in recent apps of course opens Locus Free normally again.

So Locus Free now has a split personality  :D


Has someone generated Vector Maps for Spain ?.

regards frodo


Untested (as usual :-) ): //http://berck.se/maps/spain.osm.map



MapsForge has released new version 0.2.4  8-)  Have you already used the new mapfile-writer? Would be interesting, if the created maps are different to the 0.2.3 version...  ;)  I'm just loading a 0.2.4 map from their server...  :)


No, haven't tried that yet, will do!


It's certenly not the first time your will hear that but i really hope Locus will one day come to iOs.

It's for me, even in it's actual version, the best GPS/Mapping app ever made. Yes it's not perfect, but it's very complete and absolutely awsome.