Mapsforge 0.5

Started by fzk, December 05, 2014, 13:48:26

0 Members and 1 Guest are viewing this topic.

balloni55

QuoteIf the icon is missing maybe you haven't copied the "ele_res" when you were moving it manually to the external sd card.
sorry for trouble :-[ you are right !
thanks, now it works as expected :)
LMC 3.70.1 AFA
Locus Map 4.20.0 Gold AFA
LMC User ID c8b19276f
LM4 User ID e06d572d4
  •  

Tobias

I got some error reports with the theme chooser. If you use map > offline > details, and hit the theme for a second time here, the mapstyle/overlay menu pops up only for a very short time. It's not the case via the button in the panel or via settings > maps advanced.
developer of Elevate mapstyle for OpenAndroMaps
  •  

Menion

Ah you are right, thanks. I'll have to change this a little bit (select map and move user to selector on main screen).
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

fzk

Hmm ... after reading through this long thread I would like to reflect some of my impressions. I don't believe that your strategy concerning mapsforge 0.5 is right. Why not supporting two libraries? The old one (locus mapsforge 0.3) for backward compatibility and the new one (standard mapsforge 0.5) for up-to-date maps and themes? The current strategy to implement only a few new features into the old lib is neither fish, nor flesh.

Regards Klaus
  •  

Menion

Hello Klaus, please compare speed of MapsForge 0.5 in any of existing app with MapsForge implementation in Locus. Are they same?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

jusc

@fzk,

which features are you missing with Locus? As I can see, the most improvements  are still not implemented in mapsforge libraries.
Sure, for theme developers it would be a bit easier to develop themes for all apps, but why should the Locus team not use their own improvements?
Regards J.
  •  

fzk

#96
The main problem is compatibility! My requirement is very simple: If someone creates a map (map data + theme) for mapsforge 0.5, this map should be used in every app with mapsforge 0.5 support. That isn't the case for Locus and that's the point.

Here is an example: There was a very old glitch concerning the width of the casing (only half of the casing was printed). The fix lead to the problem, that a map in Locus (without the fix) looks different. Other areas of incompatibility are:
- SVG: handling and scaling different
- DPI: no resolution adaptation

Here are two screenshots, one from Locus and the other from a standard mapsforge 0.5 app, from the same area with the same zoom level:





Regards Klaus

PS: Please don't misunderstand me. I love Locus which is my preferred app. I own three pro licenses just in order to support the project. My hope is, that in one or two years Locus is still my preferred app. But currently I'm not sure about this ... I believe that Locus is moving in a wrong direction.
  •  

Menion

Understand, and thanks for financial support of course!

Anyway Locus officially do not support new version of MapsForge, that is all. I never wrote it is supported and hope I do not promised, it will be supported. Around two years before wasn't sure, if MapsForge will continue or not. And instead of waiting till something happen, I started to modify this library to exactly match to Locus system.

And wrong direction because I highly optimized older MapsForge library to better fit Locus requirements and because I do not wants to include a third MapsForge library into Locus at once and allow users to choose which they wants to use?

Sorry, but I still prefer speed and optimizations before perfect support of latest "standards". I understand, it complicates work on themes etc. Anyway just take Locus as only supporting MapsForge v. 0.3, nothing more for now.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

jusc

@fzk
Maybe I donĀ“t understand correctly what yo mean. But Locus improvements were usefull long time before Mapsforge version 0.5 was out.
And what are the other apps using Mapsforge? Only OruxMaps, Cruiser beta (from member of mapsforge) ore more?
Specially scaling icons and fonts with Locus is very usefull.

And on the other side, with your map, the Freizeitkarte, you go your own way too with all the (to German) translated tags. A time ago I tried to implement these tags into my theme, for using your map too, But I gave it up, because of to hard work (for me).  ;)
Regards J.
  •  

fzk

Quote from: menion on June 15, 2015, 11:53:32
And wrong direction because ... I do not wants to include a third MapsForge library into Locus at once and allow users to choose which they wants to use?

... exactly, that's the point.

Klaus
  •  

gynta

Quote from: fzk on June 15, 2015, 11:04:27
Here are two screenshots, one from Locus and the other from a standard mapsforge 0.5 app, from the same area with the same zoom level
Are you sure?
And what was the "standard mapsforge 0.5 app"?

fzk

Quote from: gynta on June 16, 2015, 22:48:41
Quote from: fzk on June 15, 2015, 11:04:27
Here are two screenshots, one from Locus and the other from a standard mapsforge 0.5 app, from the same area with the same zoom level
Are you sure?
And what was the "standard mapsforge 0.5 app"?
Yes, it's in both cases the same zoom level (housenumbers are only displayed only in ZL 18). The first screenshot was taken from "Cruiser beta" (Mapsforge 0.5) and the second (the smaller one) from "Locus Pro". Both screenshot are made on a tablet (Galaxy Tab S 10.5, 2.560x1.600 pixel) from the same map and theme. What I wanted to show: 1. Cruiser has an automatic DPI adaptation, Locus hasn't. Cruiser has a fix concerning the width of the casing (see the houses), Locus hasn't. Both effects are resulting in different looking maps.

Klaus
  •  

john_percy

What theme were you using? And was it identical for the two apps?
Voluntary and Velocity themes - https://voluntary.nichesite.org
  •  

fzk

  •  

Menion

FZK sorry, but I have to say that 0.5 version is really not planned. You still do not answered to my question about compare of speed rendering mainly at high zoom levels. Anyway I believe that adding support for some features included in 0.5 is the way I wants to go, even a slower and more painful.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •