Mapsource von Google Sat gesucht

Started by franc, October 23, 2013, 22:45:45

0 Members and 1 Guest are viewing this topic.

franc

Hallo

kennt jemand die aktuell funktionierende mapsource (xml) für die Satellitenansicht von Google?

Ich finde nur die für die Maps.

Danke.

franc
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •  

john_percy

  •  

ch3ch2o6

#2
Hallo !
Ändere diese 2 Zeilen:

<url><![CDATA[http://khm{$serverpart}.google.com/kh/v=138&src=app&x={$x}&y={$y}&z={$z}]]></url>
   <serverParts>0 1 2 3</serverParts>
  •  

franc

#3
Quote from: ch3ch2o6 on October 24, 2013, 09:33:55
...<url><![CDATA[http://khm{$serverpart}.google.com/kh/v=138&src=app&x={$x}&y={$y}&z={$z}]]></url>
   <serverParts>0 1 2 3</serverParts>
Funktioniert!
Danke!
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •  

franc

Verstehe ich das jetzt richtig: MapTweaks (die App) ändert oder setzt nur die Datei providers.xml?

In:

/Locus/mapsOnline/custom/

Und das Format ist das selbe wie in MOBAC?

Gruß franc
Locus Pro - always the actual version on Xiaomi Mi A1 mit Android 9
  •  

john_percy

Quote from: franc on October 25, 2013, 22:20:30
Verstehe ich das jetzt richtig: MapTweaks (die App) ändert oder setzt nur die Datei providers.xml?
In:
/Locus/mapsOnline/custom/
Ja  :)
  •  

RalfHN

Ich versuche gerade wieder bei meiner providers.xml Google satellites zum Laufen zu bringen. Leider funktioniert es nicht. Hier meine XML-Daten. Kann mir jemand helfen und sagen was falsch ist.

Viele Gruesse

Ralf



<provider id="10021" type="0" visible="true" background="-1">
      <name>Google</name>
      <mode>Satellite</mode>
      <area></area>
      <url><![CDATA[http://khm{$serverpart}.google.com/kh/v=138&src=app&x={$x}&y={$y}&z={$z}]]></url>
         <serverParts>0 1 2 3</serverParts>
      <zoomPart>{z}-8</zoomPart>
      <zoomMin>8</zoomMin>
      <zoomMax>28</zoomMax>
      <tileSize>256</tileSize>
      <attribution><![CDATA[(c)2011 Google - Map data (c)2011 Tele Atlas]]></attribution>
      <extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1]]></extraHeader>
      <extraHeader><![CDATA[Referer#http://maps.google.com/]]></extraHeader>
   </provider>
  •  

Menion

sorry for English

two possible problems:

1) ID of map is not unique. It has to be unique, so if you have also other maps already defined, check if is
2) serverPart should looks like <serverPart>0;1;2;3</serverPart> - so not "serverPartS" and not separated with spaces
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

RalfHN

#8
Thanks, I tried with your change but dosn't work. 10021 is unique. Here the complete Google XML. Everything, except Google satellite works.

   <!-- GOOGLE maps -->
   <provider id="10020" type="0" visible="true" background="-1">
      <name>Google</name>
      <mode>Classic</mode>
      <area></area>
      <url><![CDATA[http://mt{s}.google.com/vt/lyrs=m@207000000&hl=en&x={x}&y={y}&z={z}]]></url>
      <serverPart>0;1</serverPart>
      <zoomPart>{z}-8</zoomPart>
      <zoomMin>8</zoomMin>
      <zoomMax>27</zoomMax>
      <tileSize>256</tileSize>
      <attribution><![CDATA[(c)2011 Google - Map data (c)2011 Tele Atlas]]></attribution>
      <extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1]]></extraHeader>
      <extraHeader><![CDATA[Referer#http://maps.google.com/]]></extraHeader>
   </provider>
   <provider id="10021" type="0" visible="true" background="-1">
      <name>Google</name>
      <mode>Satellite</mode>
      <area></area>
      <url><![CDATA[http://khm{$serverpart}.google.com/kh/v=138&src=app&x={$x}&y={$y}&z={$z}]]></url>
         <serverPart>0;1;2;3</serverPart>
      <zoomPart>{z}-8</zoomPart>
      <zoomMin>8</zoomMin>
      <zoomMax>28</zoomMax>
      <tileSize>256</tileSize>
      <attribution><![CDATA[(c)2011 Google - Map data (c)2011 Tele Atlas]]></attribution>
      <extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1]]></extraHeader>
      <extraHeader><![CDATA[Referer#http://maps.google.com/]]></extraHeader>
   </provider>
   <provider id="10022" type="0" visible="true" background="-1">
      <name>Google</name>
      <mode>Hybrid</mode>
      <area></area>
      <url><![CDATA[http://mt{s}.google.com/vt/lyrs=y&x={x}&y={y}&z={z}]]></url>
      <serverPart>0;1</serverPart>
      <zoomPart>{z}-8</zoomPart>
      <zoomMin>8</zoomMin>
      <zoomMax>28</zoomMax>
      <tileSize>256</tileSize>
      <attribution><![CDATA[(c)2011 Google - Map data (c)2011 Tele Atlas]]></attribution>
      <extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1]]></extraHeader>
      <extraHeader><![CDATA[Referer#http://maps.google.com/]]></extraHeader>
   </provider>
   <provider id="10023" type="0" visible="true" background="-1">
      <name>Google</name>
      <mode>Terrain</mode>
      <area></area>
      <url><![CDATA[http://mt{s}.google.com/vt/lyrs=t@130,r@207000000&hl=en&src=api&x={x}&y={y}&z={z}]]></url>
      <serverPart>0;1</serverPart>
      <zoomPart>{z}-8</zoomPart>
      <zoomMin>8</zoomMin>
      <zoomMax>23</zoomMax>
      <tileSize>256</tileSize>
      <attribution><![CDATA[(c)2011 Google - Map data (c)2011 Tele Atlas]]></attribution>
      <extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1]]></extraHeader>
      <extraHeader><![CDATA[Referer#http://maps.google.com/]]></extraHeader>
   </provider>

edit
I do some test again. It works, but only for overview. If I zoom in there is the message connection failure.
  •  

gynta

<provider id="10021" type="0" visible="true" background="-1">
<name>Google</name>
<mode>Satellite</mode>
<url><![CDATA[http://khm{s}.google.com/kh/v=142&src=app&hl=en&x={x}&y={y}&z={z}]]></url>
<serverPart>0;1</serverPart>
<zoomPart>{z}-8</zoomPart>
<zoomMin>8</zoomMin>
<zoomMax>28</zoomMax>
<tileSize>256</tileSize>
<countries>World</countries>
</provider>

works here

RalfHN

Thank you,

    <provider id="10021" type="0" visible="true" background="-1">
        <name>Google</name>
        <mode>Satellite</mode>
        <url><![CDATA[http://khm{s}.google.com/kh/v=142&src=app&hl=en&x={x}&y={y}&z={z}]]></url>
        <serverPart>0;1</serverPart>
        <zoomPart>{z}-8</zoomPart>
        <zoomMin>8</zoomMin>
        <zoomMax>28</zoomMax>
        <tileSize>256</tileSize>
        <countries>World</countries>
        <attribution><![CDATA[(c)2011 Google - Map data (c)2011 Tele Atlas]]></attribution>
        <extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1]]></extraHeader>
        <extraHeader><![CDATA[Referer#http://maps.google.com/]]></extraHeader>
    </provider>

Now it works.
  •