New OSM tiles Tracetrack won't work in Locus

Started by axelpix, November 01, 2023, 10:22:06

0 Members and 1 Guest are viewing this topic.


There's a new OSM style called Tracetrack. One need to create an API key in order to get it work. On they obviously have an issue with their referer settings. So Tracetrack is not shown there currently.
Anyway, I quickly created a key and I'm able to view tiles with it:

Trying to see it in LocusMap fails with an unknown error. So what's wrong with my providers code:

<provider id="10014" type="0" visible="true" background="-1">
<mode>Tracetrack Topo DE</mode>
<tileScale dpi="0" multi="2.0" replace="19"/>
<extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 6.1; rv:36.0) Gecko/20100101 Firefox/36.0]]></extraHeader>

It also doesn't work without the scaling.
Also tried to use a referer. No luck.
Any ideas?


Hm, on I managed to see the Tracetrack layer by disabling AdGuard in my browser. So looks like a DNS issue.
Unfortunately disabling AdGuard on the phone still doesn't help Locusmap to show Tracetrack.


interesting. I've simply copied & pasted your definition into Tracetrack.xml file (placed into Locus/mapsOnline/custom directory and after restarting the app and selecting the map > all works without any issue.

It seems to be some block on your side, sorry. Seems anyway, that your config is correct.
(I've removed a key from it to prevent abuse ...)
- Official help (ideas, questions, problems):
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download