UK OS maps not showing

Started by hendo, October 30, 2022, 20:50:13

0 Members and 1 Guest are viewing this topic.

hendo

Hi
I wonder if anyone can help, I have 16 UK Ordanace Survey maps paid for and downloaded through Locas Classic,
My previous phone was the Pixel 4a and I never had any issues.

I bought the newer however Google Pixel 6a, and now only 6 of the 16 are shown, the other maps show grey tiles and "unknown problem" I did re download all the 16 maps from the Locus store and have re installed the app, but the problem persists,

I am aware there are updates for most of my maps, but these require re purchasing and I was under the impression that using older maps wouldn't be an issue. As an aside my 4 LoMaps and 4 OSM maps are working perfectly, so this seems to be a UK OS map problem

If anyone can give any pointers I would be most grateful, I have searched the forums but couldn't find anything that helped.

Regards and thanks in advance.

Andrew
  •  

michaelbechtold

This smells like an Android 11+ issue, where file access restrictions have gone crazy.
Do you know how to find the locations where the maps are stored (it sounds like you can download a map for offline use - I have no practical experience with UK Ordn.Surv.?)
  •  

Menion

Why do you think Michael? When some works and some don't? Also maps directly downloaded from the Locus Store should work in all cases, mainly for basic raster maps.

"Unknown problem" is weird. These maps are bound to your account (account used for purchase). The result is that in the "Locus/maps/ordnance_survey" should be raster map files (*.sqlitedb) + small info files (*.info) that are used to validate of the purchase. May you check that your raster maps have this info file? Thank you and sorry for the complications!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

michaelbechtold

In fact we advise similar step to assess the hard facts, Menion. Though my assumption about the root cause may be wrong :-)
  •  

hendo

Hi Guys
Thanks for the quick response, My Google Pixel 6a is running Android 13, and it took me a little while on how to figure out how to view the Locus maps folder. I managed it after doing a bit of research, and I can say that all the UK OS maps have 2 files, the "info" and "sqlitedb" so 32 files in all, which would relate to my 16 maps.

Andrew
  •  

Menion

Thanks Andrew,

oki, so maps seem to be correctly in place. I'm checking that app code that takes care of drawing maps and can't see any reason why this should simply end with "Unknown problem" on map tiles. So I'll need a big log from you. It may (or may not) tell us more.

How to do it:
- start the app and simulate the problem by selecting one or two maps that do not work
- follow these steps to create a bug report

Thanks a lot!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

hendo

Hi Menion
I have followed the instructions and sent a bug report from my Google Drive to locus.map@asamm.com
If you any problems with access, please let me know as I can send it as an atachment.

Regards

Andrew
  •  

Menion

Hi Andrew,
thanks for the log, appreciate it! There is clearly visible my own error message: "unable to decode image, set to 'unknown problem'". Unfortunately nothing more.

So to simulate it and detect the real reason for this issue, I would ask you for one more thing. Send me please one problematic downloaded map file together with its info file (over Google Drive or any other service like this), thanks.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

hendo

Hi Menion
I have sent the requested files via Google Drive.

Regards

Andrew
  •  

voldapet

@hendo It seems that you have discovered an issue in our store related to OS maps in version 2021. The issue should be fixed now. Please remove your not working OS maps (look for them in the Store -> REMOVE button) and download version 2021 again.
Sorry for the complication
Thanks, Petr
  •  
    The following users thanked this post: Menion

hendo

Hi Voldapet
I have done what you advised and my maps are now visible, thank you very much for all the help.

Regards

Andrew
  •