[APP] - version 4.11.+ ( 07/2022 )

Started by Menion, July 26, 2022, 15:31:26

0 Members and 1 Guest are viewing this topic.

Andrew Heard

Quote from: luce on September 03, 2022, 20:48:22In 4.11.1.3, the side panel can't be displayed any more by double clicking (setting = hide automatically)
@luce - it's still working for me
LM4.14.2.1 GOLD user ID:142d400c7
  •  
    The following users thanked this post: luce

luce

Quote from: Andrew Heard on September 04, 2022, 00:27:45@luce - it's still working for me

Hm, interesting... Maybe Menion can simulate the issue?

My bottom bar is set to always visible, only the side bar is set to "hide automatically".
  •  

Tapio

#77
Bad behaviour: Clicking a picture (see screenshot, geotagged photos) for the first time displays it maximum stretched, non resizable. Leaving and re-entering allows for resizing. webp pictures.
Latest Beta. You cannot view this attachment.

@luce,like Andrew, no side panel problem here. top/side are auto, bottom is always
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •  

Andrew Heard

#78
Quote from: luce on September 04, 2022, 10:56:26Hm, interesting... Maybe Menion can simulate the issue?
@luce FWIW my settings:
  • bottom function panel: partial auto-hide
  • side function panel: auto-hide
  • panel hiding timeout: 99,999
LM4.14.2.1 GOLD user ID:142d400c7
  •  
    The following users thanked this post: luce

Tapio

#79
There seems to be an issue with stopping recording via an intent. It does not (always?) stop. I have automated my recording start/stop heavily and I noticed multiple saving attempts of the same track hourly, but with the first saving the recording should have stopped. It doesn't, recording continues. Will observe...
Menion has there been any change in those realms? It happens since I installed latest beta. But hard to track down, because when I execute the intent code manually, it works.

This is the saving intent code...
tasks: { track_record  : { action: "stop", auto_save: true } }
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •  

Menion

@Andrew Heard
hmm error 10102 is a generic problem with the internet connection so it probably happened when the app was on background > system decided that Locus Map should not use the internet now. The app should anyway handle this more gently. Weird is that the "refresh" button does not help. Will have to try it ...

@luce
thanks for the shared settings, it helped! The issue was found and will be fixed in the next version.

@Tapio
The problem with the image when visible for the first time should be fixed in the next version, thanks!

The issue with recording & tasker > hmm, yes, there was a minor change in the recording system because of some optimization around ignoring points with "invalid" accuracy. But it should not affect the recording life-cycle & handling of such events.

What you may try > enable "Log to file" in the Beta version (long click on the main menu). When this issue happens, remember the time when it happened and send me the log from Locus/logs directory. There should be (maybe) some info ... at least something to start with. Thanks!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download

joeloc

#81
Is cloud sync actually supposed to work? I just tried it for the very first time and it remains at 1% forever. Internet monitoring shows a few bytes(!) per second upload speed. What's it doing... uploading every single track point in a single http request?

My database is only around 1GB currently and if I upload eg a Locus backup zip (800mb) directly to some random ftp server, it does 5Mb/second and finishes in a few minutes. I assume Locus should be about as fast when doing its sync stuff?

  •  

michaelbechtold

Hi joeloc,
my DB is more than 1 GB and sync across devices works like a charm. However, my big initial upload happened in the early beta stages of this feature. Hence my happy sync may not prove anything today ...
Cheers
Michael
  •  

Andrew Heard

Quote from: Menion on September 05, 2022, 14:15:49hmm error 10102 is a generic problem with the internet connection so it probably happened when the app was on background > system
@Menion - yes, more than likely.
LM4.14.2.1 GOLD user ID:142d400c7
  •  

Andrew Heard

Quote from: joeloc on September 05, 2022, 16:36:33Is cloud sync actually supposed to work? I just tried it for the very first time and it remains at 1% forever.
@joeloc - maybe just 1% for a longer than expected time - I experienced similar behavior with the initial bulk upload - have a look at & maybe vote or comment on my suggestion https://help.locusmap.eu/topic/26282-provide-more-info-while-performing-cloud-sync. I use manual cloud sync & it's a great facility, but would like to see more details during progress, and finer grained update of the progress bar.
LM4.14.2.1 GOLD user ID:142d400c7
  •  

Andrew Heard

#85
I've had this issue before, but don't really see why... zoom out to ZL10 over region with existing offline map - LM4 displays "unknown problem". Wifi & mobile are disabled, so "LoMaps Online" will not work & shouldn't be needed anyway. An existing track is visible for reference and comparison with 2nd screen capture:
You cannot view this attachment.
Zoom in to ZL12 with no other change & the existing offline map is now correctly displayed:
You cannot view this attachment.
Why isn't this map displayed @ ZL10 as well? Map settings are also attached. Thanks for any suggestions.
LM4.14.2.1 GOLD user ID:142d400c7
  •  

Menion

@joeloc
initial sync may really take a long time. The app does not send data as a plain file so the conversion of files, checking with the server, etc. takes its time. So expected, in your case, that it may take maybe even a few hours. All following sync will be fast as in the case of other users.

@Andrew Heard
"Unknown problem" should not be visible at all, rather a "No internet" message should be there. Anyway aren't you using online LoMaps as a world map? Check settings > Maps >Advanced features > Pre-load global map.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Andrew Heard

Quote from: Menion on September 06, 2022, 07:08:21"Unknown problem" should not be visible at all, rather a "No internet" message should be there
@menion - OK one improvement

Quote from: Menion on September 06, 2022, 07:08:21aren't you using online LoMaps as a world map? Check settings > Maps >Advanced features > Pre-load global map.
no; but even if I were, there was a valid offline map that could be displayed rather than "unknown error" or "No internet"
LM4.14.2.1 GOLD user ID:142d400c7
  •  

joeloc

Quote from: Andrew Heard on September 06, 2022, 00:10:02
Quote from: joeloc on September 05, 2022, 16:36:33Is cloud sync actually supposed to work? I just tried it for the very first time and it remains at 1% forever.
@joeloc - maybe just 1% for a longer than expected time - I experienced similar behavior with the initial bulk upload - have a look at & maybe vote or comment on my suggestion https://help.locusmap.eu/topic/26282-provide-more-info-while-performing-cloud-sync. I use manual cloud sync & it's a great facility, but would like to see more details during progress, and finer grained update of the progress bar.
More details and progress updates are absolutely required, especially when performance is that miniscule. I have no patience for staring at a never changing 1% number. And since there is no network traffic worth mentioning during that time, I simply abort.

michaelbechtold

Just checked - cannot vote twice :-)
  •