Changing "Time between GPS locations" back to 0s not working

Started by svartbjorn, July 11, 2011, 09:41:50

0 Members and 1 Guest are viewing this topic.


How to recreate:
- Set GPS > "Time between GPS locations" to e.g. 30 seconds. I can see the GPS receiver is turned on once every 30 seconds as expected.
- Then set to 0s. ==> The previous value (in this example 30s) is still being used.

I have to set it to 1s to force continuous location updates. Since 0s is the default value, I assume this is supposed to be a valid value and work as continuous updating (i.e. same as 1s), right?


Hi Menion. Do you have any comments? I noticed yesterday that when the accuracy is good, the 1s setting will cause the GPS status to flash on/off once/1s (as expected), so we need the 0s setting to keep the GPS receiver on all the time. And again, this is your default setting and hence is supposed to work, right?


I have tested it and for me it works fine.

Read here ... gIntent%29

you can see in middle that "Background services should be careful about setting a sufficiently high minTime so that the device doesn't consume too much power by keeping the GPS or wireless radios on all the time. In particular, values under 60000ms are not recommended.", so this feature is mainly used for some background services that needs location once a time. Values below cca 30s do nothing on my phone.

It's also possible that this works differently on various phones. If this do not work correctly with values above 60s for you, don't use it!
- Official help (ideas, questions, problems):
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download


Thanks for answering, Menion. But I think we are not on the same page.

You are saying that "if this does not work correctly with values above 60s, don't use it". But that is not what I am reporting. Any value at 1s and above works as expected, also any value above 60 seconds.
And I am fully aware of the power saving benefit of setting a value above 30s or so.
But my point is at the 0s-1s end. When you are driving a car or are biking, you need continuous position updates to make the right turn at intersections. And this works fine with 1s. And it also worked with the 0s default setting until I tried a higher value to save power. The 0s setting used to keep the GPS receiver on all the time. But now the 0s setting is ignored, Instead the previous setting is used.

To summarize: Any setting at 1s and above works exactly as expected, but the 0s setting is simply ignored. And 0s is your default setting, so it is supposed to mean continuous on.


Quote from: "menion"Values below cca 30s do nothing on my phone.

I have mine set to 2s, and it certainly makes a difference. I have found that guiding on a track with many points will not even work properly with a setting of 30s. By the time the position is updated I have walked past the "next" point, and then it stays locked to that point, even though it's behind me. I have been meaning to post something about this, but I haven't completely finished investigating it yet, because it seems the guiding can also get locked on a past point if "Distance for sounds" and "Set next point" are not set correctly.