[APP] - version 4.5.+ ( 1. 12. 2021+ )

Started by Menion, December 01, 2021, 21:06:00

0 Members and 1 Guest are viewing this topic.

Menion

Nice path to the map directory, seems to work for you  ;)

How this may be possible, hmm. Nothing like this happens to me. Isn't this directory added for example also as "External maps" together with the default "mapsVector" directory?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

balloni55

QuoteIsn't this directory added for example also as "External maps" together with the default "mapsVector" directory?
no, all my vector maps are stored a long time on extSD inside this path
I also kept these directory when I moved LM4 to Android/data/... 
for test i´ve deleted Lomap world and downloaded it again, it was stored correctly in this folder  and it is again visble twice.
One thing i noticed while testing:
i moved this map to internal SD, after that it was not possible to delete the "world" label with the 3.dot button
Locus Map Classic 3.65.1 AFA
Locus Map 4.14.1 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

Menion

Damn, I was worried this may happen. Locus Map Pro update was rejected. Now LM4 is published with new "All files access" options and LM Pro waits on the result of my appeal with a high risk that it won't be successful. One guy thinks the app is ok, second doesn't...

@balloni55
hmm, one more try ... top toolbar in the map manage > offline tab > Refresh list. Does it help? If not, you may try to remove Locus/cache/map/init2 directory that contains all initialization files and restart the app.

- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

bezel

@Menion :
locusmap 4, but also locusmap pro still does not work under andoid11!!!

what is going on?
I am really desperate as I need locus urgently. is there a solution in itself?
What to do?!

(when initialising/booting locus, the message appears:
T:unable to opnen /storage/.... file as input
in my case the locus app is stored internally - maps, srtm etc data on external sd card )

Thanks for your help!!
  •  

Menion

Hmm really interesting. Try to rename your "SRTM" data directory on the SD card, so Locus won't be able to find it. This should help I believe.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

balloni55

Hello menion,
unfortunately, neither of the two options is successful
LMP and LM4 are accessing the same vector maps in this folder, is this a problem?

@bezel
for me both work on A11with Samsung Xcover 4s
what´s your device?
Locus Map Classic 3.65.1 AFA
Locus Map 4.14.1 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

michaelbechtold

#66
Hi Menion,
first try on my Tab:
- migration of mapsVector to old root level folder where the backup had stayed has worked
- theme function are fast again
- after restart I also tried to move maps folder - this function is missing
- then I tried mapsVector again, to move to /Android/media
- initializing for "Set custom sub-durectories" takes forever
- after maybe 10 minutes I get the options
- touching custom selection does not do anything, so I cannot move to /Android/media
- tried to activate logging - fail as before
Here is the sequence of events with resp. photos:
1) long tab to menu opens the tools selection - looks same as logging-3.jpg
2) switching on the interesting options - logging-1.jpg - so far so good
3) now the essential step: switch on logging to file - but the Locus reaction smells like the opposite - logging-2.jps
4) going back we are where we started - logging-3.jpg - bummer ...
Cheers
Michael


  •  

balloni55

Hello menion
it seems to be due to the path on the extSD
Vector cards in extSD android/media folder are only displayed once
Locus Map Classic 3.65.1 AFA
Locus Map 4.14.1 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

bezel

Quote from: balloni55 on December 17, 2021, 20:51:23
Hello menion,
unfortunately, neither of the two options is successful
LMP and LM4 are accessing the same vector maps in this folder, is this a problem?

@bezel
for me both work on A11with Samsung Xcover 4s
what´s your device?
I use the Unihertz Atom L outdoor smartphone
  •  

bezel

Quote from: Menion on December 17, 2021, 20:50:32
Hmm really interesting. Try to rename your "SRTM" data directory on the SD card, so Locus won't be able to find it. This should help I believe.
@menion:
after renaming srtm, locus opens, but then no offline maps are displayed next to the srtm information!
does this mean that the maps, srtm etc. files can/must only be stored in the internal memory?!

(that would be the end of the locus app - so much memory can only be stored externally).
  •  

michaelbechtold

Do you have the latest version from TODAY?
That opens free storage selection, at least for mapsVector (which I tried successfully), SRTM (mayne, did not try), not maps (for me).
But even in the older versions since Nov. you can select int or ext SD private storage.
That is very flexible and helps balancing the capacities.
(It has other limitations, hence the very latest approach.)
  •  

CabrioTourer

  •  

michaelbechtold

  •  

Andrew Heard

@menion: testing 4.5.5 on Android 11 tablet...

All files are on internal storage; there is no external storage. Previously I had custom backup & export directories (as displayed by Solid Explorer):
  internal memory > download > to-save > Locus > backup
  internal memory > download > to-save > Locus > export

So now... settings > Misc > default directories > Set custom sub-directories > backup directory is highlighted in red (see attached) > tap Custom selection > tap Custom selection > tap is ignored; appears not possible to select any other directory?

Is this correct behavior? At least there should be some explanatory message rather than just ignoring the tap?
LM4.14.1 GOLD user ID:142d400c7
  •  

michaelbechtold

Hi Andrew,
someone had such in LMP as well last week or early this week.
The path is fully broken and blocks any user action with it.
Need to leave that to Menion.
Cheers
Michael