Locus Map 4, discussion (beta)

Started by Menion, December 22, 2020, 12:20:09

0 Members and 1 Guest are viewing this topic.

john_percy

When I pan the map in dark mode, I find the map tiles appearing out of black tiles disconcerting and less smooth than previously. I was going to suggest you detect and use the background colour of the map but just realised that would only work for vector maps.

Sent from my moto g(6) plus using Tapatalk
  •  

jonny.blue

Quote

When I pan the map in dark mode, I find the map tiles appearing out of black tiles


Since last version I have the same problem ..🤔
  •  

Ricardo Borges

Add Dark Mode icon in Quick Settings would be great!

Enviado de meu SM-G780F usando o Tapatalk

  •  

Andrew Heard

#153
Quote from: john_percy on January 30, 2021, 18:53:02
When I pan the map in dark mode, I find the map tiles appearing out of black tiles disconcerting and less smooth than previously.
me too

Quote from: Menion on January 29, 2021, 22:42:07
You may as well have some very dark map ... it is not an ideal solution.
@Menion - you can see from my screen caps the map color has not changed; should I be expecting it to be dark?
LM4.12.2.4 GOLD user ID:142d400c7
  •  

luce

Would it make sense so make the protective area around the zoom buttons also "touchable", so that the invisible area around the button is also part of the button? The zoom buttons are the only buttons on the map screen that are sometimes hard to target, also without gloves... Maybe also adding a little more space between these two buttons could improve this.

Tapio

In dark mode, on zooming via the buttons, it temporarily shows a kind of the inverted map theme. I am using oam/lomaps + vol UK.
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •  

Diddi

Little bug while recording a track:
After some time the icon in the left bottom changed from "active tracking" (pause key) to "start track" (Play key).

Tracking itself was working finde the whole time.
  •  

jonny.blue

Since 2 or 3 versions LM crashes during longer (1-2 hours) trips.
I can't repeat the steps but it always happens when using the map ... switch to points ... log caches ... zoom ... and sometimes LM stops without any message.
When I start again the recording continues ( one time it records but doesn't show the created line). Navigation and waypoint alarm have to be started new ...
  •  

freischneider

Quote from: jonny.blue on January 31, 2021, 23:05:54
Since 2 or 3 versions LM crashes during longer (1-2 hours) trips.
I can't repeat the steps but it always happens when using the map ... switch to points ... log caches ... zoom ... and sometimes LM stops without any message.
When I start again the recording continues ( one time it records but doesn't show the created line). Navigation and waypoint alarm have to be started new ...
Immediately afterwards I would make an error log and send Menion.
Xiaomi Redmi Note 10 Pro, Android 12
Locus Map 4 Gold (always latest version)
LM4 User-ID: 64fc904a8  (Devices-ID)
  •  

Menion

I'm not fast enough to handle all feedback quickly, sorry :).

@Andrew Heard
"Protective area" on tablets > hmm, will have to try. Anyway as wrote @luce below ... I was also thinking about it, but choose the most simple solution to do. Seems there is interest in this feature > I'll try to invest a little more time into this.

"Map refresh" > it will be harder.

Map color in dark does not change. For this already exists "Map color mode" settings.

@freischneider
ah thanks, stupid issue!

@WujTom
no problems with sync noticed. What exactly was the problem?

No change in plans ... just a usual small delay here and there :-\

Web for testing > final steps in progress - automatic sync after changes. Hopefully next week!

@john_percy, @jonny.blue
hmm, I'll look at it ...

@Ricardo Borges
"dark mode" settings into quick settings hopefully won't be necessary.

@Diddi
an interesting observation with the recording button. Never saw anything like this and I use recording almost daily. Any other UI problem except this button on the main screen?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download

Diddi

I had one other bug in main screen for only one time. After going back from mobile phone screen lock to locus map view (with finger print), there was a gap between the top bar (with coordinates) and the active guide to a cache bar, so that I could see about 1cm of the map.
Forgot to take a screenshot...
  •  

freischneider

#161
Quote from: Diddi on January 31, 2021, 15:36:43
Little bug while recording a track:
After some time the icon in the left bottom changed from "active tracking" (pause key) to "start track" (Play key).

Tracking itself was working finde the whole time.
I had a similar problem. But was 2 versions back.
I have recorded and normally the red dot for recording is shown. This was suddenly gone. Screen off and on again. Then he was back. The recording was active the whole time. Nothing was missing in the track. Only the symbol wasn't always there.

The problem has never reappeared since. But there was also an update 2 days later and I thought that would fix it. That's why I didn't write anything.
Xiaomi Redmi Note 10 Pro, Android 12
Locus Map 4 Gold (always latest version)
LM4 User-ID: 64fc904a8  (Devices-ID)
  •  

Menion

These graphical problems may appear due to the complexity of the whole main screen layout. Fortunately, they are not serious problems.

I've added one more refresh of the "track rec button", so it should help here.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  
    The following users thanked this post: Diddi

john_percy

Still getting "nothing to display" instead of the map name. It's annoying because I can't change the theme without selecting the map again.


Sent from my moto g(6) plus using Tapatalk
  •  

Andrew Heard

#164
Quote from: Andrew Heard on January 31, 2021, 02:56:52
Quote from: john_percy on January 30, 2021, 18:53:02
When I pan the map in dark mode, I find the map tiles appearing out of black tiles disconcerting and less smooth than previously.
me too
I uninstalled LM4 beta 985 & installed LM4 beta 984 but unfortunately it has expired, so there is no way to compare the performance or regressions. But as I've said previously & after more testing I am now 100% that changing themes or maps in latest beta has resulted in the map sometimes not being refreshed. It is not 100% repeatable. I continually switch back & forth between maps & themes using presets. Sometimes the map is displayed, sometimes left blank. POI are always refreshed. It's not related to dark/ light mode. I have to drag the map to force a refresh. This is something that has never occurred in previous betas.

PS 30m later: after re-install LM4 beta 985 & restore settings I can no longer reproduce this map refresh issue. No other settings changes. Now refreshing is 100% reliable again but I can't provide any further info what has changed.

I note @Menion has made 12,000 posts & been thanked 500 times. SUPER effort.
LM4.12.2.4 GOLD user ID:142d400c7
  •