Locus Map 4, discussion (beta)

Started by Menion, December 22, 2020, 12:20:09

0 Members and 1 Guest are viewing this topic.

joeloc

#270
Now even Androids problem solver thinks, Locus does "frequent crashes" :). No idea what that means, but maybe it helps a little for debugging. This is with the previous beta though.

On average, I have about one crash per day while I'm using the app and about two forced quits per day (Locus disappears while track recording when the display is off and the phone is not in use).

The forced quits happended with Locus Pro as well. I still suspect my database size and Samsungs aggressive killing strategies... even though I tried hard to disable all that nonsense. It's hidden all over system settings and they make it harder to deal with ever day it seems.
  •  

Diddi

Quote from: Diddi on February 23, 2021, 11:33:38
Beta 9 is crashing every time I try to Download a pocket query

Still the same error...

Crashing and restarting...
  •  

john_percy

I keep getting this lock screen authorisation request now. Granting permission doesn't seem to stick.
Also I'm not sure what I changed to cause this to come up.

Sent from my moto g(6) plus using Tapatalk

  •  

freischneider

Quote from: Menion on February 26, 2021, 15:34:04
@freischnerider
this big delay in the display of the edit screen happen also for a very short track? And the detail of the track (the big screen with the chart, stats, etc) appears a lot faster?
I started the new beta and tried again. It's always been like that.
Then I wanted to make a video but it just doesn't happen anymore.
It was a 40km track. I will keep watching.
I started it from the main screen. Click on track, then there is a small popup with a small arrow on the right. Modify track was selected there.
Xiaomi Redmi Note 10 Pro, Android 12
Locus Map 4 Gold (always latest version)
LM4 User-ID: 64fc904a8  (Devices-ID)
  •  

Andrew Heard

#274
Recorded track preview displays "connection failed" & map is not displayed - see screen cap - but Wifi/ mobile were never enabled during track recording & an offline map is selected, so there is no need for any connection. Can't reproduce now sorry/ working properly again but thought I should report it anyway.
LM4.12.0 GOLD user ID:142d400c7
  •  

joeloc

#275
Something is fishy with online overlay maps, they dont seem to be properly cached anymore. I use a hack for strava bike heat map from a slow russian server and it keeps disappearing on almost every zoom in Locus. Sucks a little, because the server is really slow :-).

I move to a certain location, wait a little, after some tens of seconds, the overlays appears. Then I move around and zoom in an out to different placesy but when I get back to the exact same location and zoom level of the first time, the overlay is gone and I need to wait again. Certainly it should be cached?

I remember Locus Pro caching online overlays maps basically forever. Especially with a heat map, the zoom level doesnt even matter much.

<provider id="8888049" type="0" visible="true" background="-1">
<name>Overlay</name>
<mode>Strava Heatmap - Ride (Bluered)</mode>
<countries>World</countries>
<usage>overlay</usage>
<url><![CDATA[https://anygis.ru/server/Tracks_Strava_Ride_Bluered_HD/{x}/{y}/{z}?locusScale={ts}]]></url>
<serverPart></serverPart>
<zoomPart>{z}-8</zoomPart>
<zoomMin>8</zoomMin>    <!-- 0 -->
<zoomMax>23</zoomMax>   <!-- 15 -->
<tileSize>256</tileSize>
<tileScale dpi="0" multi="2.0" replace="19" />
<extraHeader><![CDATA[Referer#https://www.strava.com/heatmap]]></extraHeader>
<extraHeader><![CDATA[User-Agent#Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36]]></extraHeader>
<attribution><![CDATA[Сборник карт AnyGIS. <a href="https://anygis.ru/Web/Html/Locus">Проверить обновления</a>]]></attribution>
</provider>
  •  

Diddi

New beta is very laggy for me.
When tapping on a cache, the pop up (from dthe bottom of the display) is coming up very shaky an not as smooth as before.
  •  

Tapio

#277
Opening times are nicely aligned now.

Quote from: philj on February 25, 2021, 16:37:55
not sure if this was reported already - when opening a POI while in fullscreen mode, the bottom bar with the buttons (edit, navigate to, share etc) gets cut off
Same here now with latest beta. But here it's newly introduced imo with feb 26 version. Have not recognized it before.

Quote from: Menion on February 26, 2021, 21:56:15
I'm working on it ... ufff. I really believed we will be able to publish LM4 by end of February.
Believe me it's really hard, I'm supressing my itch to post further suggestions here. But that would be really unreasonable. Yeah, you have put a lot of changes into Locus recently (it's nice, but I was surprised) and hence, imo, the delay had to be expected.
LM4 USER ID: 1AACAFF2A2
My "Tasker vs. Locus" YouTube playlist: http://tiny.cc/LocusVsTasker
  •  

jonny.blue

Quote
"App not responding" error when app closing > hmm this does not happen to me, weird. Any bigger function running when closing app?

Maybe I found a/the reason: AddOn Geocaching4Locus 🤔

When I stop LM I can see Geocaching4Locus running a while.
Deinstalled it and after 10 attempts leaving LM ... no message.
Installed it again ... and with first attempt the error message was back again.
  •  

joeloc

#279
Locus displays inclination percentage besides altitude difference underneath guide line now. It's not particularly useful in real mountains I suppose because there are always switchbacks, but maybe it's good for other purposes... like flying... or really flat mountains with straight paths. Problem is however, that text is very long now and hidden completely if it doesn't fit. I suggest not hiding it but simply clipping instead, so we could still see altitude difference. Alternatively, make percentage value turnoffable.
  •  

joeloc

Btw, the new syncing things will do nothing to help reselling/planning with a buddy, right? Or am I missing something here?

I am still dreaming of a day where I can add a point to my Locus and it would simply popup on my buddy's screen right away, without further crap involved. Online... offline... in 5g-land or at night by a campfire in Bolivia 300 miles away from the next cell tower. None of that must matter.



  •  

balloni55

opening waypoint list of a geocache
> click on text of one > wpt detail window open > back with back button or swipe down >this wpt is activated and icon is visible on map, this should not and is different to Pro.

The wpt schould be visible on map if user click on map inside wpt detail window or eye is activated inside wpt list
Locus Map Classic 3.63.0 AFA
Locus Map 4.12.0 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

Menion

@ADiet
problem with zoom with overlay > can't simulate it. What map is used as an overlay? Any special settings like blend mode for overlay or any shading or coloring?

@joeloc
long tap is complicated, agree. So why use it for adding new points or starting guidance? You may use the button placed in the side menu for these cases or "Quick new point" as an even faster method for the new point.

Crashes > I've spent the weekend implementing an automatic reporting system so, in next Beta 12, the app should (hopefully) automatically send crashes to me. Anyway, database size really should not have an effect here. The effect may have a number of tracks/points on the map. Suggest to keep the map clean, hide tracks on the second side of the world ...

Strava overlay > firstly please check if
- map (in the list) has enabled caching (visible in map detail as "Cache timeout" and may be set over "Set cache timeout" option)
- you have globally enabled caching for online maps in settings > Maps > Online > Cache maps.

Improve inclination texts > added to TODO

Syncing with buddy > it will help only partially. It allows easily generate Url to your track that may anyone with this URL download and use. Anyway, it still needs an internet connection. Sharing locally may be easily done over "Share as GPX" and some method to send data between devices.

@Diddi
PQ crash > still can't simulate. Crash log needed.

Laggy version > this may be even worst for fixing. Firstly please try to restart your device. Then I suggest some of our steps here, mainly check if there is not too much content on the map etc. I simply need some clue to find out a reason.

@john_percy
hmm, weird, but probably nothing I can fix. This is a completely system-based dialog. I've never had a problem with this. Anyone suffering but not confirmed screen on/off permission?

@Andrew Heard
weird problem with the map. It is not a generated PNG preview, but a regular map window with exactly the same map as you have on the main map screen. So if using some offline vector maps, it should work correctly.

@tapio
so now you have a problem with the bottom panel, that was not previously visible? Damn ...

@jonny.blue
ah, nice discovery. Does this happen with the live-map enabled?

@balloni55
So you think that tap on the waypoint should open a full-screen window with this waypoint, but does not display it directly on the map? Probably agree. Anyone else opinion on this?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  
    The following users thanked this post: Tapio

balloni55

QuotePQ crash > still can't simulate. Crash log needed.
same problem for me
log send just now
Locus Map Classic 3.63.0 AFA
Locus Map 4.12.0 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  
    The following users thanked this post: Diddi

balloni55

QuoteSo you think that tap on the waypoint should open a full-screen window with this waypoint, but does not display it directly on the map?
in preview map the position of the waypoint is visible, this is ok.
If i click on the map this WPT icon schould vie visible
but
If i click back button this WPT icon schould be hidden
Locus Map Classic 3.63.0 AFA
Locus Map 4.12.0 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •