Locus Map - cloud/sync server

Started by Menion, September 08, 2020, 13:06:05

0 Members and 1 Guest are viewing this topic.

Menion

I do not perfectly get the point, sorry.

So when you update track preview (by long click on the preview in the list of tracks) does it trigger the sync task? It should not. And the result is > yes, you won't have identical previews on multiple devices without any other modification of the track itself. Not a big problem for now I believe.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

slarti76

Quote from: Menion on March 09, 2021, 08:26:52
I do not perfectly get the point, sorry.

So when you update track preview (by long click on the preview in the list of tracks) does it trigger the sync task? It should not. And the result is > yes, you won't have identical previews on multiple devices without any other modification of the track itself. Not a big problem for now I believe.
OK, sorry, I realize my description wasn't that good...
Of course, a preview update doesn't trigger a sync, but it marks the track as "updated", which means the track is synced next time a sync is performed. But the overview image is not synced anyway. So the sync is useless, as nothing new is transferred to server.*
Additionally, on the other device the download of the "new" (unchanged) track leads to the preview being removed. This leads to a vicious cycle where I can't have track images on  both devices, because everytime I recreate the image on one device, this leads to the next sync removing the image on the other. You're right, I don't care if the images are not identical, but like this it's a) unnecessary syncs, and b) no previews at all on one of the devices.

* I remember distinctly that we discussed this before and you even agreed not to mark a track as updated if only the preview is changed, but for the life of me I can't find the posts in any thread. Perhaps I dreamed it ;)
  •  

Axel D

Could it be that the sync in LM4 do not work now? I got the code 14199.

Gesendet von meinem XZ2C mit Tapatalk

Axel

Locus 4 Gold
  •  

janaton

@ADiet Yes, it is very likely. We are still doing some adjustments and testing here (as noted in my previous post https://forum.locusmap.eu/index.php?topic=7114.msg62270#msg62270). Sorry for the inconvenience. We should be ready soon. I will definitely notify you here ;)
  •  

Diddi

I can't test the sync feature.
Try to start. Log in with Locus account and getting the following:
"Active subscription of locus map premium is required. Code 14199"

  •  

freischneider

Hello Diddi,
Who can read is clearly in the advantage. A contribution before is everything. Should go again soon.
Xiaomi Redmi Note 10 Pro, Android 12
Locus Map 4 Gold (always latest version)
LM4 User-ID: 64fc904a8  (Devices-ID)

slarti76

Don't wanna pressure, just for information: Do you have an estimate when sync can be tested again by everyone? Thx!
  •  
    The following users thanked this post: Diddi

Andrew Heard

Quote from: slarti76 on March 19, 2021, 10:42:23
Don't wanna pressure, just for information: Do you have an estimate when sync can be tested again by everyone? Thx!
@slarti76 - funny isn't it - how very quickly we get used to have the new sync available. It saves me a *lot* of time - I use it instead of backup manager > full backup > FTP file to PC > FTP PC file to 2nd device > backup manager > restore.
LM4.12.0 GOLD user ID:142d400c7
  •  

slarti76

Quote from: Andrew Heard on March 19, 2021, 22:50:51
Quote from: slarti76 on March 19, 2021, 10:42:23
Don't wanna pressure, just for information: Do you have an estimate when sync can be tested again by everyone? Thx!
@slarti76 - funny isn't it - how very quickly we get used to have the new sync available. It saves me a *lot* of time - I use it instead of backup manager > full backup > FTP file to PC > FTP PC file to 2nd device > backup manager > restore.
Well, I'm using FolderSync with my NAS as storage most of the time, and Google Drive when I'm on the road. And regular local backups on the phone.
So I'm fine, I was mainly asking to do some more beta testing - I did report a few minor bugs lately, and had a bigger data loss (well, got everything back with local backups) a few weeks ago which I didn't report, because nobody would be able to reproduce it anyway. So I hoped to get some more quality testing in before LM4 is out.
  •  

slarti76

Good news:
Beta from Play Store doesn't trigger sync anymore if only track preview updated, as discussed. Can put this to rest, thx  :)
  •  
    The following users thanked this post: Menion

slarti76

A bit older report, but just to confirm: No crashes anymore when opening Sync or returning to Sync dialog after Locus was in the background for a while.
  •  
    The following users thanked this post: janaton

dyoghenes

I couldn't post to helpdesk so I write here.
Yesterday I changed a lot of my folders and groups in the app but I forgot to turn off automatic sync. It tried to sync after every little thing I changed.
The problem is, syncing is now crashed. When I try to sync, it stays at 1% (tracks downloading), then the whole app crashes. Resetting the app did not help. Trying just to compute the syncing plan in the advanced settings gives the following error code: "rr$!, code: -1"

Please help, how could I solve this without redoing everything?
  •  
    The following users thanked this post: lor74cas

lor74cas

Quote from: dyoghenes on April 09, 2021, 11:51:13
I couldn't post to helpdesk so I write here.
Yesterday I changed a lot of my folders and groups in the app but I forgot to turn off automatic sync. It tried to sync after every little thing I changed.
The problem is, syncing is now crashed. When I try to sync, it stays at 1% (tracks downloading), then the whole app crashes. Resetting the app did not help. Trying just to compute the syncing plan in the advanced settings gives the following error code: "rr$!, code: -1"

Please help, how could I solve this without redoing everything?

I created a track on the web portal, but I can't synchronize on the app. It crashes at the "Groups - data deletion" screen or on "tracks - download in progress" I sent an error report in the description look for lor74cas.
If you start the lock screen while the sync is working (I don't know if it is actually doing something) the next time you unlock it it says "Congratulations, sync done" but it didn't actually sync anything. The track added in lcoud does not appear on the phone.
Last update data:
id: cc4e583f-212c-4ecc-a969-1ffe37d06434
status: 10600
start: 9 Apr, 12:10
end: 9 Apr, 12:12
changesSince: 9 Apr, 07:53

plan:
  operation POINT_GROUP, pull: 0, pullDelete: 0, push: 0, pushDelete: 0
  operation TRACK_GROUP, pull: 0, pullDelete: 0, push: 0, pushDelete: 0
  operation       POINT, pull: 0, pullDelete: 0, push: 0, pushDelete: 0
  operation       TRACK, pull: 1, pullDelete: 0, push: 0, pushDelete: 0 | pull: b2f5e8de-6514-41ce-837b-050e4dca6cd0

rr$!, code: 10601


Locus Map 4
Locus Map for Garmin
Locus Tasker
Geocaching4Locus
  •  

Andrew Heard

#103
I made lots of track group/ folder changes on my primary phone, so on my backup tablet instead of a manual live sync, and to avoid potential duplicate tracks/ points as with past experience (twice), I decided to do a Cloud Sync > Advanced > Full Download

but now Cloud Sync screen > Tracks downloading: displays 48% for 10 minutes with no other indication. Eventually it jumped to 53% (and further big jumped), but with all that blank space on the screen it would be so nice to see a little more detail of what is actually downloading in addition to a percent that generally changes in big jumps, then crawls along so slowly. Maybe percentage could have single decimal instead of being an integer, and the progress updated with finer resolution. How about displaying

  operation {group {folder{ track | point name}}}, percentage x.y%

Of my 1000's of recorded tracks, there is no single huge track that could be 5% (53-48%) of progress, so why does the percentage jump in such big amounts?

And on completion, instead of just a glib "Congrats", maybe a button or in-place summary, to # tracks & points that have been updated/ deleted/ created plus total time # minutes. This would give the user much greater confidence in the sync operation, and great diagnostic ability in a user-friendly manner.

The complete cloud sync took 75 minutes which is much slower compared to previous full downloads during beta testing. The Locus servers are probably working a lot harder now than during beta testing, but this would be concerning if the time to sync gets slower & slower.

Possible bug: the current operation (deleting/ downloading/ uploading) sometimes doesn't reflect actual operation - in subsequent manual sync the only operation should have been "downloading tracks", but I only read "deleting points" & "deleting tracks". The final result (# tracks) was OK.

BUG: https://help.locusmap.eu/topic/24105-route-created-in-web-planner-does-not-sync-to-mobile-app - confirmed.
LM4.12.0 GOLD user ID:142d400c7
  •  

dyoghenes

Quote from: dyoghenes on April 09, 2021, 11:51:13
I couldn't post to helpdesk so I write here.
Yesterday I changed a lot of my folders and groups in the app but I forgot to turn off automatic sync. It tried to sync after every little thing I changed.
The problem is, syncing is now crashed. When I try to sync, it stays at 1% (tracks downloading), then the whole app crashes. Resetting the app did not help. Trying just to compute the syncing plan in the advanced settings gives the following error code: "rr$!, code: -1"

Please help, how could I solve this without redoing everything?

The new update (4.0.2) solved it for me. Thank you for this great support!
  •