[APP] - version 3.40.+ ( 2. 10. 2019 )

Started by Menion, October 02, 2019, 13:38:28

0 Members and 2 Guests are viewing this topic.

Menion

Important links
- blog post about major version
- list of news of public versions

Versions
2. 10. 2019 - Locus 3.40.0
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Žajdlík Josef

Trifle. Autopreset Navigation setting has not been set after restoring PRO version from Beta. Obviously, it is not backed up.
  •  

Menion

Really weird, should be. There is no exception for any settings in the app.

Are you sure you restored a fresh backup from the Beta version? If so, I'll try to invest it precisely.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Tapio

#3
Big release, thx, will test happily.
First finding: GPS is started on Locus startup, but I have set it to "Never" in the GPS&SENSORS options.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •  

Žajdlík Josef

Quote from: menion on October 02, 2019, 18:01:43
Are you sure you restored a fresh backup from the Beta version? If so, I'll try to invest it precisely.
Yes, but maybe there was an error.  Normally, after the data recovery, a version change screen will appear.  This time, the screen did not appear after an automatic restart.  But everything has been restored except for those navigation presets.  So I set them up manually.  The next time Locus was started, the instruction screen was shown.  It is therefore possible that the first restart was not performed correctly.
  •  

Viajero Perdido

On both my daily-use devices (Android 6 & 7), after installing 3.40, Locus was gone from the quick-launch panel at the bottom of the home screen.  (It gets the premium corner spot.)

Minor but interesting.  It was easy enough to put back.  :)
  •  

balloni55

QuoteOn both my daily-use devices (Android 6 & 7), after installing 3.40, Locus was gone from the quick-launch panel at the bottom of the home screen
confirm
Locus Map 4.24.3 Gold AFA

LM4 User ID e06d572d4
  •  

Tapio

A tasker task also failed calling the app. I had to point the "Launch app" command to Locus again.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •  

Menion

@tapio
this is interesting. Only idea: automatic live tracking or automatic track recording after the app start? I'm using this setting as default and never had a problem with it. Btw. does it happen always to you when you previously correctly (by double-back) close app?

@Žajdlík Josef
I've just tried restoring the backup from one version to second and it works correctly, so seems to be some temporary one-time glitch. Let's hope :).

@Viajero Perdido, @balloni55
expected behavior, hope not a big problem. I had to change the first starting screen to something different (because of speed optimization of start itself) and the result is, that the old "start icon" does not work so the system removed it.

And tasker task ... if you have any task hardcoded on certain activity within Locus then yes, this is broken with current version.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

CabrioTourer42

Question. What does the purple color mean in route planner?
My last point of track in picture is 15.
Even if I set a following shaping point on the purple line it will not draw a green line over it. Means except increasing track length nothing visual happens which is a bit weird.
  •  

syni

#10
GPS coordinates in the upper toolbar not shown correctly (at least in the Singapore area) after the update to 3.40, please see screenshot.
  •  

Tapio

#11
Quote from: menion on October 03, 2019, 08:56:10
@tapio
this is interesting. Only idea: automatic live tracking or automatic track recording after the app start?
No, no track recording etc. at start. Idk, now behaviour is gone. I always exit it via menu entry, because it runs as a service. Let's leave it like that.
EDIT it does simply start with the gps state of last session. But I chose the option to have it off at start. See my video. Feels like it is related to the quick startup behaviour. You can see the super quick start of Locus. As if the Locus session stays active after exit Locus.

https://youtu.be/JGxiNqCrUuQ
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •  

Tapio

#12
Track preview is not showing map/theme. Tested with oam+volUk and also Google Sat (online).
May I ask, is there a possibility to define the images resolution? Or even other (hidden) options? Currently it seems fixed and no such option in configuration file...
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest
  •  

CabrioTourer42

Planned route lost shaping points and via points. Couldn't find a reliable way to reproduce.
  •  

joeloc

Is it just me or does Locus (latest pro) forget what map items (kml/gpx files) are enabled on every restart? I remember those were kind of permament once, but now they are all gone on each new start. Very painful, especially since the UI to enable them again is a clicky tappy horrible inconsistent mess :-).
  •