Author Topic: Off line map is not loading!  (Read 842 times)

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Off line map is not loading!
« on: March 10, 2019, 17:45:44 »
Hello everyone,
I would like to share with you one of the problem I am having recently. Couple of days ago, I bought 'John Thornmap' from Locus store. After downloading and playing with this map, my offline vector map (England, previously bought) doesn't load any more. Also 'John thornmap' is displaying night mode I believe, as deep black shadow every where in the map. I am using Locus app nearly 8 years or so. Never faced this issue. I tried all the trouble shooting including disabled /enabling auto load offline map, enabling /disabling night mode, clearing cache, restarting app and phone couple of times. I am using Huawei 10 View. Any help will be appreciated regarding this, please.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11390
  • Thanked: 305 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Off line map is not loading!
« Reply #1 on: March 10, 2019, 23:45:22 »
Hello,
this looks like some problem with the theme you use for your map.
What vector theme is enabled when you use this map?
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Re: Off line map is not loading!
« Reply #2 on: March 10, 2019, 23:52:24 »
I am using GB style.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11390
  • Thanked: 305 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Off line map is not loading!
« Reply #3 on: March 12, 2019, 10:43:22 »
Thanks bbairagee
have to say, this problem is a nice mystery to us. I'll keep you informed when we find something.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Re: Off line map is not loading!
« Reply #4 on: March 12, 2019, 11:25:43 »
Thanks for the reply. I played with all the themes. This problem is only with GB style theme. I have been using this theme since long. It happened after purchasing John thornmap. I don't know if any relation with it. In John thornmap all green areas are deep black and sometime it loads partially in GB style theme. Hope some one will find the bugs soon.
 

Offline john_percy

  • Master of Locus
  • ****
  • Posts: 678
  • Thanked: 94 times
    • View Profile
  • Device: MotoG
Re: Off line map is not loading!
« Reply #5 on: March 12, 2019, 13:46:27 »
Have you tried reinstalling the theme?

Sent from my moto g(6) plus using Tapatalk

 

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Re: Off line map is not loading!
« Reply #6 on: March 12, 2019, 13:59:10 »
Nope. Even I forget how to do that. Thanks.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11390
  • Thanked: 305 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Off line map is not loading!
« Reply #7 on: March 13, 2019, 09:59:25 »
Interesting here is that maps from John Thorn come together with a map theme. So every time you download a map, it is also downloaded a GB theme. This means the latest maps have a new theme and mainly the same map I and you download, have the same theme. And we both see maps differently.

I'll look on this deeper tomorrow and let you know what I find.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Re: Off line map is not loading!
« Reply #8 on: March 13, 2019, 22:50:05 »
I have sorted the problem out by deleting the map including style and re-downloading map. It is working as expected. Thanks for all the helps.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11390
  • Thanked: 305 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Off line map is not loading!
« Reply #9 on: March 14, 2019, 08:41:54 »
Ah thanks for info. If this helped, then it looks like app is incorrectly downloaded and extracted theme attached to your map in case, the same theme already exists (so "overwrite" works maybe incorrectly). I'll look at it, thanks!
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Re: Off line map is not loading!
« Reply #10 on: May 23, 2019, 14:35:59 »
Hi Dev,
The problem came back again. Can I get some help that will sustain, please. Not very practical for deleting and re-downloading the map.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11390
  • Thanked: 305 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Off line map is not loading!
« Reply #11 on: May 23, 2019, 17:08:50 »
Hello bbairagee
sorry for these troubles. I've implemented for "theme creators" small tool to check if the theme is correct and thanks to this I've found, that map theme from John Thorn (creator of these maps & theme) has a small issue (three missing icons) that may cause these troubles. We already contacted him and let you know immediately once we will have some news. Thanks!
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline zossebart

  • Apprentice of Locus
  • **
  • Posts: 157
  • Thanked: 20 times
    • View Profile
  • Device: Sony Z1 Compact
Re: Off line map is not loading!
« Reply #12 on: May 24, 2019, 05:18:28 »


Hello bbairagee
sorry for these troubles. I've implemented for "theme creators" small tool to check if the theme is correct

I would be very intetested in this tool! Could you make it available somehow? I'm currently converting a v3 theme to v4+ having some problems. The theme loads in Locus now, but after a few rendered tiles, locus gets stuck and eventually closes.
Maybe this tool could give me a hint where to look?
Xmllint with the latest schema is nearly happy with the scheme and also cruiser on desktop displays it without delays...

Gesendet von meinem D5503 mit Tapatalk

 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11390
  • Thanked: 305 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Off line map is not loading!
« Reply #13 on: May 24, 2019, 09:15:23 »
Sure, it is already there for these cases.
Just long click on any theme in the list of themes in the app and choose "Validate".
This feature currently searches for all external files (icons) and check if they exist. This cause usually most of the troubles so this is a nice tool to check if nothing is missing.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline bbairagee

  • More than Newbie
  • *
  • Posts: 47
    • View Profile
Re: Off line map is not loading!
« Reply #14 on: May 24, 2019, 13:41:46 »
Hi,
When I tried validation I got error message. Please see the screenshot for details.