Author Topic: 1.5.2 not saving settings problem  (Read 1297 times)

Offline userloser

  • More than Newbie
  • *
  • Posts: 20
    • View Profile
1.5.2 not saving settings problem
« on: April 20, 2011, 19:08:01 »
Since my second upgrade today, I cannot make Locus Pro save settings.

Here is what I did:

1. Some days ago, I upgraded to 1.5.2 without reading the notice. Some maps went missing.
2. Yesterday, I uninstalled 1.5.2 and restored 1.5.1 from backup via ADB.
3. This worked for awhile, until I suddenly got a "Your application isn't licensed" error.
4. Subsequently, I installed a custom provider.xml and upgraded to 1.5.2 from the market.
5. The "Your app isn't licensed" error disappeared, but Locus pro doesn't save any settings now.
6. Uninstalling and reinstalling or downgrading the app doesn't fix the problem.

Every time I restart it, I get the "Basic info" screen, the app starts with the default settings, and I have to redo all my preferences (e.g. full screen, tracking distances, GPS preferences, etc.) by hand. I assume this is a permissions problem resulting from the multiple installs/uninstalls - any ideas where to start looking to fix it?

Thanks,
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11438
  • Thanked: 317 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: 1.5.2 not saving settings problem
« Reply #1 on: April 20, 2011, 19:22:05 »
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline berkley

  • Premium
  • Master of Locus
  • ****
  • Posts: 900
    • View Profile
  • Device: 1+1, N7
Re: 1.5.2 not saving settings problem
« Reply #2 on: April 20, 2011, 19:30:41 »
Common problem on SGS 2.2.1 :D
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Search before posting!!!
XDA Orbit, HTC Touch HD, SGS1, SGS2, Nexus S, S4 Active, OnePlus One, Innos D6000
OnePlus X
 

Offline userloser

  • More than Newbie
  • *
  • Posts: 20
    • View Profile
Re: 1.5.2 not saving settings problem
« Reply #3 on: April 20, 2011, 19:33:33 »
thanks, I fixed it already the "hard" way, with chmod. i'll see if your link has a better solution.
« Last Edit: January 01, 1970, 01:00:00 by Guest »