[APP] - version 3.17.x (16. 5. 2016+)

Started by Menion, May 16, 2016, 15:36:07

0 Members and 1 Guest are viewing this topic.

JoxM

Nice work again, but there is a bug in the geocaching logging section.
If you want to log there is only a single line to write into. Even on a   RETURN there is no linebreak.
  •  

Menion

@Christian: small mystery ... try to clear also a cache on your SD card in /android/data/menion.android.locus.pro/cache/map/shading/hillshading (or something like this).

@jusc: there should be no change. Just check "version" parameter in top of your themes. Version 1 is used for MapsForge V3 maps, version 4 for MapsForge V4 maps.

@poutnikl: yes, agree. In case you will plan route over same place in one route, there is possibility that Locus cause some mess there. Have to improve it ...

@JoxM: ah thanks, I'll check it
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Christian

Quote from: menion on May 17, 2016, 20:27:35
@Christian: small mystery ... try to clear also a cache on your SD card in /android/data/menion.android.locus.pro/cache/map/shading/hillshading (or something like this).
Sdcard is broken. No card = no cache on card :)
Tomorrow i will buy a new card.
  •  

gynta

#18
track export 2 Strava -> typ -> virtual ride = twice



edit
...but "WeightTraining" is missing

Andrew Heard

Quote from: poutnikl on May 17, 2016, 16:53:47
So simple routing works fine . The issue reportedly ( Andrew, 0709 ) occur if the route goes through some trackpoint more times,
therefore there is multiple trackpoints and waypoints with the identical coordinates.  ( I cannot yet confirm )
@poutnikl no my example was just the "general case" of single waypoint corresponding to multiple track points. But it may be "red herring". Real problem is here - http://forum.locusmap.eu/index.php?topic=5119.msg42845#msg42845.
LM4.14.1 GOLD user ID:142d400c7
  •  

bobo20141010

"MAP SHADING-Enable-TYPE" hoping to multiple choice
  •  

poutnikl

Quote from: Andrew Heard on May 18, 2016, 02:57:05@poutnikl no my example was just the "general case" of single waypoint corresponding to multiple track points. But it may be "red herring". Real problem is here - http://forum.locusmap.eu/index.php?topic=5119.msg42845#msg42845.

That is strange, as I got for multiple identical trackpoints multiple identical hint waypoints ( but with different hints ). I just thought Locus interpreted them incorrectly - and Menion confirmed this may be a trouble and will try to fix it.

But I may have got it incorrectly your report.

jusc

Quote from: menion on May 17, 2016, 20:27:35

@jusc: there should be no change. Just check "version" parameter in top of your themes. Version 1 is used for MapsForge V3 maps, version 4 for MapsForge V4 maps.


Thanks, this works, but what was the reason to change it? I never thought about this.
Regards J.
  •  

Menion

@Christian: if SD card is broken, then same directory will be in internal memory ;)

@gynta: thank you! Copy & paste issue, second "Virtual ride" is a "Weight training". Such options, crazy ... hike & bike should be enough :)

@bobo20141010: I was thinking about adding some more options to shading ... well we will see interest on our help desk

@jusc: there were some complains that Locus use modified version of MapsForge and do not follow "standard". After long thinking, I decided to insert complete 0.6 version of MapsForge to Locus, but I needed to keep it separate from old system. Not just a map, but also a themes. So in new version of Locus it's separated and you may use maps in V4 format, but only with V4 themes. These themes cannot be used in "older" maps, that use modified version of mapsForge. To be true, main reason here is a simplicity on my side as a developer.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Christian

All subfolders in internal cache are empty.
(Cleared cache yesterday)
  •  

Andrew Heard

#25
@menion - regards "chg: connection to GPS automatic restart in case of connection troubles" - I have now experienced twice that GPS never starts if the device has been inside with GPS disabled for few hours then I run Locus outside with GPS enabled. The satellite map just sits with nothing on the map forever:


It makes no difference if I disable > re-enable the GPS from the satellite map.

Only workaround (so far) - drag down Android top notification panel > disable Location > enable Location > then from Locus satellite map disable GPS > enable GPS > then satellites appear as normal, fairly quickly.
LM4.14.1 GOLD user ID:142d400c7
  •  

poutnikl

Regarding GPS troubles addressing...
when I got GPS lock lost, the Locus was happily beeping every 10s until last lock was more then 2 minutes old.
Than I did my verified manual trick ( cca 75% efficiency ) -  switching on GPS Locus screen the GPS manually OFF and after 5+ s back ON.
And voila - working again. As I have said before, the OFF interval may matter.

sabaca

In my Note 3 Locus crashes at startup
  •  

gynta


Menion

#29
@Andrew: hmm I'm almost sure that my small change should have no influence on this. I may disable it, as it's just one line of code, but it really should work without a problem.

Do you have exact steps I may follow to get exactly same problem?

I'm trying to play with it little bit, but GPS is always turned of correctly in Locus, hmm :/.

EDIT: maybe I've found some weird combination, so next version probably during weekend, thanks
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download