[APP] - version 3.17.x (16. 5. 2016+)

Started by Menion, May 16, 2016, 15:36:07

0 Members and 5 Guests are viewing this topic.

Menion

GPX file will be fine, thanks.

Discard of track: it should really happen only in case, no single trackpoint is recorded. Maybe forget to enable GPS, maybe no GPS signal at all? Don't know if I Locus should notify that "No trackpoint is recorded, really discard?" Will be such question better and more logical for you, then simply "nothing" as now?

And maps ... hmm. If overlay has only level 12, then in level 18/19, it will be completely disabled, so it's correct. But why it is draw as black, it's a question. Some incorrect combination o transparency and some blend mode maybe? But again ... be able to simulate this problem is a key for me ... unfortunately :).
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

michaelbechtold

0709 found the smoke of this gun.
The duration points to Jan 1, 1970, the beginning of Unix time counting ...
  •  

Menion

Yes I know it will be this value, because this value has absolute value of milliseconds equal exactly "0". But I wanted to know, how this value appear in Locus. Oki, I'll try to play with it little bit.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Menion

Thanks for an email Michale (btw, please change your support email to locus.map@asamm.com . Email you used is not longer used).

Seems you were a victim of one small issue on previous version. On the end of recorded track is one single invalid point. Exported file looks like:

    ....
    </trkpt>
    <trkpt lat="49.985613" lon="9.138136">
    </trkpt>
  </trkseg>
</trk>
</gpx>


Last point is without a time and other values. I'll try to fix it on Locus side, thank you.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download

michaelbechtold

TXs Menion.

Maybe this irregularity could be related to the track closing without commit to DB ? Both are random effects that smell like uninitialized object, i.e. random content with unpredictable effects. Just guessing.

Good luck in any case.

Cheers
Michael
  •  

Menion

Yes. Issue happen when I changed order of some conditions and when you disabled GPS and THEN! tapped on "Stop" of track recording, one more point was also saved into database. But is wasn't a point from GPS, but already an empty map center with zero speed and maybe also invalid coordinates. Not sure if this is fixed in last public version (think so), but it's definitely fixed in Beta version.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Menion

Hello guys,

wish you a nice weekend. New beta 3.17.2.4 is out if you will to do some tests before release of final version (maybe next Thursday).
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

balloni55

 New beta 3.17.2.4
- map folder naming > solved :)
- activity change inside save dialog is considered now > solved :)

thanks ;)
Locus Map 4.24.3.3 Gold AFA

LM4 User ID e06d572d4
  •  

joeloc

#113
Unless Locus finally finds an intelligent way to deal with multiple labels, i guess the panoramio layer and also the georeferenced photos layer need to default to "show Labels on hover" Mode. Otherwise they simply cover too much of the map to be useful.


Suggestion for intelligent Labels from 3 years ago: http://help.locusmap.eu/topic/more_intelligent_display_of_many_waypoints

Now more important than ever :)

Ps, also... the waypoint Name for geotagged pictures seems to uppercase the first letter of the picture Name. That's weird, it shouldnt be changed at all.
  •  

lor74cas

Quote from: joeloc on June 19, 2016, 09:03:54
Unless Locus finally finds an intelligent way to deal with multiple labels, i guess the panoramio layer and also the georeferenced photos layer need to default to "show Labels on hover" Mode. Otherwise they simply cover too much of the map to be useful.


Suggestion for intelligent Labels from 3 years ago: http://help.locusmap.eu/topic/more_intelligent_display_of_many_waypoints

Now more important than ever :)
I also suggest to apply a date filter on geotagged photos, as you can see it works but if you have to much photos it's a mess.


Inviato dal mio SM-G800F utilizzando Tapatalk

Locus Map 4
Locus Map for Garmin
Locus Tasker
  •  

Andrew Heard

Sorry if this has already been discussed. I have noticed that any track point that doesn't have a timestamp results in displayed statistics Total time of  100,000s of hours. Simple to reproduce - just edit GPX file, delete time, import. Can I suggest these tracepoints are ignored for this time calculation?
LM4.24.3.4 GOLD user ID:c7d47597a
  •  

michaelbechtold

Quote from: menion on June 13, 2016, 15:11:36
GPX file will be fine, thanks.

Discard of track: it should really happen only in case, no single trackpoint is recorded. Maybe forget to enable GPS, maybe no GPS signal at all? Don't know if I Locus should notify that "No trackpoint is recorded, really discard?" Will be such question better and more logical for you, then simply "nothing" as now?

And maps ... hmm. If overlay has only level 12, then in level 18/19, it will be completely disabled, so it's correct. But why it is draw as black, it's a question. Some incorrect combination o transparency and some blend mode maybe? But again ... be able to simulate this problem is a key for me ... unfortunately :).
Some more food for the black tile invasion issue in case of overlay: if you have black tiles and then click on overlay button, they are immediately displayed with correct map data.
Effect is the same since a number of betas, incl.  very latest.
As I have seen that only on the LG G5, which is damn fast,  this may be a timing issue.

Gesendet von meinem LG-H850 mit Tapatalk

  •  

michaelbechtold

P.S.: and it only happens on the currently visible map page. When scrolling away, the vector map is correctly shown. Going back to the initial page will show a correct vector map, too,  using the very latest beta. in earlier betas this was not the case,  as far as I remember. You had to play around longer to get rid of the black tiles.

Gesendet von meinem LG-H850 mit Tapatalk

  •  

john_percy

I don't think the black tiles are necessarily connected to overlays. If I change the theme on a vector map I occasionally and irreproducibly may get a black tile or two.
Voluntary and Velocity themes - https://voluntary.nichesite.org
  •  

john_percy

"Mute sounds navigation"does not mute out of track notifications.
Voluntary and Velocity themes - https://voluntary.nichesite.org
  •