Author Topic: Geocache icons not displaying properly  (Read 654 times)

Offline szebenyib

  • Apprentice of Locus
  • **
  • Posts: 176
  • Xperia P
    • View Profile
Geocache icons not displaying properly
« on: May 09, 2015, 20:58:46 »
Hi!

I have not been following the newest versions of Locus unfortunately but I have noticed a bug that may have started to appear in Locus. It can be a bug in the source website, in my code, or in Locus. I have tried my best to check the source code and it should not have changed important parts that could influence this phenomenon.

The problem: the geocache icons are replaced by the folder's icon in which they are imported

Steps to reproduce:
1: download my file: https://www.dropbox.com/s/w7ejvm2lukwfibu/2015_budaihg_converted.gpx?dl=0
2: import it into Locus (I have tried it with Locus Pro 3.5.3, Locus Free newest beta and different devices)
3: see the result:
All green and multi cache icons are gone and the brown info icons of the folder are present. If I changed the folder's icon then it was visible on the icons on the map as well.

(Don't mind the reddish screen it is because of the twilight app).

Menion if you have some time can you please look into this? As far as I know the source website has not changed since it was working properly (the last time that happened it was visible and came to the sunlight very fast) and my converter has not changed either. Nevertheless it can still be a problem that is not in Locus.


« Last Edit: May 09, 2015, 21:26:59 by szebenyib »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11486
  • Thanked: 329 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Geocache icons not displaying properly
« Reply #1 on: May 09, 2015, 22:05:05 »
Quick check, problem is here:

Code: [Select]
<groundspeak:type>Found it</groundspeak:type>
Here should be real type of cache, like "Traditional cache" or "Multi-cache". Locus is not able to recognize type of cache.

If cache was found or not, is usually defined by <sym>Geocache Found</sym>

Hope this helps.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline szebenyib

  • Apprentice of Locus
  • **
  • Posts: 176
  • Xperia P
    • View Profile
Re: Geocache icons not displaying properly
« Reply #2 on: May 12, 2015, 06:19:14 »
Oooo, thanks for the quick help!
I don't know when this has changed and where but I am happy because it is solvable :)