Offline navigation - GraphHopper - preparation

Started by Menion, July 16, 2014, 20:43:19

0 Members and 1 Guest are viewing this topic.


Something must have been changed from version 0.1.5 onward, because with that version I could even use a graph generated for DACH! without any issues. Okay it was rather slow, but it worked. Now, starting from version 0.1.6 I miss the icons to start navigating (car, foot etc.). I'm using the latest version from play store (3.10.0) on my xperia z1c, using android 4.4.4 (firmware .108). Any ideas, what causes that?
Kind regards

Okay, after some testing and generating routing data for Eastern and Western Germany, as well as comparing the size of routing data for France, it seems that the new graphhopper addon since version 0.1.6 has problems with routing data above 1 GB. Unfortunately 0.1.5 doesn't work anymore in Locus Pro 3.10, but it worked without a flaw in the previous version together with routing data way above 1 GB (Germany, DACH). Could you please look into this? Thanks in advance.

By the way, I like the graphhopper navigation because it includes most street names, but brouter creates better and more logical routes imho.


There's version 0.1.7 on google drive. What's new?


Bucky Kid

Hello there

Please advice how can I run import <your-osm-file> on Windows

Running this in MSYS produces an error complaining something about Java, I can't process further

Thanks for help!

$ bash ./ import czech-republic-latest.osm.pbf
## using java  from
## using existing osm file czech-republic-latest.osm.pbf
./ line 82: mvn: command not found
## existing jar found tools/target/graphhopper-tools-0.5-SNAPSHOT-jar-with-dependencies.jar
## now import. JAVA_OPTS=-Xmx10200m -Xms1024m -server
./ line 253: java: command not found

Btw. what are changes in add-on 0.1.7 ?


I have become fascinated by Locus Map since I installed it a couple of weeks ago.  Now, I read about GraphHopper with interest and would like to try it.  I have read and re-read but do not understand fully what I should do.  I wonder, might it be possible to compile and provide a fresh step-by-step process for Android mobile 'phone users like me who are full of enthusiasm but lack confidence and knowledge to undertake some tasks?  Additionally, I noted John Percy's reference to a British Isles osm.pbf file from  I have used Geofabrik in conjunction with my Garmin eTrex Legend and wonder whether this data source has advantages or whether it is simpler to take data from the link menion describes in his initial post of the link above?
Incidentally, where lie the differences between, or preferences for, the forum or the help desk?  I discovered the help desk quite by chance, recently.


Quote from: silvermapper on July 25, 2015, 17:52:57I have read and re-read but do not understand fully what I should do.
Hmm ok,and how can we help you? because what u read is all what you need to install.

Is your problem the installation of GraphHopper or it's difficult for you to understand how it works any of this routing services inside Locus? Or is it the creation of your own graphhopper routing profile?


I thank you for your reply.
1. I read the forum on my Windows PC.  Therefore, I would download the addon_0.1.7.apk file and routing data from the links to Google Drive provided to Windows Explorer in the first instance.  Is that the correct procedure or should everything be carried out on my 'phone?
2. The routing data I wish to use is at 2015.06.05>europe>united_kingdom.  It appears in the form of,, etc.  I do not see a file or file, nor does the United Kingdom folder appear to be a .zip folder.  Clicking presents a folder, england.osm-gh.  The only way I see to download it is that when a cursor is moved, a downward facing arrow appears which, when a cursor is placed over it, reveals 'Download'.  Clicking this presents 'Google Drive can't scan this for viruses' and 'Download anyway',  This I did to Windows Explorer again and extracted all the files.  Do I copy the resulting england-gh folder or the folder within it, england.osm-gh, or does it not matter which?
3. Having downloaded the addon_0.1.7.apk file, I have no idea how to install it on my 'phone let alone where.  Do I copy it, use 'Send to' or am I in the wrong place, completely, anyway?
I do hope you understand that what is a straightforward exercise for so many presents me and some others, presumably, with such issues.  That is why I should appreciate more explanatory help.


use google search: "how to install apk on android"
extcract the zip and copy "england.osm-gh" folder to .../Locus/mapsVector/


 It is a question to voldapet: Where is United_Kingdom_gh_zip??
Zufall ist, wenn das Schicksal eine Maske aufsetzt, um nicht erkannt zu werden.  (Wepper)


Thanks, gynta.
Just to be sure: is there a particular place to which the .apk file should be copied before installation for GraphHopper to work with Locus Map and the chosen routing data?


Quoteis there a particular place to which the .apk file should be
no - and after install the apk - you can throw it in the trash

Quote from: KaHeMu on July 26, 2015, 11:10:16
It is a question to voldapet: Where is United_Kingdom_gh_zip??
good question - but not for Petr :)
Whole UK (England, Scotland, Wales and Northern Ireland) has 470MB - not a big deal to offer a all in one file - isn't it Menion?


Now, I'm becoming a pain.  I reached so far as changing the data source from MapQuest to GraphHopper when something happened: A message displayed stating, "Unfortunately, Locus Pro has stopped."  Each time I open it a window displays briefly that I do not have time to read properly but is headed, Working..." then "Previous State".  I have powered down the 'phone twice but to no avail.  The same message appears as soon as I select 'Navigate to' in 'FUNCTIONS' or its icon on the side panel.  My set up is as follows: the GraphHopper routing data for England and my file are both in Computer\XT1039\Internal storage\Locus\mapsVector.  Is it likely that the map file has to be of England alone, also?  I should appreciate any help because I am so interested to get GraphHopper up and running.


Do you have an old "graphhopper" folder inside locus?

Please create screenshots (like i do above) from your file structures.



This is my first time attempting to use GraphHopper.  I placed addon_0.1.0.7.apk in the root of my internal storage and installed it from there.  Its 'Properties' dialog dispalys a package name,  A search of internal storage shows file of 0 bytes.  I do not begin to know the relevance of this but give it to you in case it helps.
I attach the three screenshots you requested.  I  note that I have an intermediate folder, sdcard0\Locus\mapsVector\england-gh.
I thank you for your continued assistance.


QuoteI note that I have an intermediate folder, sdcard0\Locus\mapsVector\england-gh
Please see my screenshot again and compare!