Author Topic: TTS voices  (Read 61405 times)

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11605
  • Thanked: 353 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: TTS voices
« Reply #90 on: April 03, 2015, 18:46:50 »
Ah I'm checking what I did in code and indeed, all defined containers needs to have at least one item, sorry. So for numbers, I'll improve this to next version.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11605
  • Thanked: 353 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: TTS voices
« Reply #91 on: April 04, 2015, 11:48:56 »
Answer to problem mentioned by ta-ka here: http://forum.locusmap.eu/index.php?topic=4467.msg35838#msg35838 - missing notification for 1 hour, 0 minutes

Issue was in TTS file, where were no configuration for '0' minutes. Please check modified EN or CZ file what I mean (extra '0' parameter in TIMES_T1 container.

I should today publish one quick special version right here on forum, so if you modify these TTS files, I'll include them into version. Same with Crowdin, thanks!
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #92 on: April 04, 2015, 14:43:26 »
@menion thanks for the fix of 0 minutes issue.

updated ja.tts : "numbers_N1" is empty now.
fixed en.tts : 's' after mile was missing at "%N1 mile per hour, 2, Inf"

EDIT:
crowdin done. (except Locus GIS, sorry for that)
« Last Edit: April 04, 2015, 16:55:13 by ta-ka »
 

Offline gynta

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 3553
  • Thanked: 40 times
    • View Profile
    • Locus live tracking service
  • Device: SM-A530F(A8) Android 8.0.0
Re: TTS voices
« Reply #93 on: April 04, 2015, 14:55:07 »
damn
 that means, my file also need a fix...
brb :)

edit
done (tts and crowdin)
thx ta-ka!
« Last Edit: April 04, 2015, 15:14:07 by gynta »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11605
  • Thanked: 353 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: TTS voices
« Reply #94 on: April 04, 2015, 15:05:26 »
thanks guys
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #95 on: April 05, 2015, 08:25:41 »
The warning popup message reported in post #89 still appears in version 3.7.1.4.
Haven't it fixed yet?  Or, is there anything wrong in ja.tts at google drive?
Could you please have a check?


 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #96 on: April 05, 2015, 09:25:30 »
About Training, I've noticed that Locus pronounces annoying 'comma' between variables if Japanese voice is selected. Could you please improve this?
 

Online balloni55

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 2595
  • Thanked: 109 times
    • View Profile
  • Device: Samsung XCover 4s Android 9
Re: TTS voices
« Reply #97 on: April 05, 2015, 09:40:54 »
Quote
I've noticed that Locus pronounces annoying 'comma' between variables
i noticed the same if i use Samsung TTS :-[, if i use google TTS it work for me :)
Locus PRO 3.44.1
 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #98 on: April 07, 2015, 18:34:27 »
@ta-ka, problem with comma should be a problem. It's weird that TTS reads it, weird. Google TTS or Czech Ivona TTS reads it correctly - just as a small break. Hmm ...

Is the adding 'comma' hard coded in the program source? If so, how about to take it out to ??.tts/crowdin text as a parameter.

Code: [Select]
"short_pause": ",""short_pause" can be 'comma' or 'white space' or any other appropriate character depending on Language and TTS engine.

Btw, reading balloni and your post, I confirmed Japanese Google TTS doesn't speak comma, too.  However KDDI N2TTS speaks comma...
 

Offline gynta

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 3553
  • Thanked: 40 times
    • View Profile
    • Locus live tracking service
  • Device: SM-A530F(A8) Android 8.0.0
Re: TTS voices
« Reply #99 on: April 07, 2015, 23:06:25 »
@ta-ka: adding "separator" to tts is not something I want. Main reason why TTS file was created, is to be able to define some special texts that will TTS engine read correctly. Because some TTS engines reads this correctly, some not, I'll try to think and find some general solution.
Seems it is a long known global problem: https://code.google.com/p/ankidroid/issues/detail?id=907 and some other pages
Hmm as I think about it, I'll try to next version add a dot instead of comma.

However KDDI N2TTS speaks comma...
Think "KDDI N2TTS" only known in asia? Isn't it?
So can't check this TTS-engine.

After some tests with "IVONA" "Samsung" "SVOX" and "Google":

SamsungTT german "Hallo , Peter" read a "comma"
SamsungTT german "Hallo, Peter" ignores the "comma"
SamsungTT english "Hello , Peter" ignores the "comma"
SamsungTT english "Hello, Peter" ignores the "comma"

Only the combination "Hello-space-comma-space-Peter" with german Samsung brings a problem.
All other TTS-engines and combinations ignores the "comma"

@Menion is there any "%X-space-comma-space-word" combination inside Locus TTS?
should be "%X-coma-space-word".
« Last Edit: April 08, 2015, 16:23:30 by gynta »
 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #100 on: April 08, 2015, 06:20:52 »
I post here about the discussion of comma and tts.

I'll try to think and find some general solution.
Hmm as I think about it, I'll try to next version add a dot instead of comma.
I'm afraid but "dot" won't be a general solution. I confirmed it is literally pronounced by N2TTS as shown in a video below.
https://www.dropbox.com/s/a99451wtokegpz0/20150408_tts_comma_period.mp4?dl=0

Main reason why TTS file was created, is to be able to define some special texts that will TTS engine read correctly.
Because some TTS engines reads this correctly, some not,
To read, or not to read, that is the question. 8)
Since "," and "." are not punctuations but special symbols in Japanese, it makes a sense that N2TTS pronounce it literally. On the other hand, it is known that "," and "." are punctuations in a lot of languages in the world. So, it also makes a sense that Japanese Google TTS doesn't pronounce it but put a pause for convenience. Which is correct?  It is difficult to say.

Japanese punctuations are "、" and "。" which correspond "," and "." respectively. When we read Japanese text, we put a short pause at "、" and a longer pause at "。". (We learn it at primary school ;)) Please note that both Google TTS and KDDI N2TTS put a pause on "、" and "。" and don't pronounce them. It is correct behaviour.

adding "separator" to tts is not something I want.
Then how about to introduce punctuations entry in tts file and put it between variables? (period is for further compatibility.)
"comma": ","
"period": "."
In fact, I usually translate "," to "、" in ja.tts and crowdin.

Think "KDDI N2TTS" only known in asia? Isn't it?
So can't check this TTS-engine.
@gynta Thanks for trying to test even Japanese TTS :). I think it is Japanese language specific TTS. Is it possible to open google play with this url?
https://play.google.com/store/apps/details?id=jp.kddilabs.n2tts
If it's not successful, you may try apk downloader.
« Last Edit: April 08, 2015, 10:23:36 by ta-ka »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11605
  • Thanked: 353 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: TTS voices
« Reply #101 on: April 08, 2015, 07:53:05 »
Very nice explanation, thank you!

Then check TTS files, added:

        "special_comma": ", ",
        "special_period": ". "

hope it helps
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #102 on: April 08, 2015, 10:28:37 »
Thank you for quick answer and decision as always!

And, please fix empty "numbers_N1" issue (post #89) as well. ;)

EDIT:
updated ja.tts
« Last Edit: April 08, 2015, 13:15:54 by ta-ka »
 

Offline ta-ka

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 250
  • Thanked: 3 times
    • View Profile
  • Device: SGNoteEdge
Re: TTS voices
« Reply #103 on: April 16, 2015, 02:51:16 »
I've confirmed that the warning message "incorrectly initialized action %N1" still appears in 3.7.1.6 and in this case the voice system of Locus falls back to crowdin text base. I'm sure that empty "numbers_N1" in tts file cause the issue and it's possible to reproduce it by using attached en.tts.

Now, I would like to ask again whether empty "numbers_N1" is a valid format or not. If valid, please fix the issue to properly load tts file. (for both tts file integrated in Locus and placed at data/tts folder.) If invalid, I'll re-modify ja.tts at google drive with non-empty "numbers_N1".

 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11605
  • Thanked: 353 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: TTS voices
« Reply #104 on: April 16, 2015, 08:50:42 »
Ah I had a check for valid amount of items in number_X folder on two places, not just on one. Sorry, fixed, thanks.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!