Author Topic: 1.6.1 deleted everything!  (Read 3422 times)

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
1.6.1 deleted everything!
« on: November 03, 2012, 08:32:45 »
I've just updated from 1.5.x to 1.6.1 and now all my tracks and points and categories are gone! The files are still there in sdcard/Locus. Maps are OK.

I just wanted to report how much I like the new category dialogs, but it seems that the merging didn't happen well! Can you send me some versions from 1.5.x to try to re-install that and see if I can get back the data? I'd be happy to help debugging!
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11353
  • Thanked: 293 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: 1.6.1 deleted everything!
« Reply #1 on: November 03, 2012, 08:39:01 »
you updated from 1.5.x to 1.6.1?? But current market version is 2.7.1 :)

anyway if you updated to latest 2.7.1, did you received request on conversion of data? If not, please try to re-intall Locus
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
Re: 1.6.1 deleted everything!
« Reply #2 on: November 03, 2012, 15:08:09 »
Sorry, I mixed up the numbers. So I had 2.6. something and I updated to 2.7.1.

I didn't receive any request for converting the data. Locus started like usual.

I don't know how to reinstall something on Gingerbread, I'm afraid of loosing all my settings if I do uninstall and install. Also, if it gets fixed by a reinstall then I cannot help you to make a fix for Locus 2.7.2. So I think it would be better if I could help you by installing versions you send me and tell if it's fixed. I have a rooted phone, it's not a problem. I can send you my database files, if you tell me which ones to send.

If you have a lot of users out there with this problem then I think it's important to make a quick fix for 2.7.2.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11353
  • Thanked: 293 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: 1.6.1 deleted everything!
« Reply #3 on: November 03, 2012, 16:50:02 »
Hi,
  what you say have perfect sense. I was also thinking about it. Anyway I just published new version 2.7.2 where few small things changed (that may have effect on missing request on conversion). So please try it and if it still will not work, I'll gladly accept your offer.

  By market stats, more then 2/3 of people already updated app on latest version. If I count it, around 10 people wrote that have same problem as you, so I hope, there will be not much people that will suffer from this. Anyway truth is that not everyone report it ... nevemind. Try it and let me know! Thanks
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
Re: 1.6.1 deleted everything!
« Reply #4 on: November 03, 2012, 17:01:38 »
Installed 2.7.2 Nothing changed. It doesn't list the categories on startup after deleting cache.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11353
  • Thanked: 293 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: 1.6.1 deleted everything!
« Reply #5 on: November 03, 2012, 17:17:18 »
fine, then please

install this version https://dl.dropbox.com/u/8015949/Locus% ... .7.2.1.apk

install also CatLog program and by this manual record "long log message" http://docs.locusmap.eu/doku.php/manual ... og_message. Enough is just start Locus till map appear and after a while close
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
Re: 1.6.1 deleted everything!
« Reply #6 on: November 03, 2012, 18:02:30 »
OK, starting the file you've sent me asks the Delete Old, Close, Delete New dialog. I choose close.

Old Locus still believes it's empty.

Files here:
https://www.dropbox.com/sh/l9n7x9u76p2seez/uEbB6FIyye
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11353
  • Thanked: 293 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: 1.6.1 deleted everything!
« Reply #7 on: November 03, 2012, 18:10:42 »
if it's ask for deleting than it's all OK. This log is then useless, damn :) How it's possible then test version works for you? Hmm anyway don't fight with it. Start test version, choose delete new, and then start test version again and it should offer you database conversion. So do it ...

I really appreciate your help, but I believe there will not be too much people left, with same problem and if so, they write email so we solve it by re-installing or I convert them manually their databases
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
Re: 1.6.1 deleted everything!
« Reply #8 on: November 03, 2012, 22:08:57 »
OK, I'm doing the conversation now with free. Why not just make a debug option to convert database manually? Similar to clear cache, clear map data, etc. But don't forget not everyone knows english or is enthusiast enough to come here.

An idea: when I started Locus Free it asked me all the first start-up questions. From this I believe that the detection bug is somewhere in the Locus Android settings, not on the sd-card contents. I'm quite sure that if I'd reseted Locus Pro, it would have asked me the data conversion too.

edit:
OK, long long conversion process done. Categories show up in Locus Pro. But I tried to create a new category and then now all categories appeared twice! Maybe it's best to start from a clean data dir.

edit
menion, I'm trying to reinitialize Locus Pro, but there is no way to do it! I renamed the data dir, removed the data from Locus in Android, deleted the cache within Locus, asked it to reset itself, and I even formatted Dalvik + cache. Still Locus Pro starts without asking me the first questions!
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline gynta

  • Global Moderator
  • Professor of Locus
  • *****
  • Posts: 3552
  • Thanked: 40 times
    • View Profile
    • Locus live tracking service
  • Device: SM-A530F(A8) Android 8.0.0
Re: 1.6.1 deleted everything!
« Reply #9 on: November 03, 2012, 22:28:18 »
Quote from: "zsero"
Locus Pro starts without asking me the first questions!
Hi zsero
How big are your old datafiles?
can u upload or send the whole data for/to menion?
Quote from: "menion"
...or I convert them manually their databases
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
Re: 1.6.1 deleted everything!
« Reply #10 on: November 03, 2012, 22:50:10 »
gynta, I've just deleted all of them, going crazy about the duplicate issues. They were quite small, just having some 100 points in them. I'm still trying to make Locus Pro do a clean start, and I cannot make it. The initial sequence what runs in Locus Free doesn't want to run.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline berkley

  • Premium
  • Master of Locus
  • ****
  • Posts: 900
    • View Profile
  • Device: 1+1, N7
Re: 1.6.1 deleted everything!
« Reply #11 on: November 03, 2012, 23:14:52 »
Hi,

Assuming from your posts and your phone type, that you know, what you can do, i suggest the following:

- go to your phone settings -> apps -> choose Locus
- delete cache and data
- uninstall Locus
- restart your device to recovery mode
- delete dalvik cache
- restart your device to android
- do a fresh install of Locus from Google Play
- you're done
;)

In case this doesn't work, uninstall Locus and delete some directories on your device:
- the directory called "Locus" located in something like "/mnt/sdcard/" or "/storage/sdcard0/"
- the directory called "/menion.android.locus.pro/" located in "/data/data/" in the very root of your device
- do a fresh install of Locus from Google Play
- you're done
;)

In case this still doesn't work, do the following:
- get the app "SD Maid" from Google Play (free is enough for this purpose)
- choose "AppControl"  
- tap Locus
- tap "delete everything"
- do a fresh install of Locus from Google Play
- you're done
;)

In case this still doesn't want to work:
- BOTHER MENION WITH SOME MAILS!!! :D :D :D

Cheers, berkley
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Search before posting!!!
XDA Orbit, HTC Touch HD, SGS1, SGS2, Nexus S, S4 Active, OnePlus One, Innos D6000
OnePlus X
 

Offline berkley

  • Premium
  • Master of Locus
  • ****
  • Posts: 900
    • View Profile
  • Device: 1+1, N7
Re: 1.6.1 deleted everything!
« Reply #12 on: November 03, 2012, 23:28:12 »
Moment, hope you read before you react... ;)
Maybe it is a good idea to do a NAND backup... just kidding... :D

Anyway, i'm pretty sure now, that you have 2 Locus installations (not installations, better: user folders for Locus) running, one on internal and one on external SD card. Please check both SD locations for Locus folders. One of them may probably contain your old database files.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Search before posting!!!
XDA Orbit, HTC Touch HD, SGS1, SGS2, Nexus S, S4 Active, OnePlus One, Innos D6000
OnePlus X
 

Offline zsero

  • More than Newbie
  • *
  • Posts: 58
    • View Profile
Re: 1.6.1 deleted everything!
« Reply #13 on: November 04, 2012, 00:06:36 »
OK, uninstalled Locus. My /data is empty. I've renamed the /sdcard/Locus to something else. I've done now a full search for "locus" on / and there is no Locus anywhere. I did a Dalvik + Cache format in recovery.

Aaaaaaaaand it's working! I got the startup wizard!
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline berkley

  • Premium
  • Master of Locus
  • ****
  • Posts: 900
    • View Profile
  • Device: 1+1, N7
Re: 1.6.1 deleted everything!
« Reply #14 on: November 04, 2012, 00:13:18 »
Perfect ;)

Now, how does your filesystem within that folder "/sdcard/Locus/" (the one you renamed before) look like?
Do you have "/Locus/data/database/waypoints.db"? Or do you have "/Locus/data/dbmain.sqlite"?
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Search before posting!!!
XDA Orbit, HTC Touch HD, SGS1, SGS2, Nexus S, S4 Active, OnePlus One, Innos D6000
OnePlus X