At times extreme battery consumption

Started by Fykantrollet, October 24, 2011, 23:13:09

0 Members and 1 Guest are viewing this topic.

Fykantrollet

Hi!

Locus is a great software, but there is one thing that keeps on giving me trouble; sometimes the power draw of the application is extremely high. I estimate it to be at least 2 amps at worst. This estimation is based on that the battery graph shows as steep a negative curve as the positive curve is when charging with the wall charger, when I at the same time is charging with a .5A charger.

I have experimented a bit, and I think I have narrowed it down to when the guiding function is active. I can have distance rings on, time rings, custom screen and track recording active, even screen on and consumption seems normal (at worst slowly dropping). But when I activate guiding the power graph spikes downwards.

I can't imagine nobody else has this problem. Is there some setting that might remedy this? I'm thinking that Locus is maxing out the processors for some reason.

I am using Statkart Topo on a i9100 Android 2.3.4 Build KI4.

Thanks for any help!
  •  

Khaytsus

#1
I haven't seen such extreme drain, although it seems like there's more battery usage than I was used to in my previous program, but not by a huge amount.  I feel the sneaky feeling that the sensors are left active, but not sure how I'd verify that.

When I'm caching, quite a bit of the time I've turned off the screen while I'm approaching or leaving the cache, with guiding on while on the way to and usually guide turned off on the way back.  I don't have time distance etc on, I should check that out sometime but so far haven't played with those options.

You could try something like CPU Notify to see what CPU usage is going on..  For me, I can almost always tell when my CPU is taxed, everything gets slow and if it goes on too long, the phone or tablet starts getting warm.
  •  

Menion

#2
hmm I received similar email yesterday so you're surely not the only one.

have to find where is problem because this is really serious, if this is locus problem.

I have yesterday bought some SystemPanel program that can monitor single process power drain (CPU usage) so I'll try to find where is problem. For a first testing, all seems to be normal, so it will probably be one function that work in incorrect way ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Gammalerik

#3
The blue animated guide line is a major battery consumer.
  •  

Menion

#4
are you sure? I'm just testing it for some time and seems that this arrow do not cause troubles, also vector maps are fine ... so I'll continue in testing :)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

jusc

#5
Maybe a SGS2 problem with  Locus?
Using the same time SGS 2 and Defy (4 hours) parallel, Defy drops from 100% to 68%, SGS2 to 28%! without any guiding. SGS2 became hot.
Without Locus at least, SGS2 (2.3.5) does not use a lot of battery. After 36 hours standby and 1hour radio only 13% battery power used.

But I have to verify it, because it was only once.

Sent from my GT-P1000 using Tapatalk
Regards J.
  •  

Menion

#6
thanks jusc. Don't know. I have tested almost all main functions and seems that separately all works fine and as I expect. So seems that problem should be
1. in some phone version where is some android internal problem
2. in locus in way that for example I enable orientation sensor and it remain enabled even if not needed anymore. I'm trying to check and control all these stuff but everything is possible. So testing continue .. every ideas are welcome
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Fykantrollet

#7
Humm, I was not able to replicate abnormal power usage tonight. Consumption remained steady for one hour while I did several tests. With screen on, lot of GUI stuff active, guide and tracking on, result was around -12%/hour and thats great.

Afterwards I connected my 0.5A pocket charger and the phone increases charge even with Locus running with same settings (though sitting stationary by the window).

Weird.

A thought; when I am using it when kayaking I have the phone in an Aquapac bag. This bag gets wet, and then I often get trouble with controlling the software because the bag is activating parts of the screen the whole time. Might this be the culprit? Even with the screen off?
  •  

jusc

#8
Quote from: "Fykantrollet"..Consumption remained steady for one hour while I did several tests. With screen on, lot of GUI stuff active, guide and tracking on, result was around -12%/hour and thats great.


Which modem, kernel and version of Android are you using?
Mine XXKI3, 2.6.35.7 (speedmod k2-6),  2.3.5  
Mostly standby, without data connection, and a bit radio, battery consumption is about only 9% per day.  
Maybe my problem with SGS2 was, that the phone was lying in the middle of the car and Defy in the trunk for half an hour?
Regards J.
  •  

raschaa

#9
HI,

just for the record, I also have massive battery consumption on my LG P500 Gingerbread. Haven't delved into it any deeper but just stumbled upon this tread and found out I'm not the only one...
If I can help in any way let me know...

greets
ra
  •  

Menion

#10
help is welcome, in simple way ... to find source of problems :) When you discover that only with some action is this happen, tell me. Damn, this have to be solved soon because I'm trying as much as possible, to lower CPU usage and now this :)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Gammalerik

#11
I have not been able to replicate the extreme battery consumption either. However, when it happens, the phone gets REALLY hot in the top left corner where the CPU/GPU is located. Hot as if I was charging and playing a 3D game at the same time.  So most likely it is not a feature or combination thereof that makes this happen, but a freeze/looping.

SGS 2, stock 2.3.5
  •  

Fykantrollet

#12
QuoteWhich modem, kernel and version of Android are you using?
Mine XXKI3, 2.6.35.7 (speedmod k2-6),  2.3.5  
Mostly standby, without data connection, and a bit radio, battery consumption is about only 9% per day.  

I'm using stock firmware: Android: 2.3.4, Baseband:XXKI1, Kernel: XWKI4.
9% a day? That results in over ten days between charges. Incredible...

Anyhow after several attempts of testing I have not been able to replicate the fault. Next time when it occurs (probably on my next kayak trip :D)  I will make sure to check it out thoroughly.
  •