[APP] - version 1.11.x, 1.12.x, 1.13.x

Started by Menion, August 30, 2011, 08:55:55

0 Members and 1 Guest are viewing this topic.

phoneguy100

#30
Oh no!

Updated pro version to 1.13.1 last night on android market and it wont even open.  Constantly force closes. :-(
I see from the market feedback system that other people are getting a forced close too.
Hope this can be fixed soon as I struggle to operate without my Locus.  ;-)

Android 2.1:  LG GT540 Optimus

EDIT: 1.13.1 DOES NOT CRASH - IT IS THE FIX!
  •  

Menion

#31
wait? you updated to 1.13.1 last night? not possible. 1.13.0 have this force close problem. Today morning (before cca 4 hours) I published new version 1.13.1 which should works fine!! check it please ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

phoneguy100

#32
Hi Menion.
Sorry about that - makret delayed things a bit on my phone and said I had the latest version but said it was 1.13.1
Just checked again now and it let me download 1.13.1 and everything is fine.
Excellent!
Thank you :-)
  •  

Menion

#33
good, you're welcome. It was my stupid mistake because I used one function available since A2.2+ and forget to check it ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Szczepanik

#34
Quote from: "menion"may someone send me crash log please?
Locus 1.13.1.1 Force close on Function Navigate to
Cheers
Tom
  •  

Menion

#35
ah sorry, my stupid mistake. I'll work on this today also so in the afternoon you find here working testing version (with some small improvements as usual)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Menion

#36
so fixed and improved version in first post ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Szczepanik

#37
Quote from: "menion"18.9.2011 - Locus 1.13.1.2
.. some more info in previous test version
  • new "Navigation settings" with few new ... settings
  • improved computing dialogs
Thanks the new "Navigation settings" in Locus 1.13.1.2 is a good improvement.

Can I request that you add a quick menu button to toggle "Guide on" as it is quite difficult to get the red cross displayed and long press to start Navigation.
Cheers
Tom
  •  

Menion

#38
you're welcome ...

but I don't understand your request. For quick navigation start is simple method
- tap on point on map, select menu with guiding and compass and ... NAVIGATION ... enjoy ;)

if this is not what you need, just try to describe it a little
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Gammalerik

#39
Framerate is now fine again with distance rings enabled. On Galaxy S2 that is, but it is buttery smooth so I guess lower spec phones will also do just fine.
  •  

Szczepanik

#40
Quote from: "menion"you're welcome ...
but I don't understand your request. For quick navigation start is simple method
- tap on point on map, select menu with guiding and compass and ... NAVIGATION ... enjoy ;)
if this is not what you need, just try to describe it a little

When I press the map, nothing happens
[attachment=1:23rovzvv]Locus-press_map.png[/attachment:23rovzvv]

When I accurately press a point, I see the instructions and can choose Navigation
[attachment=0:23rovzvv]Locus_press_point.png[/attachment:23rovzvv]

Only when I precisely press on the track does the menu appear.  If I am driving this is too difficult Can the Quick Menu have a button to do everything necessary to turn guide on and maybe go to nearest point?
Cheers
Tom
  •  

dibrial

#41
I noticed that selecting poi's on the screen is a lot harder when map center is shifted. After changing back to normal center, selecting is smooth again.
  •  

Menion

#42
new test version available ...

about pressing to items.
------------------------------
I know, that there is mistake during rotation. If you imagine bounding box around item that is set as pressing area (defined by icon size), this bounding box is not rotating with map (as icon do), so when you rotate map for 180°, tapping area of POI's will be still on same place, so it will be below the icon and not on the icon. I know about this (for a big surprise), but I have still no simple solution that will work fast. When I'm recomputing this area, it takes a too much CPU power. Anyway I'll try to find solution, promise :)

Anyway there is sometimes also one more problem. Tapping on icon or around icon ... no matter where ... nothing. I still have no idea how to simulate this problem, but sometimes it happen. And when you turn off and then on Locus, it will works fine ... weird
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Szczepanik

#43
Menion - thanks for this - the  "Name filter" in Points manager screen is good
Quote from: "menion"20.9.2011 - Locus 1.13.1.3
.. some more info in previous test version
  • improved navigation system. Now should much better check for "Nearest point"
  • new "Name filter" in Points manager screen
Dibrial - thanks for the suggestion - unfortunately did not make things any better for me. I do like having the map shifted to the bottom and also rotate 90 in portrait (so the track goes up the screen),
Quote from: "dibrial"I noticed that selecting poi's on the screen is a lot harder when map center is shifted. After changing back to normal center, selecting is smooth again.
Menion - weird, I will see if I can unsimulate thes problem I have where tapping on map does not bring up Navigation.
Quote from: "menion"new test version available ... Anyway there is sometimes also one more problem. Tapping on icon or around icon ... no matter where ... nothing. I still have no idea how to simulate this problem, but sometimes it happen. And when you turn off and then on Locus, it will works fine ... weird
Note: I do not have a data plan so I am setting Navigation on WiFi before journey and restarting Locus in the car. Would this make a difference?
Cheers
Tom
  •  

Menion

#44
I'll also try to find where is problem - giving it more priority. About offline navigation - It's really not a problem, just be sure you have (in settings) disabled automatic recompute!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •