Author Topic: KML Polygon and Multigeometry problem  (Read 3573 times)

Offline Qba

  • Newbie
  • *
  • Posts: 6
    • View Profile
KML Polygon and Multigeometry problem
« on: August 20, 2011, 17:50:39 »
Hi,

I am pretty new user of Locus but it is very impressive application in matter of functionality and apperance. Previuosly I have used Maverick Pro but I think they stoped to develope it. For now I am testing Locus Free but probably it will get me to buy Pro version. But comming back to the topic. I have got 2 problems during importing KML files with Multigeometry or Polygon functions.

1. When I import KML file with Multigeometry (with Point and Polygon) with <name> and <description> under <Placemark> and under <Multigeometry> Locus import Point as a Point and Polygon as a Route but Point have a name from <Multigeometry><name> nad Info from <Multigeometry><description> but Route have no name no infos.

2. When I import KML file with <Polygon> Locus properly copy <name> and <description> but do not transfer style <LineStyle> and <Polystyle>

attached two KML files as an example (extension kml changed to zip due to this forum restrictions).


best regards
Qba
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11506
  • Thanked: 334 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: KML Polygon and Multigeometry problem
« Reply #1 on: August 21, 2011, 09:34:42 »
there is few mistakes on my side and few on yours! (fix me if I write something wrong please)

yours:
1. http://code.google.com/apis/kml/documen ... html#style - styles have to be in <Document> tag
2. Multigeometry http://code.google.com/apis/kml/documen ... tigeometry - contains only geometry objects, no more name and description tags

mine:
1. igonoring data from PlaceMark - fixed!
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline Qba

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: KML Polygon and Multigeometry problem
« Reply #2 on: August 22, 2011, 19:53:03 »
Thank You for quick answer, but unfortunately I have bad news:

Quote from: "menion"
yours:
1. http://code.google.com/apis/kml/documen ... html#style - styles have to be in <Document> tag
STYLES - adding <Document> for file with <MultiGeometry> do not change nothing. Do You have differ results than I have? If yes, could You send me a KML file to investigate? Despite of that <style id...> used for <Polygon> work perfectly without <Document>,

Quote from: "menion"
2. Multigeometry http://code.google.com/apis/kml/documen ... tigeometry - contains only geometry objects, no more name and description tags
NAME, DESC - probably in one <Placemark> could be only one <name> and one <description> (Locus take name and description from the last one used even if it is located in <Multigeometry> area).

Quote from: "menion"
mine:
1. igonoring data from PlaceMark - fixed!
I am not sure which data You have mention

Tehere is another one - when I use <Multigeometry> with <Point> and <Polygon>, Locus importing that give a name for POI (Point) and do not give a name for Track (Polygon). Track is shown as "/sdcard/Locus/tracks/"
I think that there is something wrong in the process of taking out <Polygon> for Track and <Point> for POI from <Multigeometry>. But that is only guess.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11506
  • Thanked: 334 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: KML Polygon and Multigeometry problem
« Reply #3 on: August 26, 2011, 07:35:59 »
hi Qba, should be all fixed now. So please try next release version and let me know. (don't forget to keep styles in <Document> tag)
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline Qba

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: KML Polygon and Multigeometry problem
« Reply #4 on: August 28, 2011, 22:15:24 »
Have Tou fixed Free or Pro version? (beacause I can not find Pro update, already upgraded to Pro )
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11506
  • Thanked: 334 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: KML Polygon and Multigeometry problem
« Reply #5 on: August 29, 2011, 05:33:32 »
wait for release, today or tomorrow ... (always fix both - it's almost identical code)
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline Qba

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: KML Polygon and Multigeometry problem
« Reply #6 on: September 01, 2011, 16:09:35 »
Definitely better ;) Thnx
« Last Edit: January 01, 1970, 01:00:00 by Guest »