Author Topic: POI with multiple icons in kmz-file  (Read 920 times)

Offline ysop

  • More than Newbie
  • *
  • Posts: 22
    • View Profile
POI with multiple icons in kmz-file
« on: August 07, 2011, 17:28:55 »
I have a problem when I import a kmz-file with multiple icons:
If the kmz file has icons referenced by external links the icons are shown correctly in the map. But if the kmz-file has icons which are provided within the file the icon of the category is shown on the map, not the icons provided in the file. Google earth works as expected.
[attachment=0:2j9ob9ge]ba3 icons test.zip[/attachment:2j9ob9ge]

Then I tried to delete a POI of the category and the app crashed. After starting Locus the category is not shown anymore. If I try to generate the category again Locus says "category already exists" (translated from german to english). But I cannot reproduce the crash again when I delete the POI.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11346
  • Thanked: 292 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: POI with multiple icons in kmz-file
« Reply #1 on: August 08, 2011, 14:11:37 »
I was searching for mistake in code and finally mistake is in your file. Even when you use own icons, you have to place them into 'href' tag ...

so this
Code: [Select]
<href>water.png</href> is valid!
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ysop

  • More than Newbie
  • *
  • Posts: 22
    • View Profile
Re: POI with multiple icons in kmz-file
« Reply #2 on: August 09, 2011, 16:12:53 »
Thank you, now it works. Excuse me for making unjustified trouble!
« Last Edit: January 01, 1970, 01:00:00 by Guest »