[APP] - version 4.21.+ ( 1/2024 )

Started by Menion, January 23, 2024, 13:53:25

0 Members and 1 Guest are viewing this topic.

Graf Geo

Hello, I have just tried out the latest beta with the new route planner administration. Thanks for all that work! As is so often the case, you have to get used to the changes.

Some remarks: I myself hardly ever need the list with the via points/shaping points. It would therefore be better for me if it didn't open initially, but I could only open it (pull it up) when needed. At the moment it's the other way round: every time I want to edit a route with the route planner, the entire list opens, in which I may have 15 or 20 or even more shaping/via points. And every time I have to pull it down to make it disappear. Perhaps this behaviour could be offered as a selectable option in the settings.

The "collaps" function is very practical, but this is only included in the menu for the very last shaping point (the destination). So I have to scroll down to the very last entry in the list to be able to select "collaps". Perhaps this option could be offered in the menu for every single shaping point. Or in the icon bar on the top of the list.

Otherwise everything works quite well, a few translations (in German) are still missing in the menus, but it's a beta version

Just one more request: it would be nice if it would be possible to choose the position (size) of the menu when selecting the altitude profile so that only the altitude chart and not the two bar charts for route types and surface are visible. They take up a lot of space and I usually don't need them. (I can select the Graph Hopper, then they are not there, but it should also be possible with the LoRouter).
SG S10, Android 12

Andrew Heard

LM4.24.3.4 GOLD user ID:c7d47597a
    The following users thanked this post: luce

Graf Geo

Two more issues:

Red circles on planned route: If I want to continue editing an already saved route (without any red circles) with the route planner (re-route), these appear at very many shaping points and without any recognisable meaning. Despite precise correction, they often persist.
See screenshot 1.

I click on a planned route and select the "Change route" option. The route planner opens. I do nothing and close it again. Now I click on another route and select the "Change route" option. The message "An unsaved route already exists..." appears.
See screenshot 2.

SG S10, Android 12

Graf Geo

SG S10, Android 12

Andrew Heard

Quote from: Graf Geo on March 08, 2024, 23:20:16It would therefore be better for me if it didn't open initially
@Graf Geo - for me in there is just a single line at the bottom - same as pre beta

Quote from: Graf Geo on March 08, 2024, 23:20:16The "collaps" function is very practical
I've never seen this menu function, and dragging down the panel now works fine for me anyway

>Red circles on planned route
I've not seen these either
LM4.24.3.4 GOLD user ID:c7d47597a
    The following users thanked this post: Menion


  • track, create a copy. The overview-map gets not created even after choosing and activating the track, dedicated show-and-jump-to-map-button
  • track with ~80 navigation waypoints. What's the easiest way to not show the bunch of this tracks waypoints on map, only the track itself ? The waypoint-popups are not needed everytime. The popups also seem to be active in overview-map when center-cross hits one.
  • route planner: collapse/expand is only available in last points menu.
  • route planner: when re-routing a track (and dismiss the last-active-temporary-route), the profile is the last one used, not the one used in the segments. idea: switch to profile of the last segment
  • route planner: idea: add reverse-list-button
  • i also rarely change the shaping/via-point-type, this dialog is not super important to me. The choice of location is of more value, recent/favorite/point/coordinates/adress/search. I suggest to add an touch-area or switch to the location-dialog
  • route planner: point > location dialog > search: searching for eg. restaurant uses the current gps-location,not relative to the chosen point]




Thanks guys for the nice feedback!

General notes to Route planner

Expected requirement: do not force to use the bottom panel and keep it hidden. It is easy to hide it now, but I'll think about better support for this.

missing estimates with BRouter > values very valid for you? This was changed because of this. Do you have enabled "Include navigation points"?

Choose location > under this menu is quite a lot of options, so I would rather stick with the united system across the app. Anyway, what is unexpected on the "Navigate to" call?

@Graf Geo
"Collapse" in all menus > you are good you've found it at all :). We do not know where to place it for now. To all items? Eh, no, please. But a better place is needed for sure.

Red warning circles > may you please share this track with me over Share > Share URL link? Thanks

Warning message on unsaved route > from my point of view, this is correct behavior. You opened the planner to re-plan some track, but closed it without saving. So track-in-progress is still there.

Limit visible content in the "Altitude tab" > I'll consider the option. The best should be if the drag of the bottom panel will be to a user-defined height or at least two defined steps.

1. overview of the copy > hmm, this is already partially rewritten in new planned data manager, so let's hope  ;)

2. 80+ waypoints on the map > and do you need to display these navigation points at all? It may be globally disabled in the settings > tracks > Show navigation commands on the map

3. collapse/expand > above in @Graf Geo

4. used profile > currently it is united behavior - the app always uses the currently selected profile. This may be changed, but I need to think more about it. It then should change also adding new intermediate points, dragging the middle red point etc.

5. reverse list button > planned, but currently same problem as with collapse/expand. Where to place it?  ::)

6. content of point detail > individual preference. I believe the dialog may be done better, but I consider the current content as a good compromise for all.

7. interesting idea > I'll discuss it with Marek
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download

Graf Geo

Hello menion, thank you for your answer.

I will try to explain the problems I have noticed (see my posts from 09.03.2024) in more detail. Firstly, the red circles around the shaping points and the initial opening of the entire list with the shaping points.

As far as I know, the red circles are supposed to indicate that the shaping points are not exactly on a path or too close to an intersection.

I am planning a route (14.7 km) with the route planner. All 20 shaping points are exactly on a path and not close to an intersection or junction. No red circles are displayed either. Then I save the route. Then I open it again with the route planner. Now red circles are displayed around several shaping points. I zoom in sharply on the map and check the position of the shaping points and save the route again. Then I open it again with the route planner. Now red circles are shown around some other shaping points. (This only happens with the LoRouter, it doesn't happen with Graphhopper.

The screen video shows the following problems:

1: Track time (value under the clock icon) is displayed completely nonsensically as 1138:52:45
2: When I open the route with the route planner (re-route), the whole list opens with the 20 shaping points, which takes up a lot of space.
3. several shaping points are marked with red circles.
4. after checking/moving these shaping points and saving, I open the route again with the route planner. Even more shaping points are marked with red circles than before.

Can't upload screen video (52 MB are not allowed), please download here:

Here the URL link of the track:

Suggestion: Place "Collapse" only in the first entry in the list, then you don't have to scroll down. Or as an icon in the icon bar above the list (screenshot 2).

Translated with www.DeepL.com/Translator (free version)
SG S10, Android 12

Graf Geo

And some more feedback on the new beta version:

I tried out the new navigation at the weekend. At first I was irritated because the previous "Navigate to" window no longer appeared and the search opened instead. But now I understand the new concept and can also see various advantages. It is much easier to modify the suggested navigation route. So many things are good!

However, it is a little more complicated or at least less intuitive for my most frequent use case: In most cases, I want to navigate to a specific position on the map. In other words, to where the red cursor cross is. The search page then opens. This is very impractical for me, as I don't need it. (Of course, I understand that other users probably want to carry out exactly this search). I now have to close the search page first. Then the route planner opens and I can mark the destination with the plus button (and set via e points if necessary.) I then click on the navigation icon and have to confirm the navigation. All in all, I have to make quite a lot of clicks before I can finally start.

It would be great for me to be able to configure quick navigation. There could be a separate icon for this, which I could then place in the right-hand panel, for example. The function should make it possible to navigate directly to the cursor position with the last navigation setting made, as an "one-click function".

Of course, this is a big wish and I don't expect it to be realised. But perhaps it can be set so that at least the search page does not open when it is not needed?

Here are the steps I currently need to take if I want to navigate quickly to the selected cursor position:

1) Click navigation icon.
2) Search page opens, I have to close it. Annoying.
3) Click the plus icon.
4) Click on the navigation icon (now above the map).
5) Click the navigation icon again in the navigation/routing menu.

As a workaround, I have currently activated the "tap and hold to display address" function, so I can navigate there directly without the search page appearing. But then an additional selection window appears where I have to select "navigate to". So also a lot of clicks... Besides, I don't really want to activate the "tap and hold...".

*** Translated with www.DeepL.com/Translator (free version) ***

SG S10, Android 12


Interesting considering it is an oddity. 
Since Locus does not support transport of shaping points in gpx files (grrr), so "silent via points" are used in the attached file (at least silent via for a Locus import). Are red circles visible in the reroute screen after an import ? In Locus classic (reroute) by Brouter extern I do not notice such.
Locus Pro Classic 3.70.5

Graf Geo

^ I created the same route with the web planner (21 Viapoints). Then synchronised and displayed in the app. After calling up the route planner, one shaping point is marked with a red circle, although there is no reason for this. I moved it a little anyway and then saved it. The next time I open the route planner, another shaping point now has a red circle ... they seem to appear randomly ;) 

I imported your track (you created it with navigation commands, which I usually don't do). No red circles. After recalculation with LoRouter, almost every viapoint/shaping point has a red circle!
SG S10, Android 12


Quote from: Menion on March 11, 2024, 09:25:15@Tapio
Choose location > under this menu is quite a lot of options, so I would rather stick with the united system across the app. Anyway, what is unexpected on the "Navigate to" call?

The search is unexpected. I already know where I want to navigate to and don't need the search. Most of the time when I use "Navigate to" I want to nav from gps pos to screen center.

Wouldn't it be more logical if it came up with the screen as attached?
Tapiola MFV4+ theme for OAM Maps:
Discuss - Releases - DL latest - Install latest

Graf Geo

Agree, would be much better. So I could choose not only for addresses but also in my points, screen center etc.
"Contacts" also should be offered to choose.
SG S10, Android 12

Graf Geo

Quote from: Menion on March 11, 2024, 09:25:15...
Warning message on unsaved route > from my point of view, this is correct behavior. You opened the planner to re-plan some track, but closed it without saving. So track-in-progress is still there.

But in this case (track closed without saving) the message is meaningless. Nothing happens when I click on "cancel", I don't get back to the "track in progress". I can only "continue".

SG S10, Android 12