Geocaching tools:Draw circle, line etc fails

Started by stebu, July 22, 2011, 22:43:22

0 Members and 1 Guest are viewing this topic.


I cannot figure out what I'm doing wrong. Sometimes the circle appear on the map, mostly not :(
When there is nothing visible on the map, the "remove temp map items" tool still asks if I want to remove all items. There seems to be 2 items per a circle (center and the circle)

I once thought that the "speed rings" enable/disable had something to do with the geocaching tools, but now it has no effect.

So what am I doing wrong? How to enable the display of temp map items?

I have the latest free 1.9.4 version


can you give me some your ... step by step?

simply say: you use function draw circle and nothing appear on map when you press OK? (and "speed rings" have nothing to do with this function)
- Official help (ideas, questions, problems):
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download


Simply yes.

I open geocaching tools, "draw circle", coordinates default to map center and radius is 160m. Color is reddish, so it should show on green background.
I do not change the defaults, simply hit OK. Nothing is shown in map center or in GPS position.

But when I tap the "remove temp items", it asks "do you really want to remove 1 item?"

I think the above should work, but I have also tried changing coordinates, radius and color, but same invisible result :(
Yesterday in one session (of Locus) everything worked, but after that never.

Android 2.2, ZTE Blade, Locus 1.9.4. No errors or crashes in logs.


Dear Menion,

I have the exact same behaviour. I'm using the the latest Pro-Version from the market (btw. thanks for this great app! That's why I bought the pro-version!) and yesterday the circles would have been very handy as the sign with the azimuth was unavailable but we had the distance. So I said to my companion: Look what a great app I have here, I think this can draw circles.... but nothing appears.

This morning I tried again and voila: I had a nice little circle. I closed the app and tried again just to see it wasn't working again. I tried each and every combination in the settings but weren't able to get circles again.

If you need any further infos please ask.

EDIT: Didn't used it before, so I can't tell if this bug is introduced in the latest version.

EDIT2: What I also experienced was that I had in mind that the new Weather feature also draws an overlay icon but now these are also missing.

EDIT3: I'm mainly using offline vector maps if it has anything todo with it.


I use the same solution as with thread // Closing Locus via an App killer and everything should be working again.
Please confirm following:
    Create point
    Draw circle around point
    Close Locus (back button and confirm exit)
    Open Locus
    Point is visible, circle not
    Draw circle again
    No circle appears
    Close Locus
    Use App Killer (e.g. Advanced Task Killer) to force close Locus
    Start Locus
    Draw circle
    Circle appears again


viz answer here ... viewtopic.php?f=10&t=878 ... same problem. Fixed ...
- Official help (ideas, questions, problems):
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download