[MAPS] - Vector maps

Started by Menion, July 17, 2011, 09:49:21

0 Members and 2 Guests are viewing this topic.


would definitely be added value for the next round of generated vector maps, Menion.
Please also pick up latest version of tag-mapping.xml!


I'll start generating in next days. And don't worry, new tags will be added :). But SRTM data to next round for sure not. Maybe someone will test it before me. I really need to complete map manager screen and fix some serious reported issues, this is my priority for this week ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download


Vector maps with contour lines would be really appreciated! Not only for me. If you do not have time this week maybe next week. I'm waiting such a long time for this feature so it does not depend on one or two more weeks. :D


Hi people.

I am trying hardly this evening to create one such map with terrain contours. A map of Slovenia as I am planning to go on holiday there soon and looks to me as an ideal area size /not so large/ to do tests too. But I get more and more frustrated as time passes.... no success so far.

Let me tell you what I did with as much details possible. Maybe someone is able to point-out what am I doing wrong.

1. Downloaded osm xml data and polygon boundaries of slovenia from http://downloads.cloudmade.com/
-- success

2. Generated a osm terrain elevation lines data using srtm2osm like this:
Srtm2Osm.exe -step 25 -cat 500 100 -large -bounds1 45.40 13.37 46.89 16.55 -o E:OSMsrtm-dataslovenia_srtm.osm-- success

3. Converted 0.5 osm xml data to 0.6 (using osmosis 0.35) like this:
osmosis --read-xml-0.5 enableDateParsing=no file="E:OSMsrtm-dataslovenia_srtm.osm" --migrate --wx file="E:OSMsrtm-dataconvert_0.6slovenia_srtm6.osm"-- success

4. Cutting boundaries of both (terrain and map) files to have them pretty "geo-aligned" before merge
osmosis --rx e:OSMosm-map-dataslovenia.osm.bz2 --tee 1 --bp file="e:OSMpolygonseuropeslovenia.poly" --wx e:OSMosm-map-datacut_mapslovenia.cut_map.osm

osmosis --rx e:OSMsrtm-dataconvert_0.6slovenia_srtm6.osm --tee 1 --bp file="e:OSMpolygonseuropeslovenia.poly" --wx e:OSMosm-map-datacut_terslovenia.cut_ter.osm
-- success

5. Merging osm map and terrain elevation lines like this:
osmosis --rx e:OSMosm-map-datacut_mapslovenia.cut_map.osm --sort --rx e:OSMosm-map-datacut_terslovenia.cut_ter.osm --sort --merge --wx e:OSMosm-map-datamergedslovenia.merged.osm-- FAIL !!! FAIL !!! FAIL !!!

18.4.2012 21:48:05 org.openstreetmap.osmosis.core.Osmosis run
INFO: Osmosis Version 0.40.1
18.4.2012 21:48:05 org.java.plugin.registry.xml.ManifestParser <init>
INFO: got SAX parser factory - org.apache.xerces.jaxp.SAXParserFactoryImpl@126b249
18.4.2012 21:48:05 org.java.plugin.registry.xml.PluginRegistryImpl configure
INFO: configured, stopOnError=false, isValidating=true
18.4.2012 21:48:05 org.java.plugin.registry.xml.PluginRegistryImpl register
INFO: plug-in and fragment descriptors registered - 1
18.4.2012 21:48:05 org.java.plugin.standard.StandardPluginManager activatePlugin

INFO: plug-in started - org.openstreetmap.osmosis.core.plugin.Core@0.40.1
18.4.2012 21:48:05 org.openstreetmap.osmosis.core.Osmosis run
INFO: Preparing pipeline.
18.4.2012 21:48:05 org.openstreetmap.osmosis.core.Osmosis run
INFO: Launching pipeline execution.
18.4.2012 21:48:05 org.openstreetmap.osmosis.core.Osmosis run
INFO: Pipeline executing, waiting for completion.
18.4.2012 21:48:28 org.openstreetmap.osmosis.core.pipeline.common.ActiveTaskManager waitForCompletion
SEVERE: Thread for task 1-rx failed
org.openstreetmap.osmosis.core.OsmosisRuntimeException: An output error has occurred, aborting.
        at org.openstreetmap.osmosis.core.store.DataPostbox.checkForOutputErrors(DataPostbox.java:78)
        at org.openstreetmap.osmosis.core.store.DataPostbox.populateCentralQueue(DataPostbox.java:129)
        at org.openstreetmap.osmosis.core.store.DataPostbox.put(DataPostbox.java:184)
        at org.openstreetmap.osmosis.set.v0_6.impl.DataPostboxSink.process(DataPostboxSink.java:34)
        at org.openstreetmap.osmosis.core.sort.v0_6.SortedEntityPipeValidator.process(SortedEntityPipeValidator.java:58)
        at org.openstreetmap.osmosis.core.sort.v0_6.EntitySorter.complete(EntitySorter.java:62)
        at org.openstreetmap.osmosis.xml.v0_6.XmlReader.run(XmlReader.java:110)
        at java.lang.Thread.run(Unknown Source)
18.4.2012 21:48:28 org.openstreetmap.osmosis.core.pipeline.common.ActiveTaskManager waitForCompletion
SEVERE: Thread for task 3-rx failed
org.openstreetmap.osmosis.core.OsmosisRuntimeException: Cannot represent 68335 as a char.
        at org.openstreetmap.osmosis.core.util.IntAsChar.intToChar(IntAsChar.java:32)
        at org.openstreetmap.osmosis.core.domain.v0_6.Way.store(Way.java:200)
        at org.openstreetmap.osmosis.core.container.v0_6.WayContainer.store(WayContainer.java:51)
        at org.openstreetmap.osmosis.core.store.BaseObjectWriter.writeObject(BaseObjectWriter.java:63)
        at org.openstreetmap.osmosis.core.store.SegmentedObjectStore.add(SegmentedObjectStore.java:130)
        at org.openstreetmap.osmosis.core.store.ChunkedObjectStore.add(ChunkedObjectStore.java:78)
        at org.openstreetmap.osmosis.core.sort.common.FileBasedSort.flushAddBuffer(FileBasedSort.java:93)
        at org.openstreetmap.osmosis.core.sort.common.FileBasedSort.add(FileBasedSort.java:118)
        at org.openstreetmap.osmosis.core.sort.v0_6.EntitySorter.process(EntitySorter.java:40)
        at org.openstreetmap.osmosis.xml.v0_6.impl.NodeElementProcessor.end(NodeElementProcessor.java:118)
        at org.openstreetmap.osmosis.xml.v0_6.impl.OsmHandler.endElement(OsmHandler.java:107)
        at org.apache.xerces.parsers.AbstractSAXParser.endElement(Unknown Source)
        at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unknown Source)
        at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(Unknown Source)
        at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
        at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
        at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
        at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
        at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
        at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserImpl.parse(Unknown Source)
        at javax.xml.parsers.SAXParser.parse(Unknown Source)
        at org.openstreetmap.osmosis.xml.v0_6.XmlReader.run(XmlReader.java:108)
        at java.lang.Thread.run(Unknown Source)
18.4.2012 21:48:28 org.openstreetmap.osmosis.core.pipeline.common.ActiveTaskManager waitForCompletion
SEVERE: Thread for task 5-merge failed
org.openstreetmap.osmosis.core.OsmosisRuntimeException: An input error has occurred, aborting.
        at org.openstreetmap.osmosis.core.store.DataPostbox.checkForInputErrors(DataPostbox.java:90)
        at org.openstreetmap.osmosis.core.store.DataPostbox.consumeCentralQueue(DataPostbox.java:160)
        at org.openstreetmap.osmosis.core.store.DataPostbox.hasNext(DataPostbox.java:237)
        at org.openstreetmap.osmosis.set.v0_6.EntityMerger.nextOrNull(EntityMerger.java:285)
        at org.openstreetmap.osmosis.set.v0_6.EntityMerger.run(EntityMerger.java:120)
        at java.lang.Thread.run(Unknown Source)
18.4.2012 21:48:28 org.openstreetmap.osmosis.core.Osmosis main
SEVERE: Execution aborted.
org.openstreetmap.osmosis.core.OsmosisRuntimeException: One or more tasks failed.
        at org.openstreetmap.osmosis.core.pipeline.common.Pipeline.waitForCompletion(Pipeline.java:146)
        at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:92)
        at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:37)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:329)
        at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:239)
        at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
        at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:47)

WTF?!@#$!% "Cannot represent 68335 as a char." &$&%%#

I'm so saaaad  :shock:


hmm, I'm not experienced with SRTM maps generating (but I'll also try it soon so your description will be very useful), but I know about already working version of slovak map. Check add-on https://play.google.com/store/apps/deta ... utePlanner , inside is possibility to download complete map directly, but mainly, author is generating slovak map with SRTM data so you should try to write him. I'm sure Martin will help you ....
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download


pfffff ...

I did that right. Java had memory problems... It seems that the "merge" thing is consuming memory massively.

back to topic... I have played with the rendering for few hours, but I still don't like the results.

level12 = bugs

level13 = bugs

also in the lower-right part of the screen is clearly visible that some contours are missing. continue....


see also level15 and 16 ...

now i have lost all power to continue.... I hope someone could possibly make better job;-)


Quote from: "menion"hmm you're correct ... damn, these areas in the sea or around the see ... it's really terrible! I'm sorry but with this I can do nothing for now. Hope new version of MapsForge map generator will be out soon ...

Hi. Can I ask if the canary island maps can be downloaded somewhere? I tried the most recent one from mapsforge, but the canary islands do not exist.  :cry:


You can try this, if you don´t find others:   http://www.openandromaps.org/en/download.html
Regards J.


Thanks for the link, I tried the CanaryIslands.map and now I have maps! :)


I am trying to set bigger text size on vector maps (I mean POI names, street names etc) - by changing in the configuration point "vector maps/text size", but I can not see any effect. Do I need anything more ?


I have just tested it.... It works perfectly...
sorry for dumb question, ...but are you totally sure you are using vector map at that particular moment ?


oh my God! I am stupid - I have prepared a map using Mobac and I was sure that it is the vector one but of course it isn't.
On the "real" vector map it works, thank you.


Hello guys,

I am brand new in this great forum and I have also a (for me) quite urgend question.
I am going to asia on WE. I found the maps for the single states here:

Now to my question. Is there somewhere around some maps without the water bug? At least for hongkong, Singapore, Malaysia and Indonesia?

Thanks for your help


Quote from: "Homer-S"Now to my question. Is there somewhere around some maps without the water bug? At least for hongkong, Singapore, Malaysia and Indonesia?
Thanks for your help


These Maps, incl. contourlines, are available at http://www.openandromaps.org/en/download.html
However, if you download them direct to your phone be shure that you do not exeed your download allowance - the filesize for Malaysia/Indonesia is close to 1GB  ;)
Best regards/ Grüsse