Locus Map With Wear OS 3.5 (GW 5 and updated GW4) does not work (SOLVED)

Started by kconan, September 14, 2022, 10:09:51

0 Members and 1 Guest are viewing this topic.


Sorry I open a new thread but after I solved the orientation problem installing with ADB the 1.4.4 version in my GW4...

I decided to do a factory reset in my Galaxy watch 4 after it received the new Wear Os 3.5 update. With a fresh installation the wear add on does not work at all. It doesnt matter if it's 1.2 or 1.4.4. I did a factory reset in my phone to test again (Pixel 5 Android 13), same result. I even tried with a diferent phone, same thing. I see the "connection lost" message every time I open it. I even tried in phone Locus classic and the other one with same results.

I suspect in the new Galaxt watch 5 happens the same as it comes directly with Wear Os 3.5. This guy says it:

So please @Menion take a look, now the the add on does not work  at all. It's really painful, I rely on Locus map wear addon for my orientation trail runs in the mountains. I really don't want to buy another watch for maps. Locus Maps is by far the BEST.


I just registered on this forum to confirm that my new shiny Galaxy Watch 5 Pro running Wear OS 3.5 does not work. All versions including 1.4.4 show blank map followed by bluetooth error.

I have been using Locus Map Pro (classic) as my main driver for a few years now using my 2018 Galaxy Watch and it worked flawlessly with Huawei P30 Pro and now Samsung S22 Ultra. But now that I upgraded to Watch 5 I can't run my favourite app anymore. On my phone it runs fine but not the watch, and it's definately not battery related settings 😞
    The following users thanked this post: kconan


I hope at least the developers take a look at this issue.

Painfully I had to use again my old galaxy watch active just for my runs on the mountains.

Please guys, we want to keep using the very best map app.

Just to summarize, it seems wear os 3.5 (updated galaxy watch 4, GW 5 and incoming pixel watch) breaks the wear add on. Even with the latest 1.4.4.


But they don't always read here. Someone should report the problem to the helpdesk. 
The other can vote for it so that he also has the problem.
Then close the topic here and the link from the problem in the helpdesk here.
Poco F5, Android 13 / Xiaomi Redmi Note 10 Pro, Android 13
Locus Map 4 Gold (always latest version or Beta)
LM4 User-ID: 11cec7cb5  (Devices-ID poco F5)
    The following users thanked this post: kconan




@freischneider that is not true, I read all topics and posts :P (except the German thread)! It just sometimes takes me a day or two because of work here and there I have to do (sorry for this delays).

Guys, I spend on this more than a day last week, and in the end, I've found this! It is a problem in the Google library.

Fortunately, at Friday, a new version of the Google library was published so I've immediately updated quite a lot of code and published version 1.5. Well... 7th attempt to publish a new version ended with Google team message: "It is not possible to install on the device". Wtf. My request for detailed info from Saturday > no reaction so far.

Anyway, you may try version 1.5 from Google Drive. It works correctly on two watches we have for testing and also emulator so I believe there is no problem at all. Feedback will be anyway welcome!
- Official help (ideas, questions, problems):
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download


Menion and all developers, THANK YOU. I can confirm 1.5.0 works just fine in my GW4 with Wear OS 3.5. Orientation, route navigation and zoom work as expected. I hope you can solve the Google play store issue, but a least we can manually install the proper version.



If it helps others, the apps are in the drive shared to the public here:

The "device release" is for the phone, the "wear release" is for your watch and this is the easiest way to install apks to your watch:


A note in case there are other users with the same combination of phone and watch as me - Huawei P30 Pro and Galaxy Watch 4 or 5 - to help you get them working OK together. I expect the technique will work for other Huawei phones up to the P30.

The Huawei P series is notorious for issues with bluetooth and by default you can't pair a Galaxy Watch 4 or 5 with it using the Samsung Galaxy Wearables app. Not only that, but even once you do pair it, if you don't mess with battery settings, the Locus Watch app gets disconnected as soon as you close the Locus screen on the phone. Here's the process that worked for me...

1. On the phone, load Wear OS by Google, Locus Map, Locus Map Watch, Samsung Health, Samsung Galaxy Wearable, Samsung Galaxy Watch (for Watch4) or Galaxy Watch 5 (for Watch5).

2. On the phone under Settings, Battery, App launch, disable "Manage all automatically" for Galaxy Wearable, Locus Map, Wear for Locus Map, Wear OS by Google. I didn't disable Wear for Locus App initially, and this was enough to cause disconnections.

3. On the watch, start it up, or if you are changing the watch to a new phone go into Settings, Connections and Connect to new phone. You will be prompted to go to your phone to continue the install.

4. On the phone go into Samsung Health (not the Galaxy Wearables app - as that won't see your watch), Menu, Settings, Accessories. The Galaxy Watch should now show up, and you can connect it there. It's a bit of a slow process, but the watch should connect OK. I did have some issues with copying my Google account onto the Watch5, but got there in the end after several attempts. It was fine with my original Watch4.

5. Back on the watch, go into the Play Store app, go to Apps on Phone, and load Locus Map Watch.

That should be it! You can now manage the watch with the Galaxy Wearables app.