Locus Map With Wear OS 3.5 (GW 5 and updated GW4) does not work (SOLVED)

Started by kconan, September 14, 2022, 10:09:51

0 Members and 1 Guest are viewing this topic.

kconan

Sorry I open a new thread but after I solved the orientation problem installing with ADB the 1.4.4 version in my GW4...

I decided to do a factory reset in my Galaxy watch 4 after it received the new Wear Os 3.5 update. With a fresh installation the wear add on does not work at all. It doesnt matter if it's 1.2 or 1.4.4. I did a factory reset in my phone to test again (Pixel 5 Android 13), same result. I even tried with a diferent phone, same thing. I see the "connection lost" message every time I open it. I even tried in phone Locus classic and the other one with same results.

I suspect in the new Galaxt watch 5 happens the same as it comes directly with Wear Os 3.5. This guy says it:

https://help.locusmap.eu/topic/29356-samsung-galaxy-watch-s-4-locus-map-watch-nejde-spustit-mapa#comment-118504

So please @Menion take a look, now the the add on does not work  at all. It's really painful, I rely on Locus map wear addon for my orientation trail runs in the mountains. I really don't want to buy another watch for maps. Locus Maps is by far the BEST.
  •  

SnowStorm

I just registered on this forum to confirm that my new shiny Galaxy Watch 5 Pro running Wear OS 3.5 does not work. All versions including 1.4.4 show blank map followed by bluetooth error.

I have been using Locus Map Pro (classic) as my main driver for a few years now using my 2018 Galaxy Watch and it worked flawlessly with Huawei P30 Pro and now Samsung S22 Ultra. But now that I upgraded to Watch 5 I can't run my favourite app anymore. On my phone it runs fine but not the watch, and it's definately not battery related settings 😞
  •  
    The following users thanked this post: kconan

kconan

I hope at least the developers take a look at this issue.

Painfully I had to use again my old galaxy watch active just for my runs on the mountains.

Please guys, we want to keep using the very best map app.

Just to summarize, it seems wear os 3.5 (updated galaxy watch 4, GW 5 and incoming pixel watch) breaks the wear add on. Even with the latest 1.4.4.
  •  

freischneider

But they don't always read here. Someone should report the problem to the helpdesk. https://help.locusmap.eu/ 
The other can vote for it so that he also has the problem.
Then close the topic here and the link from the problem in the helpdesk here.
Xiaomi Redmi Note 10 Pro, Android 12
Locus Map 4 Gold (always latest version)
LM4 User-ID: 64fc904a8  (Devices-ID)
  •  
    The following users thanked this post: kconan

kconan

  •  

Menion

@freischneider that is not true, I read all topics and posts :P (except the German thread)! It just sometimes takes me a day or two because of work here and there I have to do (sorry for this delays).

Guys, I spend on this more than a day last week, and in the end, I've found this! It is a problem in the Google library.

Fortunately, at Friday, a new version of the Google library was published so I've immediately updated quite a lot of code and published version 1.5. Well... 7th attempt to publish a new version ended with Google team message: "It is not possible to install on the device". Wtf. My request for detailed info from Saturday > no reaction so far.

Anyway, you may try version 1.5 from Google Drive. It works correctly on two watches we have for testing and also emulator so I believe there is no problem at all. Feedback will be anyway welcome!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download

kconan

Menion and all developers, THANK YOU. I can confirm 1.5.0 works just fine in my GW4 with Wear OS 3.5. Orientation, route navigation and zoom work as expected. I hope you can solve the Google play store issue, but a least we can manually install the proper version.




  •  

kconan

If it helps others, the apps are in the drive shared to the public here:

https://drive.google.com/drive/folders/1Cji-J48_MXnv3p3eI0JK7e85ue-xMsBx

The "device release" is for the phone, the "wear release" is for your watch and this is the easiest way to install apks to your watch:

https://wearablestouse.com/blog/2022/01/04/install-apps-apk-samsung-galaxy-watch-4/#3_Sideload_and_Install_APK_on_Galaxy_Watch_4
  •  
    The following users thanked this post: Menion