screen-on nav & pin code unlock

Started by GusGF, August 30, 2022, 21:49:44

0 Members and 1 Guest are viewing this topic.

GusGF

Okay today I tried out Locus again on my commute and with the following options set I still cannot get LM4 to turn on the screen before a turn. This is a game changer for me and if I can't get it to work I'd be forced to use Komoot or OSMand+ both of which I previously have had no problem whatsoever getting turn notifications to work. I remember I posted about this a year or two ago and I simply can't find the thread now. I was using LM Classic and Menion, you did a code change from your end which fixed the issue, I think it had something to do with voice instructions.

Samsung Settings:
Notifications allowed
Allow background battery usage unrestricted
Allow this app to change system settings: currently disallowed

In LM4:
Controlling..display: Screen on/off control enabled
All 3 guidance/navigation options enabled

Currently LM4 is set much lower than my OS for putting the screen to sleep so it's in control. One thing I will check tomorrow is when I manually turn the screen on even though LM4 is running BUT is my current location correct or does it have to update.

I'm at loss as to what to try next?
  •  

Menion

Hmm hard to say. Turning the screen on should cause no problems because the app here uses existing Android methods, no hacks.

Do you hear any voices during the navigation? "Screen on" is connected to the voice navigation announcement.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Die Batzen

  •  

GusGF

Quote from: Menion on September 06, 2022, 07:01:30Hmm hard to say. Turning the screen on should cause no problems because the app here uses existing Android methods, no hacks.

Do you hear any voices during the navigation? "Screen on" is connected to the voice navigation announcement.

I turned on voice nav and was hopeful as I set off this morning on my commute but no it didn't work screen remained blank and no voice. When I manually turned on during nav I could see the screen quickly update to my current position. This is so frustrating
  •  

GusGF

Quote from: Die Batzen on September 06, 2022, 18:30:24@GusGF: this should be the thread you were referring to:
https://forum.locusmap.eu/index.php?topic=7545.0

Yes went through it and still can't get screen on to work for turns  :'(
  •  

GusGF

#20
I've uninstalled Locus Classic & LM4 completely and just reinstalled LM4 after a reboot and now seem to be able to set LM4 to not sleep whereas before I couldn't, will this help I won't know till tomorrow.

Incidentally, should I allow LM4 to ascertain my precise location 'All the time' or 'Only when using the app'?

QuoteDo you hear any voices during the navigation? "Screen on" is connected to the voice navigation announcement.

@Menion I thought you'd disabled the need for this?!

If I can get LM4 to work with turn notifications then I'll have a look at using something like tasker or/and smart lock with a wearable device :)
  •  

Menion

Only what has disabled some time ago, is that when you have enabled the "Mute" button in the Locus Map navigation settings, the screen on/off will still work.

Anyway, the app still compute and prepare navigation instructions, and the "screen on" event is connected to it. Disabling "mute" is a good practice to check if problem is in "instructions" or in the "screen on/off" function.

Hmm it may be also checked by enabling and testing "gestures". Maybe it is even better check. Simply enable "Wave once" option and try it (cover proximity sensor by your palm for a sec).
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

GusGF

Okay good news got the screen on for turn notifications but couldn't hear any instructions but will try again tomorrow.


QuoteOnly what has disabled some time ago, is that when you have enabled the "Mute" button in the Locus Map navigation settings, the screen on/off will still work.
  • What exactly did you disable some time ago?
  • I have no mute button on the map screen. I've searched settings and the functions panel for mute and can't find it. You will need to be clearer as I don't understand what you are talking about, sorry

QuoteHmm it may be also checked by enabling and testing "gestures". Maybe it is even better check. Simply enable "Wave once" option and try it (cover proximity sensor by your palm for a sec).

Yes I might give this a try but I'm not a fan of gestures and prefer a double tap.
  •