No more multi-selecting files on GPX import

Started by MacBo, January 18, 2022, 09:37:41

0 Members and 1 Guest are viewing this topic.



I'm using the latest Locus Map 4 (Gold) on a Samsung Galaxy S20 Ultra (Android 12, One UI 4.0). I'm pretty sure the following issue has occured due to system changes with the latest Android updates. But I guess there should be a fix. Maybe it's already in the making?

When importing GPX files, from time to time I used to import multiple tracks at once - using the track panel, "plus" button, import, internal memory and then select multiple files in the file browser. With the current version I can select only one file at a time. So importing multiple tracks has become quite a hassle. Importing from outside Locus Map (selecting multiple files in a file manager and then "share" to or "open with" Locus Map) isn't much better either, only one of the selected files ends up in my tracks. Although I believe that's not much different from before: importing multiple files from outside never worked properly to begin with. Now from inside unfortunately is off the table for now as well.




However, there may be more unpleasant surprises to come ?
As Google still is trying to improve Android to the point where it becomes almost impossible to use.
Locus Pro Classic 3.70.5
    The following users thanked this post: MacBo


for me it work with Android11,
3-dot button > import > long click on a file you want to import > new multiselect window open
Locus Map Gold AFA

LM4 User ID e06d572d4


It works with LM4 but not with the latest LM Pro v3.56.5 though I gave LM Pro the same access as LM4.


PS: in another topic Zdenek mentioned that multi-select only works if you have AFA granted.
I.e. latest LM4 PLUS you give permission for AFA.
I run Android 12 since yestaerday and just checked again: multi-select for GPX import does work.


@Mapper: you need to use the special LMP AFA version from Google Drive to have AFA power.
Google denied MANAGE_EXTERNAL_STORAGE privilege for LMP ...
    The following users thanked this post: Mapper

Andrew Heard

FWIW with LM4 on Android 8, I long+tap on 1st GPX to import, then the whole list has checkboxes on right side where I can select any/ all for import.
LM4.24.3.4 GOLD user ID:c7d47597a


Yes, and exactly same behaviour and appear - IF you have AFA, i.e. LM4 or LMP-AFA with Android 11 or 12.