Author Topic: startup of locus is really slow since last update (about 35s)  (Read 846 times)

Offline michaelbechtold

  • Expert
  • Professor of Locus
  • *****
  • Posts: 1010
  • Thanked: 126 times
    • View Profile
Re: startup of locus is really slow since last update (about 35s)
« Reply #15 on: December 31, 2021, 14:21:10 »
Link works.
Happy New Year!
Cheers
Michael


http://bit.ly/lmVersionsTest

Tapatalk doesn't show signatures, so I can't easily find the link to the download.

Sent from my moto g(6) plus using Tapatalk
[/quote]
 

Offline Menion

  • Locus team
  • Professor of Locus
  • *****
  • Posts: 12780
  • Thanked: 928 times
  • Country: cz
    • View Profile
    • https://www.asamm.com
  • Device: Pixel 5, A12
Re: startup of locus is really slow since last update (about 35s)
« Reply #16 on: December 31, 2021, 20:12:14 »
@bongo
Beta versions replace public versions. Usually, it is not easily possible to downgrade back on the public version. But usually, it is not a problem as we talk more about minor changes. Where there is a bigger update in the Beta version, it is discussed in the main version topic.

Anyway in this case, the Beta version is perfectly safe to install. Once the new version will be on Google Play, you will get an update as usual.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
 

Offline bongo

  • Apprentice of Locus
  • **
  • Posts: 140
    • View Profile
  • Device: samsung a50
Re: startup of locus is really slow since last update (about 35s)
« Reply #17 on: January 14, 2022, 12:09:43 »
in the mean time, i replaced the sd card. the new one is a samsung evo+ too, but has twice the size and is probably less fragmented than the one i had before...
but startup is only a few seconds faster than with the old one.
so the old sd card was probably fine.
 

Offline michaelbechtold

  • Expert
  • Professor of Locus
  • *****
  • Posts: 1010
  • Thanked: 126 times
    • View Profile
Re: startup of locus is really slow since last update (about 35s)
« Reply #18 on: January 14, 2022, 12:36:12 »
@bongo: the well known suspects for slow start are:
- old versions from before Xmas
- vector maps themes expanded (to folder, not as ZIP) on external SD card
Can you exclude both?
I do not remember your configuration ...
 

Offline bongo

  • Apprentice of Locus
  • **
  • Posts: 140
    • View Profile
  • Device: samsung a50
Re: startup of locus is really slow since last update (about 35s)
« Reply #19 on: January 17, 2022, 08:48:37 »
- i'm actually using the end-of-year-beta
- themes are zipped on the sd card
i think menion has already analyzed my logs. so this was just meant to be an update to confirm that this behaviouir is not because of a bad sd card.
 

Offline michaelbechtold

  • Expert
  • Professor of Locus
  • *****
  • Posts: 1010
  • Thanked: 126 times
    • View Profile
Re: startup of locus is really slow since last update (about 35s)
« Reply #20 on: January 17, 2022, 08:55:22 »
Has the log shown a Smoking gun?