Author Topic: [solved] no access to the "Screen on/off" function with a BT remote controler  (Read 337 times)

Offline uenue

  • More than Newbie
  • *
  • Posts: 10
    • View Profile
  • Device: Samsung S8
Dear experts,

I have successfully connected a "Magicsees Bluetooth remote control" with LM. So I get access over various functions "without touching the display", but with the buttons of this BT remote control.
The standard options that LM offers for this feature can be found in the "Expert Settings".
And exactly there you will find the (important) function "Screen on/off".
This function is supposed to turn the screen on/off (=save battery) at the push of an assigned button.

I can assign a button of the BT-FB to this function successfully (like I did with the other functions e.g. map zoom, map centering), but as soon as I press the assigned button on the remote control, the following Android/LM (?) message appears (see attachment).
If I now click on "Activate", the message disappears, but the button has no function afterwards, i.e. the screen neither turns on nor off at the push of a button.
If I close LM and restart it, the same thing happens: message appears, click on 'Activate', message disappears, no function.

It looks like LM/Android asks for the correct permission to be granted, but when you give this permission, it is not accepted and not saved.

I have already searched without success in the settings of LM or Android.
- All maps and LM itself are saved in the internal memory.
- I have also already deactivated any screen lock in Android - nothing....

Any ideas by the Pro's?
Am grateful for any tip :-)

Many greetings
Cali
« Last Edit: July 29, 2021, 13:47:06 by uenue »
"Who is like us? There are only a few...and they're dead!"
 

Offline Menion

  • Locus team
  • Professor of Locus
  • *****
  • Posts: 12461
  • Thanked: 771 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Hi,
we were already fighting this issue a long time ago. Please read the orange box in our manual below this setting and let me know if this helped.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
 
The following users thanked this post: uenue

Offline uenue

  • More than Newbie
  • *
  • Posts: 10
    • View Profile
  • Device: Samsung S8
Hi Menion,

thanks for the tip; I will check it out this afternoon.
Although I had already moved the maps back to the phone's internal memory, there were still parts of the LM installation probably on the external SD card storage. I had always assumed that LM ALWAYS installs itself to the internal memory. This was probably not the case.
However, I just moved the installation of LM from the external (SD-Card) to the internal memory.
This afternoon I'll see if this will solve the problem with the "screen on/off function" in interaction with the BT remote control.
I will give you feedback in any case.

Best regards
Cali
"Who is like us? There are only a few...and they're dead!"
 

Offline uenue

  • More than Newbie
  • *
  • Posts: 10
    • View Profile
  • Device: Samsung S8
Hi Menion,

your hint was the solution: everything works fine ;D
Now I'm able to switch the 'screen on/off' with the assigned button.
I don't have to turn off the Android screen controls to do so

All I have to do additionally is to set the "Disable Screen Lock" function to the "All screen locks disbaled" value.

Thank you very much!!!

Regards
Cali
« Last Edit: July 31, 2021, 04:58:45 by uenue »
"Who is like us? There are only a few...and they're dead!"
 

Offline Menion

  • Locus team
  • Professor of Locus
  • *****
  • Posts: 12461
  • Thanked: 771 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Perfect! I do not know why there is such weird limitation, but at least we have confirmed it works, thanks too.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
 
The following users thanked this post: uenue