Author Topic: [APP] - version 3.49.+ ( 15. 10. 2020 )  (Read 1756 times)

Offline Andrew Heard

  • Master of Locus
  • ****
  • Posts: 821
  • Thanked: 49 times
    • View Profile
  • Device: Samsung Galaxy A5 Oreo/8, Lenovo Note 4 Nougat/7.1
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #15 on: October 28, 2020, 22:13:21 »
The new directory for custom profiles should be "Locus/router/profiles". This directory should be already created by Locus Map upon start. Old Locus/data/brouter directory is no longer used.
Thanks for reply. I can see an empty Locus/router/profiles2, but no Locus/router/profiles directory. Directory datestamp is yesterday 28/10/2020 when I upgraded to 3.49. I also assume Locus has copied BRouter BRF files into Locus/data/brouter/profiles2. Directory datestamp is 15/4/2020. This is quite confusing. Should Locus move all Locus/data/brouter/profiles2/*.BRF to Locus/router/profiles/? And if the former directory is now empty, delete that directory?

I moved one BRF from Locus/data/brouter/profiles2/ to Locus/router/profiles2/ & this is displayed in profile list. So are you sure you mean /profiles, not /profiles2?

I created a short route yesterday (GPX attached) to test another issue, but Locus 3.49 crashes very shortly after I start navigation along the route. There is one navigation command announced then crash. I've never seen a navigation crash before. Can I send more info?

PS. I have just used a long route for which navigation was working in 3.48 but now crashes in 3.49. So this bug is related to 3.49 (or my configuration), not something strange related to the route.
« Last Edit: October 28, 2020, 22:40:04 by Andrew Heard »
 

Offline Menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11929
  • Thanked: 461 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #16 on: October 29, 2020, 12:42:11 »
@john_percy
routing data for integrated BRouter now needs to be download/updated manually. As I wrote before, I'm currently with @radim work on system integrated also in Locus Map.

@Andrew Heard
Ah sure, sorry, I wrote address just from the head without verification. "Locus/router/profiles2" is the correct path. During the update, the app only copied old existing profiles from Locus/data/brouter directory to new Locus/router/profiles2, nothing more.

Crash: nothing un-usual on the GPX file.I've tried it and no problem, so please if this still happens, create a log by common method. Thanks!
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
Support email: locus.map@asamm.com
 
The following users thanked this post: Andrew Heard

Offline Menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11929
  • Thanked: 461 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #17 on: October 29, 2020, 14:16:11 »
Configuration:
: GPS in LM Pro is always on (with an entry in cfg)
: Location service is handled in Android settings (on/off global)

If you start LM Pro and _than_ switch on Location service , LM Pro will never get an satellite signal. LM Pro has to be shut down and restarted. Means, LM Pro needs an activated GPS from the beginning. Not nice :(

Can't confirm.

In LM, I've set "always enabled GPS at start", then closed that app. In system, I've disabled "location" and started Locus Map. Blue warning about disabled GPS appears. The GPS icon is colored orange, but nothing is visible on the map. Later, I enable "location" in the system. Immediately Locus Map start loading new location. Did I miss any steps?
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
Support email: locus.map@asamm.com
 

Offline Andrew Heard

  • Master of Locus
  • ****
  • Posts: 821
  • Thanked: 49 times
    • View Profile
  • Device: Samsung Galaxy A5 Oreo/8, Lenovo Note 4 Nougat/7.1
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #18 on: October 29, 2020, 23:41:59 »
Crash: nothing un-usual on the GPX file.I've tried it and no problem, so please if this still happens, create a log by common method. Thanks!
thanks for checking the GPX file; I've emailed you the report

The crash is 100% repeatable in LM Pro 3.49, it didn't happen in LM Pro 3.48. Unfortunately it happens in LM 4 3.49.0.2_967_beta too although it was a few announcements later. But it is always just after a navigation announcement.
« Last Edit: October 30, 2020, 22:02:45 by Andrew Heard »
 

Offline freischneider

  • Master of Locus
  • ****
  • Posts: 645
  • Thanked: 51 times
    • View Profile
  • Device: Samsung S8, Locus Pro, always newest official version
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #19 on: October 30, 2020, 06:59:29 »
@ Andrew Heard
Please post LM4 topics here.  https://forum.locusmap.eu/index.php?topic=6817.0
 
The following users thanked this post: Menion, Andrew Heard

Offline Christian

  • Premium
  • Master of Locus
  • ****
  • Posts: 835
  • Thanked: 10 times
    • View Profile
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #20 on: October 30, 2020, 16:50:58 »
Configuration:
: GPS in LM Pro is always on (with an entry in cfg)
: Location service is handled in Android settings (on/off global)

If you start LM Pro and _than_ switch on Location service , LM Pro will never get an satellite signal. LM Pro has to be shut down and restarted. Means, LM Pro needs an activated GPS from the beginning. Not nice :(

Can't confirm.

In LM, I've set "always enabled GPS at start", then closed that app. In system, I've disabled "location" and started Locus Map. Blue warning about disabled GPS appears. The GPS icon is colored orange, but nothing is visible on the map. Later, I enable "location" in the system. Immediately Locus Map start loading new location. Did I miss any steps?
Did you switch off the display (multiple times) before you activated GPS in system and before GPS signal is available?
Sometimes i can not reproduce the behaviour but last week i happend three times in an row.
 

Offline Menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11929
  • Thanked: 461 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #21 on: November 02, 2020, 09:06:03 »
@Christian
uff. If I remember correctly, you wrote nothing about turning on/off display etc etc  ;D

Oki ... so please, exactly

Requirements:
- system GPS turned off
- Locus Map GPS settings set to "Start always"

Steps
- start Locus Map, it tries to use GPS, but it is disabled in the system, so the icon remains orange and you see a blue warning popup after a while
- turn the screen on/off multiple times
- turn GPS in the system settings
- Locus Map ignore enabled GPS and still does not load location

----

These are steps that cause the mentioned problem? No problem with my device. So please modify if you do something differently, thanks.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
Support email: locus.map@asamm.com
 

Offline Henk van der Spek

  • Premium
  • Padavan of Locus
  • ***
  • Posts: 252
  • Thanked: 8 times
    • View Profile
    • enduro.nl
  • Device: Ulefone Armor 2 Android 7.0
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #22 on: November 06, 2020, 20:06:06 »
An old? problem seems to be back.
It's about track style and color.
Style on map for this track is set to be "Folder" but that is partly ignored when navigating reversely. We use arrows pattern 3 and they are reversed but the color of the "folder" is not applied.
It works ok when navigating in original direction (so using complete folder style).

To make it even more complicated this happens on my wife's android 10 phone but I can not simulate it on my Android 7 with the same track and settings.
« Last Edit: November 07, 2020, 21:34:35 by Henk van der Spek »
Ulefone Armor 2 Android 7.0
 

Offline Žajdlík Josef

  • Padavan of Locus
  • ***
  • Posts: 386
  • Thanked: 21 times
    • View Profile
  • Device: Xperia M, Alcatel One Touch II, Samsung A3 (2017)
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #23 on: November 08, 2020, 17:42:49 »
Greetings to all and I apologize for the Czech language. But the description is too complicated for my knowledge of English.

Dnes jsem narazil u Locusu na dvě věci. Jednu považuji za chybu, ta druhá by byla dobrým vylepšením Presetů. Bylo by asi dobré, kdyby minimálně ta první byla v LM4 opravena.
Když spustím navigaci bez přepočtu trasy, navigace vydává navigační příkazy i když sjedu z trasy. Je to dost blbé, když jsem třeba dost daleko od trasy a ona hlásí, abych odbočil po za 500 m doprava. Přitom já vím, že musím jet doleva abych se na trasu vrátil. Takže bych doporučil, aby se navigační příkazy vypnuly po překročení vzdálenosti na upozornění ze sjetí z trasy. Zapnuly by se pak až po návratu na trasu. Nemělo by to snad ani být moc složité. Hlavně pro začátečníky je totiž současný stav dost matoucí.
Když mám vytvořených více Presetů, ztrácí se přehled, které funkce jsou ve kterém použity. Takže třeba vytvořím Preset pro turistiku bez otáčení mapy, ale s čárou ve směru pohledu. Po čase si chci vytvořit Preset na kolo, ale už nevím, že jsem v některém předchozím nastavil neotáčení mapy. Vznikají z toho takové zmatené situace. Pokud by to tedy bylo možné, barevně bych v “Obsahu” zvýraznil funkce, které už jsou v nějakém Presetu použity. Při nastavování by hned bylo jasné na co si dát pozor. Tohle je asi složitější, ale rozhodně by to moc pomohlo s přehledností nastavení.
 

Offline 0709

  • More than Newbie
  • *
  • Posts: 50
  • Thanked: 62 times
    • View Profile
  • Device: THL4000 CM12.1 (A5.1.1) SM-T235 (A5.1.1) MI A2 Lite (A9)
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #24 on: November 08, 2020, 20:50:08 »
Check maximum deviation from route distance.
Locus Pro 3.49.0
 
The following users thanked this post: Žajdlík Josef

Offline Christian

  • Premium
  • Master of Locus
  • ****
  • Posts: 835
  • Thanked: 10 times
    • View Profile
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #25 on: November 12, 2020, 16:30:13 »
@Christian
uff. If I remember correctly, you wrote nothing about turning on/off display etc etc  ;D

Oki ... so please, exactly

Requirements:
- system GPS turned off
- Locus Map GPS settings set to "Start always"

Steps
- start Locus Map, it tries to use GPS, but it is disabled in the system, so the icon remains orange and you see a blue warning popup after a while
- turn the screen on/off multiple times
- turn GPS in the system settings
- Locus Map ignore enabled GPS and still does not load location

----

These are steps that cause the mentioned problem? No problem with my device. So please modify if you do something differently, thanks.
Sounds weird? Display on/off means GPS on/off when energy savings are active.
 

Offline Menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11929
  • Thanked: 461 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #26 on: November 16, 2020, 13:16:41 »
@Henk van der Spek
thanks for the info about the incorrect style of navigation route in the reverse direction. The issue found and fixed.

@Žajdlík Josef
1. as 0709 correctly wrote, check the mentioned settings. Also agree Willy, that is should be somehow united.

2. I also have a bigger update related to presets in my head that will hopefully help in this case as well. Next year hopefully ...

@Christian
So my steps are exactly what you do + enabled "energy saving" in your device?
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
Support email: locus.map@asamm.com
 
The following users thanked this post: Henk van der Spek, Žajdlík Josef

Offline Žajdlík Josef

  • Padavan of Locus
  • ***
  • Posts: 386
  • Thanked: 21 times
    • View Profile
  • Device: Xperia M, Alcatel One Touch II, Samsung A3 (2017)
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #27 on: November 16, 2020, 15:06:29 »
@ Menion, 0709 Thank you, that will probably be the problem. I have set 2000 m.
 

Offline slarti76

  • Apprentice of Locus
  • **
  • Posts: 236
  • Thanked: 24 times
    • View Profile
  • Device: S9, XCover 4s - Galaxy Tab S5e & S2 9.7
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #28 on: November 17, 2020, 08:59:47 »
Noticed an annoying new behaviour:
When I edit a track with "Modify Track" and exit the editor, it returns me to the position when I opened the editor! Usually, I exit the editor to add or remove waypoints from a track at the position where I am just now (because, unfortunately, still can't do that in the editor).
Is there any way to turn that off?
I faintly remember this in the changes list of a new version - but what is the reasoning? I don't see the benefit...
 

Offline Menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11929
  • Thanked: 461 times
    • View Profile
    • http://www.asamm.com
  • Device: Pixel 2
Re: [APP] - version 3.49.+ ( 15. 10. 2020 )
« Reply #29 on: November 19, 2020, 09:15:18 »
Quite old topic
- 3 positive votes, 0 negative
- united behavior with the Route planner
Feel free to convince more people that old behavior was a lot better. But as usual, this will lead to different personal usage > extra settings to satisfy all  ::)
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
Support email: locus.map@asamm.com