[APP] - version 3.44.+ ( 20. 2. 2020 )

Started by Menion, February 21, 2020, 15:43:24

0 Members and 1 Guest are viewing this topic.

slarti76

In the icon selection dialog, there it's possible to order the icons into section with a special file in the ZIP. I know that because I once redid the icon collection in the store (Menion, perhaps you remember).
Today I noticed that the sections are still there, but the section titles are gone. Don't know since when, but definitely in 3.44.2. Is there a reason or is that a bug?
  •  

slarti76

Another thing, which I still think is a bug:
In the store, when I choose "Check for Updates", it will show me for which maps there are updates. However, this is only based on whether I bought the updates, not if my maps are up-to-date.
I have several phones, so when there are new LoMaps out, on one phone it will show me the updates. Then I buy the updates and download them, but on the other phones "Check for updates" doesn't show them anymore. Yes, I bought them now, but the maps on those phones are not updated, so I think they should be displayed there, too.
  •  

balloni55

long click on "preset icon" in side panel / information > window appears "purchase locus...."
although PRO is running
LMC 3.70.1 AFA
Locus Map 4.20.0 Gold AFA
LMC User ID c8b19276f
LM4 User ID e06d572d4
  •  

Menion

@Andrew Heard
probably some problems with the auto-loading of maps.

@tapio
if you tap on the menu > more > import, then this imported file (track) has an incorrect name? May you please double-check it? Because I see no problem on my side, thanks.

@slarti76
missing section: hmm good observation. It seems to be a problem not directly in my code. I'll have to do something with it, thanks.
"Check for updates problem" may be a little more complicated. I'll discuss this with @Petr if we have something to do here.

@balloni55
ah, thanks :)
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

Viajero Perdido

Quote from: menion on March 22, 2020, 09:53:16
@Andrew Heard
probably some problems with the auto-loading of maps.
Oh speaking of which...  I see the opposite effect.  I often have several OAM maps that *could* be chosen for the selected area - eg current and older for "home" - and Locus often decides to show both at the same time.  Green areas get darker (rendered twice), trails get doubled if they've been edited between the versions.  Manually selecting the map I want makes the other one go away.

I don't have an exact recipe to trigger this, but it's not uncommon.
  •  

john_percy

I think this is a known issue if you have Automatic map loading turned on for offline vector maps. (Settings - Maps - Offline maps - LoMaps & other vector maps).



Sent from my moto g(6) plus using Tapatalk

Voluntary and Velocity themes - https://voluntary.nichesite.org

Andrew Heard

Quote from: john_percy on March 22, 2020, 18:33:31
I think this is a known issue if you have Automatic map loading turned on for offline vector maps. (Settings - Maps - Offline maps - LoMaps & other vector maps).
thanks @john_percy - I had that setting enabled. The problem has only occurred once so unlikely to know if fixed.
LM4.20.1.0 GOLD user ID:c7d47597a
  •  

Tapio

Menion indeed, the file imports correctly, need to look closer, sorry.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download
  •  

balloni55

Hello menion
inside folder of locus auto backup sometime .temp files are stored, i suspect they remain on a unsuccessful backup
LMC 3.70.1 AFA
Locus Map 4.20.0 Gold AFA
LMC User ID c8b19276f
LM4 User ID e06d572d4
  •  

Menion

Thanks balloni, you are correct, these are results of some failed backups. I've added it to "Backup improvements" todo list, thanks.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 Release download
  •  

poutnikl

#40
EDIT: To avoid redundant investigation, you may want to skip to findings in post #50.
------
The Route planner in the PRO Release 3.44.3 is  reporting a straight line stats in spite of the route segment being calculated by the BRouter. I do not remember such a behaviour before.

I  tried to calculate a cycle route Brno (S Moravia ) to Feldbach ( SE Austria ) by one of my profiles.

When I had calculated the route within the Locus route planner ( no intermediate via/shape points ), it reported distance 252 km and ascend above 8000 m, what seemed to be statistics of the straight line across all mountains and valleys along the line. ( screenshot )

When the route had been calculated directly via BRouter as an aftercheck, it reported  the direct distance  about 252 km, the true route distance about 350 km and the filtered ascend ( via 10m hysteresis filter ) cca 1100 m ( used to be cca 1/2 of the unfiltered ascend usually reported by Locus ).

But, when I saved the route calculated in the planner and displayed the saved route statistics, it provided the correct and expected about 350 km distance and about  2000 m total ascend. ( screenshot )

The same happened when I had formally divided route into several segments by converting few guidance points into shape points.

The route planner may easily confuse users during the planning.

Sorry for dark images, taken in reddish subzero night mode vision.



Sent from my Xiaomi MI A2 / Android 10, via Tapatalk

poutnikl

#41
What is interesting, that the shorter route, very familiar to me, along car road 373 from the eastern part of Brno to the north to the village BeneŇ°ov ( near Boskovice town ) , with help of few shape points, is evaluated correctly, some 48 km and about 900m.

But when I returned to re-evaluating the affected route Brno Feldbach, It was wrong again.

Similarly for Vienna-Feldbach. It has shown  just about 4500 m, comparing to previous 8400m for Brno-Feldbach ( like If there had been huge mountains between Brno and Vienna, haha. It is a flat region ). When I moved start little to the west along Donau, the planner returned the ascend 9500m, as straight line goes through higher mountains there.

Few shape points little prolonged the straight line distance, and little decreased the crazy ascend, but not much.

All with Trekking-dry profile. Just reminding calculation directly in Brouter application provides proper distances and ascends, so do the statistics when the route is saved ( with expected 2:1 exception of Locus/BRouter ascends ). And finally, the Route planner draws the real BRouter route, not a straight line.

Sent from my Xiaomi MI A2 / Android 10, via Tapatalk

Tapio

Route planner, add green waypoints, save route, exit route planner. Tap this new track, enter route planner, no green waypoint there, it has not always been like this?
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download
  •  

poutnikl

@tapio  I did so as you described and the green shaping triangle points are still there, as usually.  ( not related to stats issue).

Sent from my Xiaomi MI A2 / Android 10, via Tapatalk


Tapio

Same here, but there must be conditions where it forgets those points, see attachment. Only 2 points left on a complex track.
Tapiola MFV4+ theme for OAM Maps:
Discuss - Download
  •