Author Topic: Locus exits if trying to open Ant+ menu  (Read 471 times)

Offline BlueCharge

  • Newbie
  • *
  • Posts: 9
    • View Profile
Locus exits if trying to open Ant+ menu
« on: December 17, 2019, 18:56:26 »
Hello,

I encounter this problem on my Galaxy S10e (Exynos9820), Android 10 whenever I try to opne the Ant+ menu in Locus Pro v3.42.0
The app "ANT Tester" shows no problems and the app "myWorkouts" finds my Garmin Tempe sensor and shows the temperature reading, so it shoulnd´t be any of the hardware.

Could you please have a look?
I´m happy to help if I can.

Thank you!
« Last Edit: December 17, 2019, 18:58:11 by BlueCharge »
 

Offline BlueCharge

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Locus exits if trying to open Ant+ menu
« Reply #1 on: January 09, 2020, 12:18:31 »
The problem still remains unchanged.
I would like to use an ANT+ device with Locus, but at the moment it is unpossible.
@Menion could you please help?
« Last Edit: January 09, 2020, 12:20:16 by BlueCharge »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11779
  • Thanked: 409 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Locus exits if trying to open Ant+ menu
« Reply #2 on: January 09, 2020, 13:36:12 »
Hi, sorry for missing answer.

ANT+ on Android 10 will be fixed in the next Locus Map version (published during the next days).
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline BlueCharge

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Locus exits if trying to open Ant+ menu
« Reply #3 on: January 09, 2020, 21:03:03 »
Great - Thank you very much  :)
 

Offline BlueCharge

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Locus exits if trying to open Ant+ menu
« Reply #4 on: January 11, 2020, 17:36:20 »
@Menion:
I´m sorry to report that Locus Ant+ menu still seems to be buggy.
Opening the menu works, but the search for Ant+ devices is not successful (at least it didn´t find a Garmin Tempe Sensor nor a heart rate strap).
Now I encounter repeated force close of Locus, if I try to open the Ant+ menu because Locus tries to find any possible device (all hooks in menu are blue) and if I hit the back-button of Android to stop this process, Locus crashes.

 Looking forward to help with more infos and I also would like to test a beta if that helps.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11779
  • Thanked: 409 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Locus exits if trying to open Ant+ menu
« Reply #5 on: January 13, 2020, 12:53:40 »
Hello, thanks for the bug report. I see the mentioned problem in automatic bug reports. There will be one more version during this week with some minor bug fixes.
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!