[Theme] OutdoorV4 theme for new mapsforge V4 OpenAndroMaps

Started by bm.ffb, April 26, 2019, 09:55:52

0 Members and 1 Guest are viewing this topic.

bm.ffb

To the Locus and OpenAndroMaps community,

after many try-and-error runs I was able to adapt my "outdoor" theme and create the new "outdoorV4" theme, which can be used with the new multi-language mapsforge V4 OpenAndroMaps. It is compatible only with these new maps!
In general, I have tried to make the theme identical to the existing "outdoor" theme. Due to problems with many tags used for the configuration of font sizes and priorities, many small changes had to be made. You will find more details (i. e. which tags had to be ommitted) an my website www.maiwolf.de/locus/ [in German].
Please take the theme as a draft. I am happy for any comments, suggestions and there will be constant improvements. Maybe, I will adapt in the future also my existing "desert" theme.

Download the newest version on www.maiwolf.de/locus/

Bernard

Magellan

Thanks for the hint about the problem tags in the theme for V4 on your site.
  •  
    The following users thanked this post: bm.ffb

Andrew Heard

Quote from: bm.ffb on April 26, 2019, 09:55:52
Maybe, I will adapt in the future also my existing "desert" theme.
Bernard I really hope so - desert is my favorite theme these days because it's the only one to properly differentiate between sealed/ unsealed roads for cycling. Thanks for all your work.
LM4.11.1.5 GOLD user ID:142d400c7
  •  
    The following users thanked this post: bm.ffb

Viajero Perdido

#3
I really like the Outdoor theme, so thank you, especially for adapting it for V4.

If I can offer a few suggestions...

  • For some reason, highway=bridleway renders abnormally large.  For example, at N53 31.484 W113 32.897 on the OAM Alberta Canada V4 map.
  • Certain highway types, where they meet (eg, residential x service), are drawn such that they appear to be unconnected.  If you were to imagine the ways as pipes, water couldn't flow through the connection.  That's sent me into OSM a few times to double-check the data. ;D
  • There's no checkbox for boundaries and protected areas.  Given that the theme draws the name on each tile, and Locus still uses lots of tiles, this can lead to a display rather full of names.  It'd be nice to have the option to turn this off.
Thanks!
  •  
    The following users thanked this post: bm.ffb

Tobias

Quote from: Magellan on April 27, 2019, 05:04:34
Thanks for the hint about the problem tags in the theme for V4 on your site.
I made a reference which mapsforge version support which tags that can be found here:
https://www.openandromaps.org/oam-forums/topic/mapsforge-rendertheme-reference
developer of Elevate mapstyle for OpenAndroMaps

bm.ffb

Quote from: Viajero Perdido on April 28, 2019, 00:23:14

  • For some reason, highway=bridleway renders abnormally large.  For example, at N53 31.484 W113 32.897 on the OAM Alberta Canada V4 map.
  • Certain highway types, where they meet (eg, residential x service), are drawn such that they appear to be unconnected.  If you were to imagine the ways as pipes, water couldn't flow through the connection.  That's sent me into OSM a few times to double-check the data. ;D
  • There's no checkbox for boundaries and protected areas.  Given that the theme draws the name on each tile, and Locus still uses lots of tiles, this can lead to a display rather full of names.  It'd be nice to have the option to turn this off.

Dear Viajero,

thanks for your hints. Your point #1 and #3 are fixed/changed and can be found in the new version on my website.
The point #2 I do not completely understand. It would help if you could show a screenshow of an example.

Regards,
Bernard
  •  

Viajero Perdido

Thanks, and thanks!

It's hard to describe, but a picture is worth a hundred of my words.  This is from V3, but I think V4 is the same.

Currently, the ways look disconnected, as if one crosses above/below the other.  (Notice also the junctions of alleys to residential in the same image.)  I think the style on the right is how it's more commonly done, and what my eyes expect to see.

Thanks again, VP.
  •  

bm.ffb

Dear Viajero,

thanks for the screenshot.
I think I have understood your request. I have found a fix and placed a new version on my website (www.maiwolf.de/locus/). Please check it out.

Regards,
Bernard

Viajero Perdido

#8
Hi.  Thanks again for the quick response.

I gave both outdoor and outdoorV4 a try, but see nothing different about road junctions.  I've noticed the .xml in both zip files is dated a few days ago.  Did you possibly forget to upload the latest?

I see you've fixed the bridleway glitch, thanks.  But I've noticed now that some mixed-use trails, ones for both cyclists and walkers (such as the one beside the bridleway I mentioned), no longer appear unless you've selected "cycling lanes".  This happens with trails tagged highway=cycleway, foot=yes.  (There are multiple ways to tag such mixed use, and I think my city has them all.)  I'd suggest walking trails *always* be visible, given the name of the theme.  :)
  •  

bm.ffb

Dear Viajero,

the display of a cycleway as part of a mixed-use trail (or path) is just an overlay in addition to the trail (path) display itself. To show it more clear I have set the cycleway a bit more transparent and moved it just a tiny bit away from the actual trail (path) display. Maybe this helps. As a cyclist I definitively want to see the cycleway even if it is "misclassified" as "highway=path" + "bicyle=designated".

The change version is on my website (I have double checked).

Regards
Bernard

Viajero Perdido

Hi again.  I'm really enjoying outdoorV4.

But maybe, a bug.  I think the combination of highway=path and tracktype=* makes trails invisible with both outdoorV4 and desertV4.

I couldn't force https://www.openstreetmap.org/way/120426357 to display, even when ticking all the checkboxes, and I think tracktype might be the cause.  This is with the June 2019 Alberta_ML.map from OAM.  The other V4 themes I have all displayed the trail.

Thanks as always,
VP
  •  

bm.ffb

Dear Viajero,

you are right. The combination of highway=path and tracktype=* (means some value is given) is so far not displayed in my V4 themes.
According to the openstreetmap wiki this combination should not be used:
https://wiki.openstreetmap.org/wiki/Tag:highway=path?uselang=en-US
I think the mentioned definition is useful: a way is either a track or a path, but not both.

But, as long as nobody else complains, I have adjusted the outdoorV4 and desertV4 themes to display this strange combination (I have tested it on the Alberta_ML map). The update in on my website: www.maiwolf.de/locus

Regards,
Bernard

Viajero Perdido

Thanks for tweaking that; I'll check it out shortly.  (Just got back from a trip, so I'm slow in replying.)

I noticed the wiki isn't consistent about this; the page for tracktype https://wiki.openstreetmap.org/wiki/Key:tracktype suggests there is usage when combined with path, and well, I've seen it with my own eyes.  :)  Cheers.
  •