why would the route in this GPX not show elevations?

Started by Andrew Heard, February 28, 2019, 07:13:36

0 Members and 1 Guest are viewing this topic.

Andrew Heard

The attached GPX file was generated by RWGPS. It contains <ele> data but Locus track statistics & chart show no elevations. Why? Other similar files are fine.
LM4.14.2.1 GOLD user ID:142d400c7
  •  

Menion

Good day Andrew,
nice "bug". Your track has a minimal value equal to "0", so Locus detect this as an invalid value and refuse to display it. Fixed, thanks.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Andrew Heard

Quote from: menion on February 28, 2019, 13:50:18
Good day Andrew,
nice "bug". Your track has a minimal value equal to "0", so Locus detect this as an invalid value and refuse to display it. Fixed, thanks.
where is this  minimal value equal to "0"? All the elevations seem OK to me, eg (start of file):

      <trkpt lat="-42.886764" lon="147.331907">
        <ele>12.1</ele>
      </trkpt>
      <trkpt lat="-42.886663" lon="147.331929">
        <ele>11.7</ele>
      </trkpt>
      <trkpt lat="-42.886662" lon="147.331929">
        <ele>11.7</ele>
      </trkpt>
      <trkpt lat="-42.886657" lon="147.331864">
        <ele>11.7</ele>
      </trkpt>

Just curious.
LM4.14.2.1 GOLD user ID:142d400c7
  •  

Christian

eg line 577 - 589.
I had this case an year ago also.
  •  

Menion

- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Andrew Heard

@menion - those elevations are valid - bridge/ sea level. As you say - now fixed.

For example line 576 - https://www.google.com.au/maps/@-42.86539,147.33802,21z.
LM4.14.2.1 GOLD user ID:142d400c7
  •