Samsung Gear/Galaxy Watch add-on feedback and testing

Started by milan.cejnar, November 23, 2018, 16:29:44

0 Members and 1 Guest are viewing this topic.


this thread is for general feedback and testing of new versions of Locus Map Watch add-on for Samsung Gear and Galaxy Watch.

Currently only closed beta version for registered users is available and is distributed only using Galaxy Apps (on both phone and the watch because of Samsung limitations). Registered users should be able to install and transfer the add-on to their watch by opening this link directly on their phone (Galaxy Apps should capture the link and open add-ons store page)

The closed beta version should communicate with the latest Locus Map Free or Pro versions directly. When the official "public/open" beta comes out it will be only available for Locus Map Free (again due to some Samsung companion app policies, we will probably have to make separate Locus Map Pro Gear add-on even though both add-on versions will be practically identical).

The add-on requires Locus Map phone app to run, it is not (at least yet) stand-alone.

There are two main screens available:
- Map screen: features zoomable and scrollable map with autocenter/rotate function button.

- Track recording screen: Offers function to select one of your tracking profiles and start the track recording. Then there is multi-page dashboard when the recording is active. You can pause/resume/stop the recording or add waypoint. Dashboard values are configurable by long-pressing them directly and choosing a value from the displayed option list.

Not yet available features:
- navigation directions: partially implemented but not available. Navigation directions will be available directly on top of the map as an overlay when the navigation is active.
- heart rate measurement: something we would like to add, but the implementation has not even started yet.

Known (serious) bugs:
- screens might not display correctly or at all on Gear S2 (seems to be mostly the case right after installing the add-on. On second or third run the things seem to sort out themselves for some reason)

- the add-on refuses to connect to the phone if the phone is in "sleep"(i.e. has had the screen turned off for a while). Just turning on the phone screen makes the add-on suddenly reconnect. Confirmed with Samsung S7 (Android 8) and Gear S3 - if you are also affected by this problem please let me know.

I don't have access to the latest Galaxy Watch so any kind feedback from that watch would be helpful.

Please share with me any bugs, crashes or any other feedback which would help me improve the app for you.

Thanks a lot and hope you will enjoy :)



Wonderful!! I got to play with this for a bit today.
I have Samsung:
Galaxy S8 phone, Android 8.0.0
Galaxy S3 Frontier watch,  Tizen

I tested with a walk around the neighborhood, driving to a park and searching for a geocache.

I found the position updates on the watch to be quite delayed.  I usually had to raise the watch 2 or 3 times before the position updated on the map.  So maybe it was something like every 10 seconds before my position updated?  I had the phone set to using Google Satellite maps.  I tried it again using an offline OSM map and although the display update of the map tiles was faster, the position update was still too slow for my taste.

If the phone screen shut off or I manually shut it off and put the phone in my pocket, the screen stopped updating altogether.  I thought if I turned on "run Locus as a service" this might not happen.  I also turned off battery optimization on the phone.  I'm not sure yet if that cured the problem.

I recorded a track and then put the phone away.  When I stopped the track, I got an error message of "can't connect to Locus - can't save" or something like that.  Turned the phone screen on and hit the stop recording button and it saved the track OK.  I never got the chance to specify WHERE to save the track, it just used the last track folder location that I had used before.

On my second track attempt, I started track recording.  Then I also selected "Hiking" in the Samsung Fitness App, which also records a track and heart rate.  Both ran concurrently and both recorded the same track.  One oddity was that the first time I raised my wrist, the Locus track screen came up.  After that, the Samsung track screen came up whenever I raised my wrist.  I could navigate back to the Locus track screen OK.  But the next time I raised my wrist, it defaulted to the Samsung screen again.  Not a big deal and I suppose not many people would run two different track recording apps at the same time.  I just thought it odd that the watch did not return to the last used screen each time.

I found the waypoint icons on the screen to be much too large.  And the default directional pointer was HUGE on the screen. Quite distracting.  Is it possible to make them smaller?

What I really, really want to see is something like the compass screen.  When hiking or geocaching, I'm usually navigating towards a waypoint.  I start the navigation and then put the phone away.  I'll periodically pull the phone out to check on my progress, noting the bearing, heading and distance.  I'd love to see this displayed on the watch so I could leave it in my pocket and just check the watch every now and then.

I tried setting the app as a Widget but it does not show up in the list of available widget apps.

I have a suggestion... If you have to make separate versions for Pro and Free, shouldn't the Pro folks get it first?  They are the ones who paid. And I would think more active.... Just a thought.

Well, that's all for now.  Thanks for starting the development of this!


I have Samsung:
Galaxy S7 phone, Android 8.0.0
Galaxy S3 Frontier watch, Tizen
Locus Map Pro v.3.34.1

Naprosto souhlasím s JohnCNA ve všech zkušenostech
- zpoždění s aktualizací polohy při zobrazení na druhý nebo třetí pokus
- ikony jsou větší než je třeba - rušivý efekt
- kompas, ten by byl super! směr a vzdálenost, to potřebuje každý geocacher ;)
- widget na rychlé spuštení

Jinak super práce, chválím moc a těším se na další rozvoj ;)

I totally agree with JohnCNA in all my experience
- delay with location update when viewed on second or third attempt
- Icons are bigger than needed - Disturbing effect
- compass, that would be great! direction and distance, each geocacher needs it  ;)
- quick start widget

Otherwise super work, I very much praise and look forward to further development ;)


I just did the following test while running a store errand.

Made sure Locus was set to Run as Service and battery optimization was off. Selected a waypoint and Guide On. Turned off the phone screen. Selected map on the watch. Map worked and updated as I drove with phone screen off.

A couple times when I raised my wrist, the watch had gone back to the watch screen and I had to navigate back to the Locus screen and select Map again. I can't tell if the app stopped or just went into the background.


Hello @JohnCNA @3am
thank you very much for the thorough testing. As I feared you have confirmed the connection issue on Galaxy phones when the screen is turned off. This issue and GUI issues on Gear S2 will now be a priority to solve.

As for other feedback
- map icons/cursor too big: Yes I also have that feeling, Menion and I will try to tweak the sizes so the map looks more optimzed for the watch screen

- compass screen: would be nice, won't probably be in the first version though

- widgets for the app: Also nice idea. Probably not usable for the map, but the compass could work very well. I will research the widget possibilities later.

- laggy map: well the map should refresh only once every 5 seconds if it is not being interacted with in any way. Of course when the map screen wakes up or is shown it should feed the data immediately (at least "Loading" or "Initializing" label should show up in the center). We will try to tweak it more, maybe the issues are caused by the unreliable connection issues.

- watchface shown instead of Locus Map on watch wake up: There is a logic in the app that Locus Map app should show automatically when the watchface shows up if the app was not closed explicitly by the HW back/home button. If this does not work then there might be some bug. Of course other application with the similar logic can force its way up to the top but you should not see watchface only.

The add-on will be targeted for the Locus Map Free first because of Locus Map Free Beta versions which we can release more easily and more often than standard Locus Map Pro version. Of course we will want to also support the Pro users as soon as possible (when the add-on is stable enough).



Hey, just got my mail, immediately installed it and all seems to be working well. I'm in the office so I can't try out much, but it looks like during recording, you can't see the map - that would be a shame. Maybe once recording starting, we could be sent back to the map screen, with a small button that goes to the recording interface ? By default, I think I would want to both look at the map and record my movements at the same time.


Hello Testi,
thank you for the feedback! There is a serious communication bug in this beta but it is manifested only when the phones screen is off for some time, so you might not have noticed it yet. This should be fixed in the next Locus Map version.
Regarding the map and track recording switching - could you please describe what exactly is the issue or what you would like to improve? Do you miss quicker possibility how to switch between map and track recording screens? Or would you like map view to be part of the track recording dashboard?
Otherwise you can switch between track recording and the map freely, the track recording is running in the phone so you can even exit the watch application and it has no effect on track recording until you explicitly stop the recording using the watch again or your phone directly.

Gerhard Kirchmair


I send you an email a little while ago to beta test the app. I have not received any confirmation so far. It would be great if I could beta test the app on my galaxy watch and galaxy s9!



I just wanted to let you know that the closed beta will stop working with Locus Map Pro afte the today's update.
I will probably release a new beta version targeting LM Pro because I expect that most of the testers are using LM Pro and not the free version.
Anyway sorry for the delays, I am kind of swamped now right before the holidays with some higher priority work that I need to attend to instead of the add-on.

By the way have you tried the add-on lately with the latest versions of Locus Map? The add-on should be able to connect to the phone practically any time now and the notification (foreground service) should appear in the Phone's notification area with the information that the watch is using Locus Map.

Best Regards


first of all, thanks for the add-on and your efforts to making it!

Just downloaded the watch app and updated the locus pro on my phone yet I failed to start testing it. I ticked the Connetct with add-on option on the phone but my watch says that "please initialize Locus on the phone first".

LM free works with the LM free add-on, only the pro versions don't connect.

Update: the free version only worked once and after that I keep receiving the same "please initialize.." message.
I have a lg g4 which has LM free (3.35.2) and LM pro (3.35.2). On the watch both the free (0.0.8 ) and pro (0.0.8 ) versions are installed.

Could someone post a quick set up guide dummies like me can start testing the add-on.

Thanks for your help.

P.s. hope it is the right thread to ask shuch thing.


@SmiCH Hello,
there is nothing to set up really. The versions of LM and the add-on that you use should communicate correctly. The message you see should only be displayed when the user tries to use the add-on without running LM on the phone even once (there is some one-time initialization that needs to be done by M during the first start after the installation).
Can you confirm that both LM Pro and Free is starting correctly after the update? And that the watch is communicating normally except the LM add-on? Which watch are you using to run the add-on?
Thank you

P.S. Oh I have just noticed there might be a bug (at least on my Gear S2) and that message might appear for a while when you start the add-on, but it should really disapper in a second or two if the communication is allright.



I have also had the same issue as @SmiCH.

With Locus Pro 3.35.2 and Locus Map Pro Watch 0.0.8 on a Samsung Galaxy Watch (the phone is a Galaxy S7) I get the please Initialize message.
With Locus Free (test version) and the free version of the watch app it works (although locus crashed on my phone after about 30mins)

I have cleared the locus cache and all data, plus reinstalling and rebooted but no improvement.

All other watch to/from phone communication seems to be working.



For everyone - if you encounter any Locus Map crash especially with the new version or new functionality it would help us immensely if you could capture and then send an Android bug report to us after such event.

@robuk Hi,
thank you for helpful input and for the confirmation of the "Please initialize ..." bug! I could not unfortunately reproduce it with Galaxy S7 and Gear S2. I am on vacation right now so I will try to dig around some more after New Year.


Thanks @milan.cejnar, good news I have completely uninstalled Locus Pro and re-installed it, which seems to have fixed my issue. I will try it properly next time I go out for a walk.



After uninstalling and reinstalling the pro version on the phone, now it seems to be working to me as well. 

I tried it with a long car tracking and with a short walk and worked well without any difficulties.

@milan.cejnar, just to answer your previous questions, I have a gear s3 that communicated well with my phone it was just the add-on. The LM pro and dree versions seem to start and work properly.