Wear for Locus Map beta testing

Started by milan.cejnar, December 06, 2017, 19:50:53

0 Members and 1 Guest are viewing this topic.


Sorry for the later answer.

QuoteBut I can confirm that if you turn off Locus Map on the phone while having Wear for Locus Map opened on the watch then Locus Map will just restart on the background because the watch still requests its services, that is the designed behavior.
that is what i was talking about. and i understand when locus on the phone restarts when it chrashed when it is connected to the watch
but its unpractical when you click the ok button on locus to confirm to close the app and forget the wtach and it just restarts and drain the phone battery.

QuoteWould you like maybe to have some dialog popup in the Locus Map saying that the watch is still connected and whether it should force kill the connection and then terminate Locus Map itself or something like that?
that sounds good


Hello guys,
a new beta version 1.1.2 of Wear for Locus Map has just been released.

If someone here wishes to test it and is not yet registered as a beta tester you can opt-in to become one via this link.

The version fixes some problems with swiping/scrolling in the track recording dashboard and also adds:

- heart rate measurement (and online HRM synchronization with LM) during track recording
- configurable values/statistics in track recording dashboard
- custom waypoint naming when adding new waypoint

Any testing and feedback is very welcome :)

Have a nice day,

Danjel Rojka

Hello Guys,

i have install the new app wear for Locus. I activate the HRM to synchronize to Locus Map. I see the Heart Rate Sensor was active but on the Smartwatch the Data was not send and not visible. I have setup the Dashboard on Smartwatch and the Track Recording was without Heart Rate Measurement.

Best Regards


@Danjel Rojka
So HRM is not working? :/ Can you confirm that the service is running on the watch while track recording is active? (Permanent notification should be in your watch notification area saying that the HR is running due to track recording).
Do you use latest versions of Locus Map and Wear for Locus Map apps on the phone?
Could you try running some other heart rate measuring app at the same time to see that the HR is really recorded by the watch?
And by the way, what watch are you using?


Danjel Rojka

So HRM is not working? :/ Can you confirm that the service is running on the watch while track recording is active? YES

(Permanent notification should be in your watch notification area saying that the HR is running due to track recording). YES

Do you use latest versions of Locus Map and Wear for Locus Map apps on the phone? Both is the latest Version. Locus Map 3.32.2 and Locus Wear Beta

Could you try running some other heart rate measuring app at the same time to see that the HR is really recorded by the watch? I have started the Polar App on the Watch and the Heart Rate was recorded and visible.

And by the way, what watch are you using? Polar M600 and the newest Wear OS

H Ifang

OK, got the beta.
At first I always had bluetooth connection error messages. As not everyone has auto-updates active on the phone: it should be noted that next to the Locus app on the watch also the counterpart on the phone "Wear for Locus" needs a (probably beta) update. And I also had to kill Locus app on the phone to get the new version active, at least only after that everything worked on the watch (Wear OS 1.5 / Home app 2.15).

I did not yet try in a real activity, but from what I can see sitting on the couch, all interesting data can now be configured to the dashboard, and the 4 pages should be enough for all one needs. The one page with only two and thus slightly bigger fonts should be helpful for running / being able to read it while running.

I am just (really) missing one thing: you still cannot switch between map and dashboard using a button, a third button (if existing) that is. Without this, the app cannot be used touch-less. The third button is currently used redundantly in both dashboard (switching pages can also be done with rotating the main button) and map (zooming can be done with rotating) - provided the main button is rotatable of course.
And even if you prefer a button press over turning for switching pages, one direction is enough to easily reach the 4 pages (of course that does not apply to the zoom).
Any chance this can get configurable? (so the one single option in new configuration dialog is no longer that lonely ;) - btw. I wont use this, the Q Explorist does not have its own HR, so I hope the dashboard element will show HR from the phone as long as this option is unused.

Thanks for the update.
If I find new aspects in real use I will check back.

[Edit: of course in dashboard there _is_ only one button to switch pages, the other one is used for pause/start/stop - no idea why I always get confused with this. But it could be used to switch to map as main button rotation can switch dashboard pages, that stays the point.
HR from phone (from belt connected to phone) was shown correctly.
Energy value stays zero all the time (probably on the phone too where I do not have it in the dashboard). At the beginning I always had an energy value in my .tcx tracks, but since quite some time this field is no longer set there, probably the same thing. Dont know how it was calculated when it still was. ]

Danjel Rojka

Hello, I tried again and there is a connection between the clock and the smartphone. I start LocusWear and the setting for heart rate monitoring is activated. I start the track recording on the clock and I don't see a pulse on the individual dashboards on the clock. I can't see anything on the activated dashboard on my mobile phone either. If I take these off I can see that the sensor is active.
After that I started the Polar Trackrecording and after a short moment I get values in the Polar app on the clock. But still no values in LocusWear.

I hope you can find the error. Can I help you figure out the problem?



Hello there!

I tried the new Beta with Locus Map 3.32.2 like Danjel did, and I can confirm that the heart rate monitoring does not work yet unfortunately. The devices are: Xiaomi Mi A1 + Misfit Vapor

What I can see is that the sensor flashes constantly, so it is controlled, if I turn the heart rate monitoring off on the settings page in Wear for Locus Maps then the sensor stops flashing.
I have the heart rate view on the watch on the tracking screen and the value is on constant 0 BPM.

I do not have the Pro version of Locus Map yet.

I would be glad to be able to help, just tell me what report do you need.  :)


Hello guys,
new beta is out. Thank you for all the feedback and testing you have done so far.
I have tried to fix the HRM issues but could not find any reason why it should not work at least according to the documentation and it unfortunately works flawlessly on my Huawei Watch 2. HRM works kind of unpredictably on old Moto 360 but then other apps seem to have trouble too so maybe it is some kind of device problem. Anyway I did some poking around the code, upgraded libraries etc. so please give it a one more try.

@fera @Danjel Rojka
Could you please try it once more with new beta? If things still don't work then please try to uninstall the Wear for Locus Map app, restarting the watch and then reinstalling the app. If it still does not work, could you please enable debug mode and check out HRM debug values? To enabled tap 6 times to the watch on the top of menu drawer (message shoud appear). Then you can choose new HRM(debug only) value in the dashboard (see the included printscreens).
It prints out following information codes
(accuracy):HR:last update before (s) / Locus HR value:last update before (s)
For HR to work the accuracy must be in range 0-3, HR value must be 25 or more and updates should keep coming every 1 - 2 seconds (so third value should be 0 - 2 s). Only after that the Locus HR value can be synchronized.

@H Ifang
Thanks for lots of feedback and tips. Forgetting to update the device part of the add-on is inconvenient. It is unfortunately a property of Android, that the two application are not allowed to communicate when they have different versions. I will try to look into it if I could detect it somehow before attempting to communicate with the add-on itself.
Switching screens by a button is a good idea. I have implemented and tested this feature in the new beta but it is hardcoded to the long press of third user button (ie. 4 button watch configuration) and I now see you have "only" two user buttons and rotary button. Sorry for that, I will probably map it to the 2nd button long press action for the next release.
Anyway user configuration would be the best solution but don't know if such relatively complicated thing could be done on the watch or if it would require phone configuration UI (mapping actions to buttons for each screen on small watch screen could be very confusing and exhausting :/ )
Also button auto-configuration algorithm cannot detect if your watch has rotary input button yet, so for now the rotary input is set the same for everyone and user button detection does not reflect this so this is why you see duplicate actions on your buttons and rotary input and why this is somewhat confusing.

H Ifang

Putting the map/dashboard switch on a button long-press sounds perfect, just did not think about that possibility. Looking forward to get it on lower button (button 3 / second user button as it seems to be called).
Short press -> scroll through dashboard, long press -> go to map (and back).

Btw. which watches have 4+ buttons? I have never seen one with more than 3.

When I wrote about configurable I just had in mind a simple switch to decide about button 3 to switch dashboard pages or between map/dashboard. Of course, a fully flexible user configuration about every detail of (e.g. button-)handling is always best, and everyone who really wants/needs something will gladly go through a bit of configuration, be it on the watch or the phone. But also of course thats nothing with a high prio, and at least for me with 3 buttons (altogether) there currently seems to be no further need for such a thing, if the above noted switching will be implemented. It might be more interesting then for people with only one or two buttons to decide themselves what to do with them.

Danjel Rojka

Hello, Milan,

I uninstalled and restarted the app on the Watch. I did not uninstall the app on my smartphone but on my watch. Then reinstalled. Still no pulse display with values.

Then I activated the debug mode as shown by you and activated the heart rate (debug) in the dashboard.

He shows me the following values as in the screenshot.

That's all I know.



Danjel Rojka

Hello, Milan,

the screenshot does not always show the 3rd value with 4 but it is as you describe at 1 or 2 and also the first value is usually at 3.


Hello Danjel,
thank you for the data, this is very helpful. Basically your screenshot says
2 = medium sensor accuracy (3 is the highest)
64 = your BPM
4 = last sensor reading before 4 seconds
The last two numbers mean that the value of 64 BPM was accepted for synchronization with Locus before 4 seconds.
I will have yet to prepare another debug version, I was focusing on the wrong area - I thought that the sensor reading was the problem but the synchronization seems to actually be the problem. I honestly don't understand where the problem could be, I also use this with Locus Map 3.32.2.

One thing though. Do you by any chance have other HRM devies configured in Locus Map via Ant or BT manager?

Thank you again and have a nice weekend


Hi Milan!

I tried out the new build as well, the HRM was still not shown in the dashboard so I enabled the debug mode.
According to the values seen there, the value gets updated in every 3, sometimes 4 seconds and it looks like it is accepted by Locus for syncing.

I got to say, I still use the free version of Locus Map, could that be a problem? Or I should be able to see HRM value on the watch dashboard without it?

Here are my screenshots, looking for the next build!  ;)

Keep up the good work, this is awesome!

Edit: I unistalled the app both from the watch and the phone, then installed it on the phone, then got the notification "Get Locus map on your watch" on my watch, and installed it by that.

Danjel Rojka

Hello, Milan,
I have configured another sensor. This is the Mio link I connected via Bluetooth. But I also deactivated Bluetooth in Locus for connection with Mio when I started recording. With no other result. And Mio wasn't activated and connected either.