[APP] - version 3.24.+ ( 31. 5. 2017 )

Started by Menion, May 31, 2017, 14:48:21

0 Members and 1 Guest are viewing this topic.

Menion

Ah damn also import of caches does not work, sorry. I'll try to fix it in the evening. If you find any more issues, please write me it here, thanks!!

Sent from my SM-G930F using Tapatalk

- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

balloni55

import .kmz from GD
> merge points with track
> FC > locus restart automaticly

import .gpx from Dropbox or internal SD
> first import ok
> second import > FC
Locus Map Classic 3.62.1 AFA
Locus Map 4.11.1.5 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

alezy

@menion, no, GPS is disabled, zoom is not changing. The old "Edit edit on map" moves map exactly in correct position. If you will add some debug messages/logs I'll may try to help you with catching this problem
  •  

Andrew Heard

@menion, my description of preset/ function panel buttons can't be more detailed? I have attached settings and presets. Maybe related to autohide? Seems easy enough to reproduce here.
LM4.11.1.3 GOLD user ID:142d400c7
  •  

balloni55

#94
minor problem using PRO and Beta

- in all presets of BETA i have "set funktion panels" and "Maps>Map Control Set functions panels" each is visible after click on "edit"

- open "edit" of one preset inside locus PRO and close it without any modification and close PRO
- run BETA, open "edit" of this preset, now  "set funktion panels"  isnĀ“t displayed, reason "Set funktion panels" is unchecked.
- the count of added functions is not modified :)
Locus Map Classic 3.62.1 AFA
Locus Map 4.11.1.5 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

Menion

@Andrew Heard: thanks for a files! Unfortunately I still don't get it. Here is a video where I try exactly follow your steps right after restore your backup & copy presets. So please check it and let me know what you do differently, thanks.
Btw. I'm always pleased to see after restoring of anyone backup, how he was able to customize Locus Map to his needs, nice :).

@alezy: in next Beta version, Locus Map will print some information into system log, so if you try this Beta, just create a log by this method right after problem occurs few times, thanks!

@balloni55 : well presets overwrite it's config files in Locus/data/presets directory quite often and also validate if data inside are valid and remove these that aren't. So your Pro version after open/close preset edit screen, just save current config and also remove all around "functions panels", because these are not valid settings in latest Pro version.
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Andrew Heard

@menion I'm sorry you aren't able to reproduce my problem. On the slow campground WiFi connection I'm unable to view your video either. In your reply to Wolfgang are you saying that if I run the beta then pro my beta preset settings will be lost anyway? I may just wait a few weeks until return from holiday and test with pro. If no-one else has this problem then maybe if I delete all presets and start again it will work, but I don't want to waste all that time right now.
LM4.11.1.3 GOLD user ID:142d400c7
  •  

balloni55

long click on function panel > "Modify panel" work only temporary and should be removed
i know modification has to be done via
Presets/advanced mode/Edit/Set function panels/3-dot >remove, or +
Locus Map Classic 3.62.1 AFA
Locus Map 4.11.1.5 Gold AFA
LMP User ID 7ee4dad32
LM4 User ID e06d572d4
  •  

Menion

@alezy: thanks for a log! Issue in creating a new point should be fixed in next Beta.
Should be in log also something around problem in "moving between points"? Because I see nothing in log around this problem.

@Andrew Heard: no needs to sorry, I really appreciate you are trying to help me with this. Enjoy holidays on 100%, this may waits till you return.

@balloni55: complicated task ... what about people (I believe most of users), who does not use "Presets"?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

slarti76

Quote from: menion on July 18, 2017, 00:11:57
@balloni55: complicated task ... what about people (I believe most of users), who does not use "Presets"?
I'd strongly advise against removing customization options just because they're also doubled in the presets feature. As Menion says, many users, especially beginners, won't use presets, so they'll be put off if they don't find an intuitive way to change the buttons or other settings.
Granted, as is obvious even among us power users, the presets feature is easily mistaken for a "profile" feature and therefore misunderstood. However, it is what it is now and should stay like this - once you understand it, it can be extremely useful. But those who don't use it shouldn't "lose" anything!

alezy

@menion,
QuoteShould be in log also something around problem in "moving between points"? Because I see nothing in log around this problem.
Yes it should. I have send you another report with video
  •  

Menion

Good day guys,
I'm just preparing new Beta version with some nice changes (hopefully). Hope you have fine time!

@alezy: thanks for logs. I do not understand, but in logs is still nothing, weird. I'll have to prepare special version that will print these logs to own file.

@all: if you find a while and if you are working with tracks & folders & track styles, please check and vote here: http://help.locusmap.eu/topic/moving-copying-tracks-doesnt-preserve-line-style , thank you!
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

Andrew Heard

#102
3.24.3.8: can no longer tap on icon in list of points, and have map positioned to point.
@menion recall my issue with preset function panels never retaining correct settings; I have gone to extreme of deleting all my presets (after backup) then defining new presets and independent function panel button combinations, and so far they are working. Of course tedious because pro and beta share same presets.
With route planner: if I tap single point new menu is much better, BUT if I zoom out a little and tap close to 2 points I get menu to select one of the points OR track, but after selecting point no other action, and why should the track be in list?
LM4.11.1.3 GOLD user ID:142d400c7
  •  

Andrew Heard

I am still experiencing issues with presets. Maybe you can reproduce this bug:
backup pro
run beta
delete all presets
add some new presets, different names
exit beta
run pro
do full restore including presets
now observe the pro AND beta presets are displayed
surely a full restore should overwrite the beta presets?
LM4.11.1.3 GOLD user ID:142d400c7
  •  

alezy

#104
@menion, my problem with erratic points movement has gone in last beta.
Some operations like "remove part of a track" or "remove before/after" hasn't ability to undo or simply cancel oration result without saving
  •