[MANUAL] - CUSTOM ONLINE MAPS (updated 25.7.2011)

Started by Menion, November 29, 2010, 14:53:04

0 Members and 1 Guest are viewing this topic.

sebbo

#30
i set up my own tile server with osm data and file strkture

http://xxx.xxx.xxx.xxx/tiles/1/1/0.png
my providers.xml looks like this:
   <?xml version="1.0"?>
    <providers>
       <provider id="1500" type="0" visible="false" required="true" background="-1">
          <name>sebbo</name>
          <mode>background</mode>
          <area>World</area>
          <url><![CDATA[http://xxxxxxxxx/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>
       <provider id="1501" type="0" visible="false" required="false" background="1000">
          <name>sebbo</name>
          <mode>contours</mode>
          <area>World</area>
          <url><![CDATA[http://xxxxxxxxxx/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>
       <provider id="1502" type="0" visible="true" required="false" background="1001">
          <name>sebbo</name>
          <mode>OpenPiste</mode>
          <area>World</area>
          <url><![CDATA[http://xxxxxxxxxxxxxxxx/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>
    </providers>


but when opening locus and browsing the online maps, it doesnt appear!?

any ideas
  •  

Menion

#31
I see wrong background Id in your definition. There should be id of layer you want to use, so 1500 and 1501. If you have then still problem, write me PM with specific values...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

sebbo

#32
im not allowed to send pm :(

so here the details:
http://217.92.52.58/tiles/
providers.xml looks like this now and still not working
   <?xml version="1.0"?>
    <providers>
       <provider id="1500" type="0" visible="false" required="true" background="1500">
          <name>sebbo</name>
          <mode>background</mode>
          <area>World</area>
          <url><![CDATA[http://217.92.52.58/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>
       <provider id="1501" type="0" visible="false" required="false" background="1501">
          <name>sebbo</name>
          <mode>contours</mode>
          <area>World</area>
          <url><![CDATA[http://217.92.52.58/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>
       <provider id="1502" type="0" visible="true" required="false" background="1502">
          <name>sebbo</name>
          <mode>OpenPiste</mode>
          <area>World</area>
          <url><![CDATA[http://217.92.52.58/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>
    </providers>
  •  

Menion

#33
i'm just going out so please try this ...

<provider id="1501" type="0" visible="false" required="false" background="1500">

- use 1500 as background ID if you want to layer with id 1500 be background layer for layer with id 1501. Or I just suggest you to use only one layer without background for testing.

So try for example only this
      <provider id="1502" type="0" visible="true">
          <name>sebbo</name>
          <mode>OpenPiste</mode>
          <area>World</area>
          <url><![CDATA[http://217.92.52.58/tiles/{c}.png]]></url>
          <cooPart><![CDATA[{z}/{x}/{y}]]></cooPart>
          <zoomPart>{z}-8</zoomPart>
          <zoomMin>8</zoomMin>
          <zoomMax>24</zoomMax>
          <tileSize>256</tileSize>
          <extraHeader>Referer#http://locus.asamm.cz/</extraHeader>
       </provider>

"required" is deprecated and "background" is not required ... this should be working fine. If not, I'll look at it tomorrow ...
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

sebbo

#34
looks like working now.
but also looks like is did something wrong on generating my tiles
  •  

sebbo

#35
alright. as my tileserver is working now there is another problem YOU need to fix.

the f*cking  download limit! :D

because its my own server, it doesnt need a limitation.
PLEASE remove the limitation somehow. maybe by adding the ip to a whitelist. or by adding private ip ranges to a whitelist
  •  

Menion

#36
ehh ... you're correct. This is very nice issue indeed ... hell

It's a little problem, how to solve it? hmm ... whitelist is nice but have to be coded into application ... damm
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

sebbo

#37
hope you can find a solution somehow.
else you could send me an older version of locus without the limitation.
  •  

Hirves

#38
Hi

First, thanks for this app.

Is it possible to exclude zoom levels in the middle of range? For example, there is no map in zoom level 20, but 19 and 21 appear.

I have topographic map but only in 3 zoom levels(levels 24-22). Is it possible to mix road map to missing zoom levels(21-12)?
  •  

sebbo

#39
any news on disabling download limit for private servers?
  •  

Menion

#40
seboo, I'm trying to find any simple solution but I have no idea .. what about you?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

InfX

#41
I would like to add an "map.geo.admin.ch" as a custom online map...

It seems to have 256x256 tiles, fetched from "http://tile{n}.geo.admin.ch/geoadmin/ch.swisstopo.pixelkarte-farbe/{z}/000/000/{x}/000/000/{y}.jpeg", referrer is "http://map.geo.admin.ch/ ", zoom range is from 14 to 22 (well, to 26, but those are simply a resize of level 22), n seems to be randomized (i've seen 5,6,7,8 and 9), coordinates - hell knows, i don't know much about how those are usually represented, but it seems like a simple x & y for the tile (NOT a geographic coordinate).

Any hints ?
  •  

marlar

#42
Quote from: "menion"seboo, I'm trying to find any simple solution but I have no idea .. what about you?

You could disable download limitations based on a server response. If a person hosts his own tile server, he should be able to send a customized http response header. Something like: Disable-Tile-Limitations: True.
  •  

Menion

#43
hmm nice idea! seboo is this possible for you?
- Official help (ideas, questions, problems): help.locusmap.eu
- Advanced topics, sharing of knowledges: you're here!
- LM 4 Beta download, LM 4 final download
  •  

sebbo

#44
should be possible somehow. never changed a header on a apache server before but ill try to find a howto
  •