Author Topic: Guiding sound issue  (Read 1555 times)

Offline svartbjorn

  • Premium
  • Apprentice of Locus
  • **
  • Posts: 188
    • View Profile
Guiding sound issue
« on: April 01, 2011, 22:29:26 »
- If I create a track with guiding on, the guiding sound AND the guiding jump to next point are BOTH triggered by the distance value set in Guiding/"Set next point". The value set in Guiding/"Distance for sound" is ignored. I tried with Guiding/"Set next point" = 100 and Guiding/"Distance for sound" = 150. I tested this on three different tracks I created, each with 5-6 points and followed the guiding distance closely. The above happened consistantly for each point. ALSO - there is no sound for the last point (kind of makes sense in this picture, since there is no next point to jump to and sound is (incorrectly) triggered by the "set next point"). I assume the sound is supposed to be triggered by the Guiding/"Distance for sound", even when guiding on a created track (ref below).

- If I enable guiding to one specifically selected point, THEN Guiding/"Distance for sound" is used to trigger the sound.
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11506
  • Thanked: 334 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Guiding sound issue
« Reply #1 on: April 02, 2011, 19:41:09 »
i actually tested this and cannot agree!

"Set next point" is used only for automatical switch to next point

"Distance for sounds" is used only when "Beep when you move too far from track" is setted. Also, distance to determinate if you're too far is computed by:
connect actual target point and previous and connect them with line (not just abscissa). I compute distance from this line!

Sound for last point? Which sound? Beep on next point? Not needed here, no more next points. Beep when too far? Go too far and you'll hear sound

Guiding on one point? There is separate settings for guiding on one point!
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline svartbjorn

  • Premium
  • Apprentice of Locus
  • **
  • Posts: 188
    • View Profile
Re: Guiding sound issue
« Reply #2 on: April 02, 2011, 21:15:46 »
You are referring to a setting called "Beep when you move too far from track". Can't find anything like that in any menu. Is this a new menu entry in a version you have not released yet?

What I noticed is that I got the beep EXACTLY at the same time as the guiding jumped to the next point on the track. Every time. I think I checked about 15 points.  That is fine, I just interpreted the menues differently. So the "Distance for sounds" is only for guiding to one point  and is not used when guiding on a track? Ok, that's fine. Should mention that I create the track with straight lines between the points (i.e. after selecting the track points, I save the track without selcting "Compute Route".

I also tried to pass the point by much more that the distance settings and never got any beep for gone too far (related to the missing menu entry mentioned above?)
« Last Edit: January 01, 1970, 01:00:00 by Guest »
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11506
  • Thanked: 334 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Guiding sound issue
« Reply #3 on: April 02, 2011, 22:51:39 »
look that as in your second issue about guiding, we talk about different version. When I'm saying that something is done after some market release, it's done in new testing version. So please try 1.3.0.3 version from here. It's there
« Last Edit: January 01, 1970, 01:00:00 by Guest »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline svartbjorn

  • Premium
  • Apprentice of Locus
  • **
  • Posts: 188
    • View Profile
Re: Guiding sound issue
« Reply #4 on: April 03, 2011, 11:16:23 »
Tested with 1.3.0.3.

Works great! Very useful and great features! This must be classified as 100% perfect!

From what has been discussed on the forum recently, seems you have implemented all the features people have requested.

Thanks a lot!
« Last Edit: January 01, 1970, 01:00:00 by Guest »