Author Topic: @Menion: Issue with mapsforge writer V4 and V5  (Read 1291 times)

Offline kech61

  • Apprentice of Locus
  • **
  • Posts: 169
  • Thanked: 3 times
    • View Profile
@Menion: Issue with mapsforge writer V4 and V5
« on: December 09, 2014, 12:01:19 »
Hi Menion,

There is an issue with the new MapsforgeWriters.
I posted it here:
https://groups.google.com/d/msg/mapsforge-dev/TeItJ4hdkNc/WTp0LUG6GbsJ
while Ludwig posted the reason here:
https://groups.google.com/d/msg/mapsforge-dev/TeItJ4hdkNc/WTp0LUG6GbsJ

It affects Locus too, while there are no white tiles, the affected Tiles are nearly empty.
Please could you take a look at this issue, it would be fine if you stay compatible with the openandromaps.
The new writer is way faster than the old one and handles complex geometry much better - so i would like to stay with the V5 writer.

Thanks and best regards,
Christian
Best regards/ Grüsse
Christian
www.openandromaps.org
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11486
  • Thanked: 329 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: @Menion: Issue with mapsforge writer V4 and V5
« Reply #1 on: December 09, 2014, 12:44:49 »
Hello Christian,

http://forum.locusmap.eu/index.php?topic=4263.msg33665#msg33665

Unfortunately I already spend on it a few hours, no progress.

EDIT: btw. for testing compatibility with V3 renderers, Locus is not the best way. I already modified quite a lot of rendering system to make it more attached to whole Locus rendering system.
« Last Edit: December 09, 2014, 12:46:33 by menion »
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline kech61

  • Apprentice of Locus
  • **
  • Posts: 169
  • Thanked: 3 times
    • View Profile
Re: @Menion: Issue with mapsforge writer V4 and V5
« Reply #2 on: December 09, 2014, 14:23:54 »
Hi Menion,

For long winter nights her is a good example an GB map:
http://www.openstreetmap.org/#map=13/53.0814/-3.2894

Reported from John Percy:
http://www.openandromaps.org/en/oam-forums/topic/missing-roads-in-uk

I know that Locus uses a most advanced Render-Engine.
The bug seems to be common to all APPs based on V3.
Dont know why it appeared since I use mapsforge writer newer than basic V3.0.0

Anyway, its not that anoying in Locus than on standard V3 implementations.

Best regards,
and thanks that you keep Locus kompatible with my old XperiaActive on Android 2.3...
Christian
Best regards/ Grüsse
Christian
www.openandromaps.org
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11486
  • Thanked: 329 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: @Menion: Issue with mapsforge writer V4 and V5
« Reply #3 on: December 09, 2014, 14:40:05 »
Hmm weird is, that I compared part that reads a data from MapsForge file.

I compared my little bit updated version (not much changes happen here as format of file has to remain same) and latest updates directly in MapsForge GitHub and - they are indentical! I wasn't able to find any serious reason that should cause this. Function that reads data from file simply reports, that for this meta-tile exists no roads. But for same metatile in different zoom level already roads exists. Really weird, but I'm sure, I'll find reason, ... later :)
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline kech61

  • Apprentice of Locus
  • **
  • Posts: 169
  • Thanked: 3 times
    • View Profile
Re: @Menion: Issue with mapsforge writer V4 and V5
« Reply #4 on: December 09, 2014, 17:57:24 »
Hi Menion,

I'm shure that you will find a solution - no need to hurry...

Merry Christmas and a HappyNewYear!
Christian
Best regards/ Grüsse
Christian
www.openandromaps.org