Author Topic: Intent...AUTO_SAVE broken?  (Read 1390 times)

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Intent...AUTO_SAVE broken?
« on: May 30, 2014, 13:07:04 »
Hello!
I'm using tasker to start recording tracks.
Since quite some time the auto save feature seems to be broken. I use it to automatically upload to GPSies after saving the track.

INTENT_EXTRA_TRACK_REC_AUTO_SAVE:true

Can someone please confirm my observations?
As I remember there was some sort of upload threshold until no action it's initialized. How was it defined?

Regards ringen00
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11776
  • Thanked: 409 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Intent...AUTO_SAVE broken?
« Reply #1 on: May 31, 2014, 09:22:27 »
Hello,

I'm checking code and there were no changes last months, so all should work correctly as before.

What happen when you call intent with auto save set to "true"?
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #2 on: May 31, 2014, 09:26:01 »
Thanks for the quick reply!
Nothing happens.
If I knew how many points must be saved until locus finds it worth to upload the track I could make a proof.
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11776
  • Thanked: 409 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Intent...AUTO_SAVE broken?
« Reply #3 on: May 31, 2014, 09:29:55 »
I'm not sure if just one point will save, but at least two will work for sure. You should anyway after succesful safe see at least some notification window
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #4 on: May 31, 2014, 09:42:15 »
Then its broken!
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11776
  • Thanked: 409 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Intent...AUTO_SAVE broken?
« Reply #5 on: May 31, 2014, 09:51:25 »
by "nothing happens" you mean, that Locus even do not save track or just export do not work?

Intent on start record works, "pause" works and just "stop" do not work?
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #6 on: May 31, 2014, 10:38:10 »
Locus saves the track but export doesn't happen.

The rest works fine.
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #7 on: May 31, 2014, 10:45:16 »
Btw: It happens that a new saved track is in the navigation folder but doesn't get recognised (numbers on the right side: e.g. 0/1). If I open and close that folder it changes. -> bug
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #8 on: May 31, 2014, 10:54:54 »
SOLVED!!!
Locus lost it's autosave settings in the recording profile!
Now it works again!
Thanks so much for your quick help!!! Much appreciated!
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #9 on: May 31, 2014, 10:56:06 »
Nicer of course if no settings get lost through updating or if I get a hint in the change log :-)
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11776
  • Thanked: 409 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: Intent...AUTO_SAVE broken?
« Reply #10 on: May 31, 2014, 11:06:19 »
ah perfect. Settings for recording gets lost, because completely whole recording system has changed. There were no other chance
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!
 

Offline ringen00

  • More than Newbie
  • *
  • Posts: 43
    • View Profile
Re: Intent...AUTO_SAVE broken?
« Reply #11 on: May 31, 2014, 11:10:40 »
Just mention it :-)
Btw. I'm missing this feature this quite some time - could be that it already came through the last update.