Author Topic: GPX import/export bug  (Read 479 times)

Offline axstet

  • More than Newbie
  • *
  • Posts: 23
    • View Profile
GPX import/export bug
« on: November 02, 2013, 11:07:17 »
Hi Menion,

sorry to bother you again with GPX stuff but there is still a bug in Locus leading to data loss.

Scenario:

I have a local geocache database and add a waypoint to a geocache. As prefix for this waypoint I choose "L0" because I know that Locus starts creating waypoints with prefixes from "L0" onwards. I export a GPX file from the database and import it to Locus. Everything is fine. Locus shows the geocache with its attached waypoint. I go outdoors and add multiple new waypoints while completing the geocache. Back at home I want to store the waypoints locally to have a full documentation in my database. I export a GPX file from Locus and import it in the database. And now here comes the bug... The very first waypoint I created locally is gone...

I had a look at the GPX file. It contains two waypoints with the prefix "L0" and therefore the same name. The one I created locally and the first waypoint Locus created. Locus does not make sure that the waypoint prefixes / names are unique what they should be.

Cheers, Axel
 

Offline menion

  • Administrator
  • Professor of Locus
  • *****
  • Posts: 11223
  • Thanked: 271 times
    • View Profile
    • http://www.asamm.com
  • Device: SGS7
Re: GPX import/export bug
« Reply #1 on: November 02, 2013, 12:37:42 »
Hi,
  please don't say sorry, if there is a problem, it's needed to fix ... in this case .. fixed ;) will work in next version. I have also added support for export attributes when I was working on GPX export
Ideas, wishes, problems
Advanced topics, public discussion, sharing of knowledges, testing beta versions: you're here!